locked
Site components do not install on remote SQL 2008R2 RRS feed

  • Question

  • We installed SCCM 2012 (RTM) and we seemed to have problems with the site component installation on the remote SQL 2008R2 server. I has tried to install:

    Component server   
    Reporting services point
    Site database server   
    Site system 

    But I can seen only errors on the allerts. Here is one example:

    Error    Detail    ###    8.11.2012 7:12:05    #### SMS_SRS_REPORTING_POINT    1083    Site Component Manager successfully used the SMS_SERVER_BOOTSTRAP_XXX service to run the following program on site system "\\XXX.XX.FI":        \\####\F$\SMS\bin\x64\rolesetup.exe /install /siteserver:XXX.FI    The program failed for the following reason:        The file "\\XXX.XX.FI\F$\SMS\bin\x64\rolesetup.exe" does not exist.    Possible cause: Site Component Manager Does Not Have Sufficient Access Rights To Administer The Site System.  Solution: Verify that the Site System Installation accounts are properly configured to allow the site to administer the site system.    Site Component Manager cannot install component SMS_SRS_REPORTING_POINT until the program runs successfully. If this problem persists, refer to your ConfigMgr Documentation or the Microsoft Knowledge Base for further troubleshooting information.    3856    1596

    I have verified that that exe is indeed available in that path. I can see similar lines for every component it has tried to install.

    I have added the SCCM server machine account to local admins group of the SQL server, but it does not solve the problem.

    I searched this forum (and some other places) but I did not find any help.

    Thursday, November 8, 2012 6:27 AM

All replies

  • Anything in srsMSI.log and srsrpsetup.log on the SQL Server? Do you use Default SQL or Named SQL instance? What about SQL Service. Ist it configured to run with an Domain account? When yes, have you defined SPN for the account?
    Thursday, November 8, 2012 7:50 AM
  • I am sorry but so far I have not been able to find those log-files???

    I am using the named instance mainly because we have SCCM 2007 running on the Default SQL. The service is configured to run on a domain account. It is using different port (1435) as the Default SQL is using 1433.

    I tried to define the SPN, but I am not so sure if it is OK as I did not find an example about Named Instance (if it is different?).

    I forgot to mention that SCCM 2012 is able to store data on the database, the only visible problem is that I can not use reports. Perhaps also there is problems with backups, but I have not yet tried them.

    Thursday, November 8, 2012 8:48 AM
  • Perhaps the problem with the log-files is that the process does not run to that point. I found only svrboot.log:

    ********************************************************************************  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.374-12><thread=1978>
    SMS_SERVER_BOOTSTRAP_XXX started.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.374-12><thread=1978>
    Microsoft System Center 2012 Configuration Manager v5.00 (Build 7711)  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.375-12><thread=1978>
    Copyright (C) 2011 Microsoft Corp.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.375-12><thread=1978>
    Command line: "SMS_SERVER_BOOTSTRAP_XXX SSS F:\SMS /install \\DDD.DD.FI\F$\SMS\bin\x64\perfsetup.exe SMS_MP_FILE_DISPATCH_MANAGER ".  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.375-12><thread=1978>
    Set current directory to F:\SMS\bin\x64.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.375-12><thread=1978>
    Site server: XXX.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.375-12><thread=1978>
    Added machine account XXX to the local administrator group  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.381-12><thread=1978>
    Bootstrap operation failed: The file "\\DDD.DD.FI\F$\SMS\bin\x64\perfsetup.exe" does not exist.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.388-12><thread=1978>
    Disconnecting from Site Server.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.388-12><thread=1978>
    SMS_SERVER_BOOTSTRAP_XXX stopped.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.399-12><thread=1978>
    ********************************************************************************  $$<SMS_BOOTSTRAP><11-08-2012 12:16:12.399-12><thread=1978>
    ********************************************************************************  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.749-12><thread=7D4>
    SMS_SERVER_BOOTSTRAP_XXX started.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.750-12><thread=7D4>
    Microsoft System Center 2012 Configuration Manager v5.00 (Build 7711)  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.750-12><thread=7D4>
    Copyright (C) 2011 Microsoft Corp.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.750-12><thread=7D4>
    Command line: "SMS_SERVER_BOOTSTRAP_XXX SSS F:\SMS /install \\DDD.DD.FI\F$\SMS\bin\x64\rolesetup.exe SMSSRSRP ".  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.750-12><thread=7D4>
    Set current directory to F:\SMS\bin\x64.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.750-12><thread=7D4>
    Site server: XXX.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.750-12><thread=7D4>
    Added machine account XXX to the local administrator group  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.762-12><thread=7D4>
    Bootstrap operation failed: The file "\\DDD.DD.FI\F$\SMS\bin\x64\rolesetup.exe" does not exist.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.768-12><thread=7D4>
    Disconnecting from Site Server.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.768-12><thread=7D4>
    SMS_SERVER_BOOTSTRAP_XXX stopped.  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.779-12><thread=7D4>
    ********************************************************************************  $$<SMS_BOOTSTRAP><11-08-2012 12:16:32.779-12><thread=7D4>

    Thursday, November 8, 2012 10:27 AM