locked
Can't enable and configure RRAS, ICS service problem. RRS feed

  • Question

  • Hi:

    I have the following problem, in RRAS mmc, right clic on servername, enable and configure RRAS, but it says: "ICS (Internet Connection Sharing) is currently enabled on <SERVER>, to configure RRAS, disable ICS and try again".

    Ok, I disabled ICS, tried to configure RRAS, and the same warning pops-up.

    Rebooted the server, and the same results.

    Help please.

    Wednesday, May 16, 2012 4:13 PM

Answers

  • Did you stop the ICS service, and then set it to "Disabled" it so it won't auto start after a reboot? The service shows up as "Windows Firewall/Internet Connection Sharing (ICS)" in the services console.

    Does the server have more than one NIC in it? If so, please check each NIC's properties to make sure ICS was never enabled on one of them. It would be a checkbox that says something similar to "Share this connection," which invoked ICS.

    .

    Also, take a look at your registry
    (reference: http://www.pcreview.co.uk/forums/please-disable-ics-isnt-enabled-t2379443.html)

    HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess
    Look for a key called ConfigurationFlags
    If it has a value of "0", replace, it with "1"
    If the DWORD ConfigurationFlags doesn't exist, create it by making a new DWORD key callled ConfigurationFlags and set the value to "1" Decimal (without the quotes).

    .

    Also check if there are any "Incoming Connections" configured in Network Interfaces. If you see it, delete it.

    .


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008/R2, Exchange 2007 & Exchange 2010, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Wednesday, May 16, 2012 5:25 PM

All replies

  • Did you stop the ICS service, and then set it to "Disabled" it so it won't auto start after a reboot? The service shows up as "Windows Firewall/Internet Connection Sharing (ICS)" in the services console.

    Does the server have more than one NIC in it? If so, please check each NIC's properties to make sure ICS was never enabled on one of them. It would be a checkbox that says something similar to "Share this connection," which invoked ICS.

    .

    Also, take a look at your registry
    (reference: http://www.pcreview.co.uk/forums/please-disable-ics-isnt-enabled-t2379443.html)

    HKLM\SYSTEM\CurrentControlSet\Services\RemoteAccess
    Look for a key called ConfigurationFlags
    If it has a value of "0", replace, it with "1"
    If the DWORD ConfigurationFlags doesn't exist, create it by making a new DWORD key callled ConfigurationFlags and set the value to "1" Decimal (without the quotes).

    .

    Also check if there are any "Incoming Connections" configured in Network Interfaces. If you see it, delete it.

    .


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008/R2, Exchange 2007 & Exchange 2010, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Wednesday, May 16, 2012 5:25 PM
  • Thanks for your answer, yes I had another NIC, although it was disabled, it has that property enabled.

    Now I'm able to start the RRAS Wizard

    Thanks.


    Wednesday, May 16, 2012 6:13 PM
  • You are welcome! :-)

    .


    Ace Fekay
    MVP, MCT, MCITP EA, MCTS Windows 2008/R2, Exchange 2007 & Exchange 2010, Exchange 2010 EA, MCSE & MCSA 2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer
    Microsoft MVP - Directory Services
    Complete List of Technical Blogs: http://www.delawarecountycomputerconsulting.com/technicalblogs.php

    This post is provided AS-IS with no warranties or guarantees and confers no rights.

    FaceBook Twitter LinkedIn

    Wednesday, May 16, 2012 7:51 PM
  • I'm Having this exact same issue and I have tried to all of the fixes you have offered here and had no luck.

    I am working on Server 2019

    One thing that is changing for me, is when I adjust the Registry value to "1" it does change my options when I right click my server name, in the routing and remote access window.  When the value is "0" I right click and "Configure and Enable Routing and Remote Access" is at the top, when I select it, is when I get the ICS error.

    When I change the value "1" as suggested here "Configure and Enable Routing and Remote access" gets grayed out, and the options of "Disable remote access" and "Enable Direct access" become available. 

    Thursday, February 13, 2020 5:05 PM