locked
Any new drivers return "Access Denied" (Vista 64bit) RRS feed

  • Question

  • this is getting really annoy now.

    every single USB / printer device i through at it, it returns an "Access Denied" message like so:


    can anyone PLEASE tell me how to fix this? it was fine when i first installed Vista, and some day, the driver install suddenly stopped working.

    even if i put my own memory stick in a different slot than what i have been using before, it returns "access denied" message.

    i AM the administrator on this computer, and i have turned off UAC.

    btw, i have installed the latest Intel chipset drivers from the mobo DVD, and have flashed mobo to the latest bios revision.

    system spec:
    -Intel Core2Quad q6600 (G0 stepping, at 3.2Ghz cooled by Thermalright Ultra 120 Extreme)
    -Abit iP35 Pro
    -OCZ 4GB 800Mhz RAM
    -PoV nVidia 8800GTX
    -Western Digital 500GB AAKS
    -Corsair Hx 620w modular power supply all in Antec p182 case.
    Tuesday, November 13, 2007 10:51 PM

All replies

  • Hello,

     

    Thanks for your post!

     

    Generally, if many devices stops working and can’t be reinstalled, there may be a conflict or block from a service or a device. please use some steps below to narrow down the problem’s scope:

     

    1.    Try the devices in another machine, ensure that the problem is not caused by damaged devices.

    2.    Confirm whether you installed any device before the problem occurred, uninstall and disconnect it and then check the issue again.

    3.    Perform a clean boot to check whether a 3rd party application or service causes the problem. Please refer to the KB article below:

    How to troubleshoot a problem by performing a clean boot in Windows Vista
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;929135

    If the problem persists, please let me know and I’m happy to be of further assistance. Thanks!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Friday, November 16, 2007 7:50 AM
  • many thanks for your reply.

    1. i am 100% sure the devices in question work in other machines, because i have always been using this memory stick and it always works. even after i can't install it to other USB ports

    2. i have done NOTHING to the computer, it worked perfectly fine, then suddernly bam! try to install a driver, and gets Access Denied message

    3. remember, im no beginner, i built my computer from manufactured parts. so i will always do clean boot with any OS when problem occurs. so no, clean boot unfortunately doesn't solve this problem. safe mode also doesn't fix this problem

    im thinking this could be a user account bug?


    i have momentarily fixed this problem by running update from Vista to Vista. which means re-install all Windows components. and it worked, for now. this Access Denied problem has been with me and this computer for nearly 2 month (when i put it together) i have first installed Vista 32bit, then 64bit, then 32bit and now 64bit twice!
    Monday, November 19, 2007 9:55 PM
  • Hello,

     

    Thank you for your feedback! It is helpful to narrow down the problem’s scope.

     

    Based on my experience, the problem you described may occur if Infcache.1 file in the %Windir%\System32 folder is deleted or corrupted. Please refer to the KB article below:

     

    (KB940199) Error message when you try to install a new hardware device on a Windows Vista-based computer: "Windows encountered a problem installing the driver software for your device"

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;940199

     

    To get to hotfix, you may visit following page (fill the KB Article Number blank with 940199):
    https://support.microsoft.com/contactus2/emailcontact.aspx?scid=sw;en;1410&WS=hotfix

     

    Alternatively, you may contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:

    http://support.microsoft.com/contactus/?ws=support

     

    If the problem still persists or I misunderstood anything, please let me know and I’m happy to be of further assistance.

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

    Tuesday, November 20, 2007 12:57 PM
  • wow, that is really helpful. many thanks.

    as i've said in my past post, i momentarily fixed this problem by re-install Vista.

    but if there's any more of this problem, i'll try that hotfix after a few normal tricks (restart etc)


    Tuesday, November 20, 2007 6:15 PM
  • Hello,

     

    Thanks for your feedback!

     

    I’m happy to hear that the system is running normally now. Your sharing is quite appreciated!

     

    If the problem occurs again and the method I provide doesn’t work, please let me know. I’m pleased to be of further assistance!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

    Wednesday, November 21, 2007 10:54 AM
  • Hi,

    I am having the exact same problem and I have gone and gotten the hotfix, but it doesn't fix my problem. 

    Any other ideas?

    Thanks
    Monday, November 26, 2007 7:21 PM
  •  

    shame it doens't fix your problem. but im sorry that i don't know how to re-mark this thread as un-solved.

     

    have you tryed in Vista, insert the disk you installed with, and then do an "upgrade"? that will re-install all files for Vista, which should fix any problem. (reactivation required)

    Monday, November 26, 2007 7:48 PM
  • Hello Fredyboy10 and WyX,

     

    Thanks for your posts!

     

    I wonder whether the problem occurs again after upgrading, WyX. If it does, and the hotfix doesn’t work, please let me know, I’ll help you to unmark the post and assist you for further troubleshooting.

    If the problem occurs even in safe mode and clean boot, please try steps below:

     

    1.    Ensure whether you’ve installed any application before the problem occurred. Some applications may change important system files, which may caused the problem. Please refer to the following KB article:

    (KB940267) You receive an error message if you try to install a USB device on a Windows Vista-based computer that was upgraded from Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;940267

    Please note: This KB article is applied to Windows Vista-based computer upgraded from Windows XP.

    2.    Fredyboy10, please let me know the model of the motherboard you’re using; Besides, have you seen the exactly same prompt window as the one described in WyX’s post.

    3.    Check if there are some unsigned drivers that may cause the problem.

    Start – in Start Search, type sigverif, press Enter – Follow the wizard to scan for unsigned drivers.

    4.    Insert the a USB drive. After seeing the error prompt, open Event Viewer (eventvwr.msc), then try to find error logs about accessing in: Applications and Services LogsMicrosoftDriverFrameworks-UserModeOperational; Windows Logs – System.

    If there are some error logs written when you plugged in the USB drive, please let me know the details.

     

     

    Thanks!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Wednesday, November 28, 2007 2:09 AM
  • Hey Lionel,

    I'm having the exact same issue with Vista x32 when installing any new drivers, though updating current drivers works fine.

    Safe mode makes no difference and I'm on the latest Chipset and BIOS on a Gigabyte P35-DS3R motherboard.
    Thursday, November 29, 2007 7:48 AM
  • Hi FJP,

     

    Thanks for your post!

     

    If you are encountering the exactly same problem just like the first post in this thread. Please refer to the methods I provided in my replies above. If they do not work in your scenario, please go on using steps below:

    Please note: the following KB article I suggested is important in such issues:

    (KB940267) You receive an error message if you try to install a USB device on a Windows Vista-based computer that was upgraded from Windows XP

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;940267

     

    1.    For Gigabyte P35-DS3R motherboard, please install all the updated drivers in the following page:

    http://www.gigabyte.com.tw/Support/Motherboard/Driver_Model.aspx?ProductID=2543

    2.    If you are a domain user, please contact the domain administrator to confirm if there is a group policy that restrict the installation of devices.

    3.    If possible, please remove all USB devices (including USB keyboard and mouse), then check this issue with problematic USB drives again.

    4.    If the problem persists, please refer to the following KB article to check the Mf.sys file:

    (KB926171) You cannot install a device that requires the Mf.sys device driver in Windows Vista

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;926171

     

    5.    If you are a member of administrators. Enable built-in Administrator account, and enter safe mode with this account.

    Run Command Prompt as administrator, use the following command to enable built-in administrator:
    net user administrator /active:yes

    The test above is a little complex but very important to troubleshoot the issue. Thanks!

    If I misunderstood anything, please let me know.

    Important Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Friday, November 30, 2007 8:58 AM
  • this problem have returned!

    after christmas, i tryed to put some photo onto my computer, i've never used this camera with my computer, so this is the first time i plug this camera in, which means require to install device driver.

    i have installed the hotfix KB940199, restarted, but not working. i've followed the Mf.sys article, and it still doesn't work. i've also logged in as administrator, and tryed to intall, still "access denied" when try to install its device driver.

    any other suggestions?

    this is a "Access Denied" message, so could there be something wrong with user accounts? i've only got 1 active user account, set as administrator.
    Wednesday, December 26, 2007 12:20 PM
  • hello? any solutions? just bought a new memory stick, still getting "access denied" message.
    Thursday, January 31, 2008 3:05 PM
  • Hi,

    I am also having the same problem with Windows Vista Business 32bit
    I am trying to install the Drivers for a new 22inch monitor - I have the lastest drivers, and the driver disk.

    There is a problem each time I boot up where the screen changes size, and the Start bar is outside the screen view area (1680 x 1050), My graphics card has the latest drivers - and supports much higher than this screen : Nvidia Quadro FX570 graphic design card.


    Each time I have tried to install the drivers Vista has the following error: "Windows encountered a problem installing the driver software for your device"

    Access is Denined

    Both the Screen and PC are brand new - clean install of Vista Business on the PC 1 week ago.

    I have gone though the process above:
    Turned off UAC - and ensured that I am logged in as administrator
    Tried to update drivers in safe mode (still errors)
    Installed hotfix 940199 (still errors)
    Tried the device on my old machine (works fine on old machine)
    There are no unsigned drivers.

    Each time I turn the PC on it tries to update the drivers automatically but fails, I have to re-adjust the screen resolution each time the PC is turned on also ie change 1680x1050 to a different res, and then reset to 1680x1050 to get the start bar to fit on the screen.

    Please let me know if there is a fix to the above problem yet - thanks.

    Sunday, August 31, 2008 11:53 PM
  • I have a similar situation... My problem has to do with USB hardware drivers... ANY usb hardware driver.
    I recently bought a new usb-hub and decided to connect it to my pc. It said it had found the drivers but couldnt install it... what it said was: 'Acces Denied'. So the driver was found, but somehow couldnt be installed. Ok, at that time I thought it might have to do with the new hardware. As I didnt really needed it (and was a part of a monitor, go figure) I just ignored it... Until yesterday that is...

    I had to disconnect my pc at that point and after plugging all the cables back in, the usual new hardware has been found popped up from the tray... It was trying to re-install all the USB devices, because I hadnt (apparently) plugged them in in the same ports (because that shouldnt be necessary, it's plug & play... right ;) )
    WRONG... with all my devices (except one USB port), I kept getting the same message... 'Drivers has been found but could not be installed. Acces Denied'.

    WTH?

    The strange thing is, I know for a fact that they still work, because:
    a) the hardware is recgonized, just the drivers are not being installed.
    b) in the bios I see all the usb ports and my keyboard works on a port, that doesnt work in Vista.
    c) the USB hardware (mouse, keyboard, and lots of other stuff) does actually work on other PC's

    Did I mention I run Vista Home Premium, 64 bits...

    I'm on the brink of reinstalling, but I fear it will come back anyway. I will have a look at the event logs this evening.
    Tuesday, March 31, 2009 8:21 AM
  • Same problem here!! Unfortunately the helpful links Lionel Chen posted before are no longer active so I cant get the hotfix he mentions. 

     

    Anyone with a solution please let me know, I cant use storage devices, my camera, printer... anything! 

     

    Grrr dont you just love Vista.

    Saturday, March 20, 2010 6:56 AM
  • I had the same problem with my brothers laptop... Access denied installing driver to audio.

    It turned out that his anti virus Kaspersky is causing the trouble, I had him uninstall the antivirus (Kaspersky, which to my opinion is too restrictive of everything) and replace it with  the more manageable Eset NOD32 (actually, I think I just know the quirks of this one, I am too lazy to try and figure out Kaspersky).

    Then, try and install the driver being denied access...it should now work...I hope (at least it did for me)

    P.S. you need an anti virus, I just dont like Kaspersky really, it has caused all sorts of problems in my lifetime...from too much internet restriction to installation of application to installation of drivers, etc etc...In the end you could install Kaspersky again after the driver install or try another antivirus, its up to you.

     

    Sunday, October 31, 2010 12:59 PM