none
az ml command not working on ML Server on Windows 2016 RRS feed

  • Question

  • I am new to ML Server. We just installed ML Server 9.3.0 on Windows 2016. After installed, we tried Administration Utility for ML which opens a cmd with admin permission to run command "az ml --help", it gave error message: 'ml' is not in the 'az' command group.

    My understanding is that, in ML 9.3, we c use CLI ( az ml) to configure ML Server. But I could not get CLI work in the first step. Any help would be really appreciated.

    Lin Zhang

    Wednesday, August 15, 2018 2:32 PM

All replies

  • Did you bootstrap the node first?  There is this shortcut command:  az ml admin bootstrap

    If that doesn't work, there is a slightly longer version:  az ml admin node setup --onebox --admin-password <Password> --confirm-password <Password>

    The doc that explains the steps is this: https://docs.microsoft.com/en-us/machine-learning-server/operationalize/configure-machine-learning-server-one-box#how-to-configure


    Heidi Steen (MSFT)

    Wednesday, August 15, 2018 4:04 PM
  • You might need to add the CLI extension manually.

    Please look here:

    https://docs.microsoft.com/en-us/machine-learning-server/operationalize/configure-run-diagnostics#az-error-argument-command_package-invalid-choice-ml

    Wednesday, August 15, 2018 4:31 PM
  • Thanks for the reply. I have read this document many times and the links in the document. I have also tried the steps to follow instruction such as:

    az ml admin setup --onebox --admin-password  <pw> --confirm-password <pw>

    it gives the same error: 'ml' is not in the 'az' command group.

    Have you or anyone actually make your ML Server configuration work based on this document? I have read it many times for the last couple of days. I don't know what is missing here.

    Thanks.

    Lin Zhang

    Wednesday, August 15, 2018 5:42 PM
  • The commands work for me.  You're not on Windows 10 or a client OS by any chance?  The operationalization features aren't supported on a client OS.

    <edit> Sorry I just realized the title of the issue specifies Windows Server 2016. Did you try the workaround posted by Efrat? It's not common, but its possible the module isn't installed.


    Heidi Steen (MSFT)


    Wednesday, August 15, 2018 7:00 PM
  • No, I have not read or found any workaround posted by Efrat. Could you please give me more details or where to find it? 
    Wednesday, August 15, 2018 7:22 PM
  • Her post is earlier in this thread.  She thought this link might help:  https://docs.microsoft.com/en-us/machine-learning-server/operationalize/configure-run-diagnostics#az-error-argument-command_package-invalid-choice-ml


    Heidi Steen (MSFT)

    Wednesday, August 15, 2018 8:17 PM
  • Hello,

    > "az ml --help", it gave error message: 'ml' is not in the 'az' command group.


    This means the azure-cli extension is not installed. To resolve this just re-add the extension:

    az extension add --source '.\Program Files\Microsoft\ML Server\Setup\azure_ml_admin_cli-0.0.1-py2.py3-none-any.whl' --yes

    There is no need to reinstall the product. 


    Note, this can happen from time-to-time because in general azure-cli extensions are installed to the user's home directory under `.azure/cliextensions` so if for some reason the user installing the product (hence also the admin extension) is not the root/admin then there can be this discrepancy. This use-case/issue has been resolved in the next release.

    Lets us know how it goes.

    Regards,

    Sean

    Friday, August 17, 2018 5:26 PM