locked
2008R2 - Group Policy Preferences - Scheduled Task XP RRS feed

  • Question

  • I am attempting to use Server 2008R2 Group Policy Preferences to create a scheduled task for Windows XP computers. The Windows XP computers have KB943729 Client Side Extentions installed. I have created several preferences for the XP machines, which all work, but the Scheduled Task does not. I am creating a New Scheduled Task. I am not creating a Scheduled Task for Vista or later. I create both Computer and User task, attaching them to the appropriate container. The task I create does not run or appear in the Scheduled Task pane on the XP computer. All other group policy settings are working correctly.

    I have also viewed HKLM\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\GPExtensions on the XP machines and verified thatHKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\GPExtensions\{AADCED64-746C-4633-A97C-D61349046527} exist and shows Scheduled Task.

    Also, the time is showing as one hour behind. I attempted to install the 2008 hotfix for this issue but it says my 2008R2 is not compatible.

    What could I be doing wrong?

     

     



    • Edited by BDCMSFT Friday, February 3, 2012 6:09 PM
    Friday, February 3, 2012 6:00 PM

Answers

  • I was able to get it working myself. I found that if any field is incorrect (for example, username and password) that it will not allow the task to be created on the machine. I also noticed that the scheduled task only will show up for a user who has security rights, which by default is System and Administrator. If you log into Administrator on the machine receiving the policy, you will see the Scheduled Task, as long as all fields are correct.

    So for my policy I set

    Run: shutdown.exe

    Arguments -s

    Username: Administrator:

    Password: ########

    When you view the task on the machine receving the policy, the path to shutdown.exe is automatically filled in for you, for some reason.


    • Edited by BDCMSFT Tuesday, February 7, 2012 4:45 PM
    • Marked as answer by BDCMSFT Thursday, February 9, 2012 1:39 AM
    Tuesday, February 7, 2012 4:43 PM

All replies

  • You need to specify the Run and Arguments in Scheduled Task..

    Run: C:\Windows\System32\defrag.exe
    Arguments: C:


    MCSE Certified
    Saturday, February 4, 2012 5:55 AM
  • So if I want to create a shutdown task, I typed in Run c:\windows\system32\shutdown.exe. I tried adding the /s to the end of the Run entry, as well as in the Arguments section, and neither allow the task to appear on the computer. I tried Run: Shutdown.exe and Start in: C:\windows\system32 then specificed argument /s. Could you provide an example using the details I provided? Thanks.
    • Edited by BDCMSFT Tuesday, February 7, 2012 2:16 AM
    Tuesday, February 7, 2012 2:15 AM
  • Hi,

    Thanks for your posting.

    Following your description, I did some test in my lab environment. My Group Policy Preference scheduled task applied on XP pc
    successfully and run follow specified time. But we can’t find scheduled task from local Scheduled Tasks management console. Maybe it’s by design, since Group Policy Preference in designed after XP, but we don’t find official support from Microsoft website.

    Follow the information you provided, I create a
    Scheduled Task-->Action: Create-->Name: shutdown PC-->Run: C:\Windows\System32\shutdown.exe-->Arguments:
    /s /t 60-->Enabled (scheduled task runs at a specified time).-->Schedule tab-->set time

    For more information please refer to following MS articles:

    Scheduled Tasks Extension
    http://technet.microsoft.com/en-us/library/cc770904.aspx
    Configure a Scheduled Task Item
    http://technet.microsoft.com/en-us/library/cc725745.aspx

    Lawrence

    TechNet Community Support

    Tuesday, February 7, 2012 9:19 AM
  • I was able to get it working myself. I found that if any field is incorrect (for example, username and password) that it will not allow the task to be created on the machine. I also noticed that the scheduled task only will show up for a user who has security rights, which by default is System and Administrator. If you log into Administrator on the machine receiving the policy, you will see the Scheduled Task, as long as all fields are correct.

    So for my policy I set

    Run: shutdown.exe

    Arguments -s

    Username: Administrator:

    Password: ########

    When you view the task on the machine receving the policy, the path to shutdown.exe is automatically filled in for you, for some reason.


    • Edited by BDCMSFT Tuesday, February 7, 2012 4:45 PM
    • Marked as answer by BDCMSFT Thursday, February 9, 2012 1:39 AM
    Tuesday, February 7, 2012 4:43 PM