locked
Export and Import of VM from one Hyper V Host to another Hyper V Host done. But VM not Powering ON on Intial Host RRS feed

  • Question

  • I exported VM from one Hyper V Host (Windows Server 2012 R2) to another (2nd ) Hyper V Host (Windows Server 2012 R2) and then I Imported the VM on the 2nd Hyper V Host using the Option : 'Register the virtual machine in-place (use the existing unique id). It got created and is Powering on successfully but when i switch it off and try to Power ON the same VM on the first Hyper V Host then it is failing and giving me an error : 'Microsoft Emulated IDE Controller Error(Instance ID 83F863B-8DCA-9EDA-2CA8B33039B4): Failed to Power on with Error 'The process cannot access the file because it is being used by another process .'." 

    I checked  both the VMs and there are using their own separate Vhd's saved separately on both the hosts. Kindly suggest as powering ON the VM on the intial Host (1st Host) is very important. I even deleted the VM on second Host and tried powering on the VM on 1st Host but it still gave me the same error.

    Looking forward to hear from you.

    Sunday, June 10, 2018 5:02 PM

All replies

  • Hi!

    Try removing the virtual DVD drives from the VMs.  It sounds like it is not able to access them both.  Check if they can power on after the DVD drives have been removed.

    Best regards,
    Leon

    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Sunday, June 10, 2018 5:19 PM
  • Dear Leon,

    On both the Hyper V Hosts, i have removed the DVD Drives for the VM. Still i am not able to power it ON on the initial (1st) Hyper V Host. Even though VMs on both Hyper V Hosts have separate vhds.

    Kindly advice accordingly.

    Monday, June 11, 2018 2:16 AM
  • Try doing the following:

    1) Make sure the VM you want to export has no .avhdx files (snapshots).

    2) Create a new export of you VM.

    3) Once the export has been created, copy the exported folder to another location (to be sure the files are not being locked).

    4) Import the VM and create a new identifier (uniqueID).

    See if it works.

    Also if this doesn't work you can create a new VM (with same specifications) and then attach the .vhdx files.


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Monday, June 11, 2018 4:32 AM
  • Dear Leon,

    Thanks for the related information. This has been very helpful.

    Regards,

    Vikram.

    Wednesday, June 13, 2018 10:55 PM
  • You're welcome, did you get it solved?

    If you found this helpful don't forget to mark as helpful or as answer.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Wednesday, June 13, 2018 11:09 PM