locked
Prompted for credentials when using anonymous access on extended Web App RRS feed

  • Question

  •  

    I have a Moss 2007 Web Application (http://internal) using Windows Authentication (default zone), and has been extended to the Internet zone (http://external) using Anonymous Authentication

    Within Central Admin I have enabled 'Anonymous' for the Internet zone under authentication providers and also at the site collection level (i.e Site Actions > Site Settings > Modify All Settings > Advanced Permissions > Settings > Anonymous Access. (set to 'entire set')

    All authenticated users can successfully access all areas of http://internal, and anonymous users can successfully open the http://external homepage.

    However, there are three links to document libraries on the http://external homepage and when an anonymous users tried to access these, they are prompted for domain credentials.

    There is no broken inheritance in terms of permissions and I can confirm that the anonymous access is being applied at the document library level of http://external.

    Does anyone have any suggestions? I think I may need to apply a Web App policy.

    Thursday, July 26, 2012 2:01 PM

Answers

  •   Even though inheritance wasn't broken originally, I've had to recreate each library individually, break inheritance and then apply anonymous at the library level - even though the entire site is set for anon.

    • Marked as answer by adam5132 Monday, October 1, 2012 9:16 AM
    Friday, July 27, 2012 8:08 AM

All replies

  • I suggest to use fiddler to find out which url specifically asks for authentication. It is quite possible that you are accessing a page that shows an image or data that is located in another document library or list for which anonymous access is not enabled

    Dirk Van den Berghe

    Friday, July 27, 2012 7:49 AM
  •   Even though inheritance wasn't broken originally, I've had to recreate each library individually, break inheritance and then apply anonymous at the library level - even though the entire site is set for anon.

    Friday, July 27, 2012 8:08 AM
  •   Even though inheritance wasn't broken originally, I've had to recreate each library individually, break inheritance and then apply anonymous at the library level - even though the entire site is set for anon.

    • Marked as answer by adam5132 Monday, October 1, 2012 9:16 AM
    Friday, July 27, 2012 8:08 AM