locked
Missing 33 GB of HDD space RRS feed

  • Question

  • Hi everyone,

    I have a problem with a toshiba laptop running Vista Home.
    There is a harddrive inside of approx. 120 GB, with 3 partitions
    partition one is EISA or something of 1.5 GB probably some system related partition for toshiba.
    Partition two is the C: of 55 GB with the OS and program files
    Partition three is the E: of 55 GB with nothing on it.

    Explorer is telling me that there's only 2GB of free space left on the C:-drive.
    I've selected all the folders and files under the c: root in administrator mode with hidden files and folders unhidden and system files shown. This totals to approx. 20 GB. So there's some 33 GB of HDD space missing?

    I've googled and checked the System Restore space. There was no data in that, I've even disabled the System Restore to see if any space was coming free, but there wasn't any.

    Maybe there is something I missed and you can help me see?

    thx!

    regards,

    Dave
    Sunday, October 12, 2008 11:59 AM

Answers

  • Hi Dave

     

    The 'missing' space is likely being taken up with System Restore. The restore points are kept in the System Volume Information folder which is, by necessity, a 'super hidden' folder that does not get counted when you try to determine disk space by selecting all of the files on the System Volume drive.

     

    I know you said that you disabled System Restore, but try the following.

     

    Here is how you can recover this space and prevent this from happening again.

     

    Use Disk Cleanup to delete all but the latest System Restore Points.

     

    Go to Start and type  cleanmgr.exe   in the Search Box.

    Press Enter.

    In the Disk Cleanup dialog:

    Select Files from all users on this computer.

    Click the C: drive and click OK.

    The wizard will take a minute or more to audit the files.

    Leave all of the default check boxes selected.

     

    Click the More Options Tab.

    In the System Restore and Shadow Copy section, select the Clean Up button.

    In the confirmation box, select the Delete button.

    Click OK.

     

    After Open Windows Explorer and check the properties, used and free space, of the System Drive. You should see a huge increase in the free space.

     

    Next, you need to restrict the amount of disk space that is allocated to System Restore.

     

    By default, Vista will allocate 15% of the entire system volume or 30% of the free space on that volume for system restore and shadow copy.

     

    **NOTE: All of the following commands should be entered exactly as shown, including the spaces.

     

    Go to Start / All Programs / Accessories, right click the Command Prompt and select Run as administrator.

    Click Continue on the UAC prompt.

     

    To see the currently allocated space available for System Restore, enter this command.

     

    vssadmin list shadowstorage

     

    Press Enter.

     

    The output will look similar to the following.

     

    Used Shadow Copy Storage space: x.xxx GB
     
    Allocated Shadow Copy Storage space: x.xxx GB
      
    Maximum Shadow Copy Storage space: xx GB

     

    I recommended 'maximum size' be set to no more than 5% of a system volume that is 100GB or less and 4% of any system volume over 100GB.

     

    To change this, enter the following command.

    vssadmin resize shadowstorage /For=C: /On=C: /MaxSize=xxGB

     

    Press Enter.

     

    This command assumes that "C:" is the system volume letter and "xx" is the maximum size you wish to set.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Sunday, October 12, 2008 11:16 PM
    Moderator

All replies

  • Hi Dave

     

    The 'missing' space is likely being taken up with System Restore. The restore points are kept in the System Volume Information folder which is, by necessity, a 'super hidden' folder that does not get counted when you try to determine disk space by selecting all of the files on the System Volume drive.

     

    I know you said that you disabled System Restore, but try the following.

     

    Here is how you can recover this space and prevent this from happening again.

     

    Use Disk Cleanup to delete all but the latest System Restore Points.

     

    Go to Start and type  cleanmgr.exe   in the Search Box.

    Press Enter.

    In the Disk Cleanup dialog:

    Select Files from all users on this computer.

    Click the C: drive and click OK.

    The wizard will take a minute or more to audit the files.

    Leave all of the default check boxes selected.

     

    Click the More Options Tab.

    In the System Restore and Shadow Copy section, select the Clean Up button.

    In the confirmation box, select the Delete button.

    Click OK.

     

    After Open Windows Explorer and check the properties, used and free space, of the System Drive. You should see a huge increase in the free space.

     

    Next, you need to restrict the amount of disk space that is allocated to System Restore.

     

    By default, Vista will allocate 15% of the entire system volume or 30% of the free space on that volume for system restore and shadow copy.

     

    **NOTE: All of the following commands should be entered exactly as shown, including the spaces.

     

    Go to Start / All Programs / Accessories, right click the Command Prompt and select Run as administrator.

    Click Continue on the UAC prompt.

     

    To see the currently allocated space available for System Restore, enter this command.

     

    vssadmin list shadowstorage

     

    Press Enter.

     

    The output will look similar to the following.

     

    Used Shadow Copy Storage space: x.xxx GB
     
    Allocated Shadow Copy Storage space: x.xxx GB
      
    Maximum Shadow Copy Storage space: xx GB

     

    I recommended 'maximum size' be set to no more than 5% of a system volume that is 100GB or less and 4% of any system volume over 100GB.

     

    To change this, enter the following command.

    vssadmin resize shadowstorage /For=C: /On=C: /MaxSize=xxGB

     

    Press Enter.

     

    This command assumes that "C:" is the system volume letter and "xx" is the maximum size you wish to set.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Sunday, October 12, 2008 11:16 PM
    Moderator
  • Thx for the advise.

     

    I tried the things you suggested. I'm seeing no system restore points available.

    The vssadmin list shadowstorage command is giving me something like "there no records that match your query".

    I don't think that system restore is responsible, but I will double check.

     

    Monday, October 13, 2008 7:57 AM
  • Are you using NTFS or FAT partition? there could be additional loses due to cluster size of formating option selected - http://www.pcguide.com/ts/x/comp/hdd/spaceMissingSpace-c.html

    Monday, October 13, 2008 10:03 AM
  • The drive is partitioned with NTFS

     

    Monday, October 13, 2008 11:22 AM
  • on a suggestion from a colleague at work I installed treeSize.
    Found 33 GB of movies under the account of the daughter of the family.

    Strange that it didn't show up in windows explorer when running it as administrator
    Sunday, October 19, 2008 9:00 PM
  • user="dgovaerts"]on a suggestion from a colleague at work I installed treeSize.
    Found 33 GB of movies under the account of the daughter of the family.

    Strange that it didn't show up in windows explorer when running it as administrator

     

    Hi

     

    That is very strange?

     

    It would be interesting to know the exact path where those files were located and what attributes and permissions were applied to those files.

     

    Anyway, I'm glad you were able to reolve the problem.

     

    Regards,

     

     



    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Monday, October 20, 2008 5:51 PM
    Moderator