none
SCVMM - Cannot add Hosts / Nameresolving Problems

    Question

  • Good Morning!

    As the final part of my apprenticeship, the final project, I try to assimilate VMM in my company. The software is installed on a fresh Win2012 VM-Server (SCVMM 2016 as well as SQL). It will be used practically (!) and I already tried to add hosts after the installation worked.

    The clusters I should add are constantly running and host the whole infrastructure like AD etc...

    After several installation problems I solved the installation with success and was in an upbeat mood to complete the project in a few little hours, but now I stuck at the adding process.

    Everytime I try to add hosts and cluster I get the error 2944: "vmm is unable to complete the requested operation because the server name could not be resolved."

    The cluster and hosts are added, but the hosts are still pending and not accessible. Strangly the VMM agent is installed and working on.

    So first of all I check the name resolving and accessibility in both directions. The SCVMM Server and the hosts know each other, I can ping them and the name resolving works. So I double-checked that the SCVMM is registered to the DNS and it is.

    On my next step I get sure that the SPN is registered, cause I didnt install the VMM with a domain admin account, so I followed the steps Microsoft suggest, but it didnt change a thing.

    Finally I got to the idea IPv6 is not enabled. So I ask my minder and he told me that they disabled IPv6 cause there were problems with several software in use.

    Is it a remote possibility SCVMM needs IPv6 to run properly? If yes, is there a opportunity to disable the use of IPv6 and just using IPv4? Or am I of the track with my thoughts and you got any other idea whats the problem is here?

    I apologize for my bad english. It is a foreign language for me :-)

    Best regards,

    Kevin Krauss

    Wednesday, September 27, 2017 7:18 AM

All replies

  • Hello Kevin,

    You can just disable IPv4 on SCVMM server.

    Additionally, please make sure that the ports mentioned in the article below has been allowed in the firewall on the hosts. Just for ease, you also can turn off the firewall on the hosts.

    https://docs.microsoft.com/en-us/system-center/vmm/plan-ports-protocols

    Best regards,

    Andy Liu


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 28, 2017 2:52 AM
  • Huh?


    -=Chris

    How does disabling IPv4 help?

    I have a similar issue but don't care enough to get a response from MS to create a new ticket.  I can see the amount of assistance I'd find already.

    I have servers A,B,C.

    A has VMM

    B has VMM Console

    C has Hyper-V

    I change the IPv4 IP of C.  IPv6 is disabled on all machines via GPO in the registry and manually on each NIC.

    VMM can no longer see the host and throws error

    Error (2944)
    VMM is unable to complete the requested operation because the server name myserver could not be resolved.

    Recommended Action
    Try the operation again. If the problem persists, contact your network administrator.

    I fire up powershell and remotely run ipconfig /flushdns and ping <mymachine> and it works.  Ping works.

    I go back to VMM and run refresh, same 2944 error.

    I restart the VMM services on the Hyper-V host and on the VMM server, same error.  huh?  Everything BUT VMM knows the right IP of this server and connect to it.  This has been 15 minutes.  DNS TTL is 2 minutes.  We're all looking at the same DNS server.

    It doesn't work until I actually login to B and run VMM.

    Where are you caching name resolution that IPCONFIG /FLUSHDNS and a restart of VMM agents and SCVMMService don't clear this issue?

    • Edited by Progent.CT Thursday, June 28, 2018 10:25 PM
    Thursday, June 28, 2018 10:14 PM