locked
Disable "Automatically adjust microphone settings" in Skype for Business client RRS feed

  • Question

  • Need to disable the "Automatically adjust microphone settings" in Skype for Business client.

    This option is available in "Skype" but not "Skype for Business".

    This is needed if you use SfB in a noisy or call center environment.

    If you use SfB certified headsets with the best microphone noise cancellation it made useless, since the volume is adjusted in windows sound settings automatically by SfB.

    This issues is not isolated and we see it in Lync 2010 -Lync 2013, in Windows 7, 8, 10, SfB certified Jabra, Plantronics, etc devices, and has nothing to do with the drivers or the settings in Control Panel => Sound => Recording => Device Level.  It's always overridden when you start SfB call.

    This features has been added in Skype but wasn't added in SfB up till now.

    Even if you untick all options under: Sound=> Recording => Advance => Exclusive Mode. SfB still overrides the microphone level. All the other suggestions online doesn't fix this limitation in SfB. I see this request come from Lync 2010 days and is still requested today.

    This is really bad/unworkable scenario in call center(RGS) environment when the microphone level auto adjust when you make SfB calls, the clients clearly hears all the adjacent agents speak.

    Most other call center software also this 'disable' feature enabled by default.

    What is the workaround, where to start, can it be fixed with code and how, is there add-ons available, when will Microsoft add this option?

    Wednesday, August 12, 2015 12:05 PM

Answers

All replies

  • If you're referring to the auto adjustment of microphone levels in S4B and Lync, then there's no great workaround that I'm aware of, yes it's very annoying, and Microsoft hasn't announced a date to change it. Letting them know at http://www.skypefeedback.com/ is your best bet at this time. 


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    • Marked as answer by wiellighSA Thursday, August 13, 2015 3:04 PM
    Wednesday, August 12, 2015 3:00 PM
  • Hi,

    It is by design for this version of Lync/SFB client and there is no way to change this setting naturally.

    You can feedback with the link Anthony Caragol provided above. Also, you may need to custom your own SFB client, you can post the question on MSDN SFB SDK forum. Thank you for your understanding.

    https://social.msdn.microsoft.com/Forums/office/en-US/home?forum=communicatorsdk

    Best Regards,

    Eason Huang


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Eason Huang
    TechNet Community Support

    Thursday, August 13, 2015 1:49 AM
    • Edited by wiellighSA Thursday, August 13, 2015 3:21 PM
    • Marked as answer by wiellighSA Thursday, August 13, 2015 3:21 PM
    Thursday, August 13, 2015 3:17 PM
  • I gave it 3 votes as this is a common issue.

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    This forum post is based upon my personal experience and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, August 13, 2015 3:26 PM
  • There is a simple solution to this, nothing more than adding an option to disable auto mic gain adjustment to Skype via a single registry key:

    1. In regedit, go to: Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Lync
    2. Add a DWORD: ShowAutomaticGainControlOption
    3. Set it to 1
    4. Restart Skype for Business

    Now, in Skype for Business under Tools -> Options -> Audio Device, you'll see a new checkbox "Automatically adjust microphone volume on calls."  By default, it's checked. Uncheck it.


    Colin

    Tuesday, November 27, 2018 5:11 PM
  • Thanks Colin
    Thursday, November 29, 2018 2:47 AM
  • This does not work. I have tested both the DWORD value for showing the option and the DWORD value for just straight up disabling the auto gain control. Skype for business STILL turns my microphone down. 
    Sunday, March 29, 2020 1:28 AM