none
Mailstore DB increase not taking effect RRS feed

  • Question

  • Hello,

     

    I'm using exchange server 2003 sp2.

    The mailstore DB limit is defaulted at 18 gigs. I've tried to increase the size to 75gbs, but exchange is still showing the limit of 18 gbs.

     

    Any idea on why this is and also how I can fix it?

     

    Thanks

     

    Ken

    Tuesday, January 31, 2012 5:30 PM

Answers

  • Make sure that you have got the registry key exactly right. If you have copied and pasted it then it is easy to put in an extra space at the end. The most common reason I see that this doesn't work is because the key isn't right.

    After making the change you need to restart the information store service for the change to take effect. Another server will have nothing to do with it, because this is a per server setting.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Tuesday, January 31, 2012 9:35 PM

All replies

  • Hi Ken

    Did you follow the steps in this article: http://support.microsoft.com/kb/912375?

    Cheers, Steve

    Tuesday, January 31, 2012 7:29 PM
  • steve,

     

    thanks for the response.

     

    Yes, i did do those steps and it even shows updated in the registry.

     

    But the mailstore still unmounts because the limit is still 18gb and not what i've set it to.

     

    I ran the exchange analyzer and it confirms that the mailstore db is still 18gb.

     

    thanks

    Tuesday, January 31, 2012 7:59 PM
  • Does event 1216 get logged in the event viewer when you mount the database?  What size does it say the DB is limited to?
    Tuesday, January 31, 2012 8:13 PM
  • yes. Still limited to 18gb

     

    The only thing I can figure is that we still have a machine on the network that still has exchange on it, but the service is no longer running on it and stores are not mounted.

     

    i've increased that size as well just as a precaution as I have not removed it from that server yet.

    Tuesday, January 31, 2012 8:16 PM
  • Make sure that you have got the registry key exactly right. If you have copied and pasted it then it is easy to put in an extra space at the end. The most common reason I see that this doesn't work is because the key isn't right.

    After making the change you need to restart the information store service for the change to take effect. Another server will have nothing to do with it, because this is a per server setting.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Tuesday, January 31, 2012 9:35 PM
  • dude,

     

    whatever they pay you, it's not enough.

     

    leading character was a whitespace. now it works.

     

    An Extreme thank you, my friend.

    Tuesday, January 31, 2012 9:49 PM
  • I've never seen these keys not work before but I guess that I always pasted without the white space.  Good shout Simon.
    Tuesday, January 31, 2012 9:57 PM
  • I've never seen these keys not work before but I guess that I always pasted without the white space.  Good shout Simon.


    Done it myself.

    More than once. In one of the versions of the instructions (I think the Technet article) if you copy and paste an extra space comes across.

    The fix it thing on the KB article should have worked though.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Tuesday, January 31, 2012 10:23 PM
  • Hi kenny

    Any update on this thread?

    If no please mark Simon's answer and finish this thread.

    Cheers

    Zi Feng

     

    Thursday, February 2, 2012 4:46 AM
    Moderator