locked
Inserting a Bookmark into a Word Header RRS feed

  • Question

  • I am trying to create a word template using bookmarks.

    The only place where i am having trouble is in the header.

    I place my cursor in the header, but when I click the Insert Tab, the "Bookmark" link is grayed out.

    In another post I found on the topic, there was this response:

    "Inserting a bookmark into a header can be done in the exact same way as inserting a bookmark on normal text.  Well, one thing to note is that you would be able to navigate to a bookmark in a header only if you are viewing the 'header and footer' in the document."

    Can someone provide step by step instructions on how this is done?

    thanks,

    Dennis

    • Moved by Sophia Gou - MSFT Thursday, August 15, 2013 4:44 AM it is a word technet issue
    Monday, August 12, 2013 12:23 PM

All replies

  • Hi Dennis

    Are we talking about using code to place the bookmark in the header, or doing it through the UI?

    You've posted in a forum that's about using code to do things, but from your description, it seems you're trying to set up a template manually? The correct place to ask this kind of thing would be the "Communities", as there are more people there who work with Word as a "user", then here:

    http://answers.microsoft.com/en-us/office/forum/word

    FWIW, though, I can't recall a situation where I've been able to click in the header/footer and not been able to insert a bookmark. Are you sure you're actually IN the header? Can you describe in more detail what it is you so when you "place my cursor in the header"?

    And what version of Word is involved?


    Cindy Meister, VSTO/Word MVP, my blog

    Monday, August 12, 2013 1:01 PM
  • Cindy,

    Thanks for letting me know about the right forum to use.  I will post there as well.

    To answer your question, yes, I am trying to create a template manually.  But I did just discover something.  The header I chose is a "Built-In".  In particular, I am using the Alphabet header.  When I used that (or I suspect any Built-In), I cannot place the bookmark in there.

    If I select the Blank header, then is works just fine.

    Dennis

    Monday, August 12, 2013 1:11 PM
  • Hi dhancy,

    This forum is to discuss problems of OfficeDev but your question is not related to the topic of this forum. I have involved one engineer into this case and I would move the thread to Word IT pro Forum and you would get more efficient responses there.

    http://social.technet.microsoft.com/Forums/office/en-us/home?forum=word


    Sophia Gou
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, August 13, 2013 11:04 AM