locked
Server 2012 R2 not rebooting after updates from 2008 R2 WSUS server RRS feed

  • Question

  • To my eyes the group policy settings look solid. Do you guys see anything that I might be missing? This machine has not rebooted in the last 30+ days although it says it needs to be restarted to install updates. This is also happening on another 2012 R2 server in our ORG. My suggestion to the boss is to can the 2008 R2 WSUS box and build a new one on 2016, but not sure if that will go over so I might as well troubleshoot this now. Thanks!

    Windows Components/Windows Updatehide
    Policy Setting Winning GPO
    Automatic Updates detection frequency Enabled Corp SERVER WSUS Update Policy
    Check for updates at the following
    interval (hours): 5
    Policy Setting Winning GPO
    Configure Automatic Updates Enabled Corp SERVER WSUS Update Policy
    Configure automatic updating: 4 - Auto download and schedule the install
    The following settings are only required and applicable if 4 is selected.
    Install during automatic maintenance  
    Scheduled install day: 5 - Every Thursday
    Scheduled install time: 02:00
    Policy Setting Winning GPO
    Delay Restart for scheduled installations Enabled Corp SERVER WSUS Update Policy
    Wait the following period before
    proceeding with a scheduled
    restart (minutes): 1
    Policy Setting Winning GPO
    No auto-restart with logged on users for scheduled automatic updates installations Disabled Corp SERVER WSUS Update Policy
    Re-prompt for restart with scheduled installations Enabled Corp SERVER WSUS Update Policy
    Wait the following period before
    prompting again with a scheduled
    restart (minutes): 10
    Policy Setting Winning GPO
    Reschedule Automatic Updates scheduled installations Enabled Corp SERVER WSUS Update Policy
    Wait after system
    startup (minutes): 30
    Policy Setting Winning GPO
    Specify intranet Microsoft update service location Enabled Corp SERVER WSUS Update Policy
    Set the intranet update service for detecting updates: http://WSUS:80
    Set the intranet statistics server: http://WSUS:80
    (example: http://IntranetUpd01)
    Policy Setting Winning GPO
    Turn off the upgrade to the latest version of Windows through Windows Update Enabled Default Domain Policy
    Extra Registry Settingshide

    Wednesday, November 29, 2017 9:37 PM

All replies

  • Hi,

    Please try to configure policy "Computer Configuration\Administrative Templates\Windows Components\Windows Update\Always automatically restart at the scheduled time" for 2012R2 servers .

    If it still doesn't restart please check the following article:

     

    "

    This update fixes the following issue with previous versions of the Windows Update Agent for Windows 8.1, Windows RT 8.1, and Windows Server 2012 R2:
    • Windows Update would sometimes not restart the computer as expected when the “Always automatically restart at the scheduled time” policy was set.


    "

    https://support.microsoft.com/en-us/help/3138615/windows-update-client-for-windows-8-1-and-windows-server-2012-r2-march

    Best Regards,

    Elton


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 30, 2017 7:18 AM