none
Search-1 and TopfDispatch in dead mode RRS feed

  • Question

  • Hi,

    I try to setup a Fast search farm.

    In the index/search node, i tried to execute the nctrl status cmd.

    I found out that Search-1 and topfdispatch are in dead mode. (rest of the services are running fine, docpush cmd can run)

    Without these 2 services up and running, i do believe basically FAST will not be able to perform search.

    I have tried to execute : "nctrl start search-1" and "nctrl start topdfispatch", but no luck.

    It returned error:

    ==========================================

    PS E:\Apps\FASTSearch\bin> .\nctrl.exe start search-1

    Connecting to Node Controller at localhost:<port number>

    Attempting to start the following processes: search-1

    Process search-1 terminated shortly after starting

    =========================================

    I have ran out of idea what would be the possible causes.

    Anyone has any clues?

     

    Regards

    Jason

    Thursday, August 4, 2011 8:59 AM

All replies

  • Hi Jason,

    Take a look at the log files for the mentioned processes in C:\FASTSearch\var\log\searchctrl and see if they provide more information on the error.

    Regards,
    Mikael svenson 


    Search Enthusiast - SharePoint MVP/WCF4/ASP.Net4
    http://techmikael.blogspot.com/
    Thursday, August 4, 2011 10:25 AM
  • Hi Mikael,

    I have looked into the log and also other areas.

    I noticed that port xxx50-96 are not in the listening mode.

    I wonder which services are listening to those port.

     

    Regards

    Jason


    Jason
    Friday, August 5, 2011 5:26 AM