locked
projectserver PWA URL error RRS feed

  • Question

  • 第一次创建显示成功,但是实际URL连接时显示“发生意外错误”

     

    删除以后,再次创建显示失败

     

    请问有可能是什么原因导致的?谢谢!

    • Edited by demospider Thursday, May 13, 2010 6:22 AM
    Thursday, May 13, 2010 3:41 AM

Answers

  • Hi,

    I am assuming you are running either the Beta or RC of Project Server 2010? 

    The allowInsecureTransport issue in the error message usually points to a missing hotfix on your server environment. 

    Check out this blog post for details:

    http://blogs.msdn.com/opal/archive/2009/11/16/installation-notice-for-sharepoint-2010-public-beta.aspx

    excerpt...

    Install WCF FIX: A hotfix that provides a method to support the token authentication without transport security or message encryption in WCF is available for the .NET Framework 3.5 SP1 (Windows Server 2008Windows Server 2008 R2) . Please note the 2008 fix also applies to Vista, while the 2008 R2 fix also applies to Windows 7.
    If you don't have this fix installed, you will get "Unrecognized attribute 'allowInsecureTransport'" error in ULS log. And most of the service applications will not run properly. 

    It might be worth installing this hotfix and reinstalling SharePoint and PS. 

    Please note this was an issue in the Beta and RC only. The RTM version of Project Server 2010 installs this fix as part of the server prerequisites. 

    Hope this helps,

    Alex


     



    Alex Burton www.epmsource.com
    • Marked as answer by demospider Friday, May 14, 2010 4:08 AM
    Thursday, May 13, 2010 10:24 PM

All replies

  • hi!

    I can not understand your post, but think that problem may be solved by reading this thread

    http://social.technet.microsoft.com/Forums/en-US/projserv2010setup/thread/0bb9d75c-2b35-4e8e-a9e7-bc3bcd67df2d

    Thursday, May 13, 2010 5:14 AM
  • Sorry, I mean that I have installed the Project 2010 in Sharepoint 2010 farm enviroment.

     

    I want to creat the PWA site.

     

    At first time, the PWA was created but when i click the URL, it said" An unexpected error occurred "(I translate the chinese into english).

     

    I guest that may because the error that appear when i use guide to configuration a sharepoint farm :

     

    发生错误Unexpected error occurred。

    由于下列错误无法设置服务应用程序代理because of the following errors the  “User Profile Service Application” cannot been settled: 无法识别的属性unrecognized property“allowInsecureTransport”。请注意属性名称区分大小写please note camel  。 (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebClients\Profile\client.config line 56)

    Corelation Id: b49e311c-e976-42a4-973f-c24ac60cd847

    Thursday, May 13, 2010 5:52 AM
  • Sorry, I mean that I have installed the Project 2010 in Sharepoint 2010 farm enviroment.

     

    I want to creat the PWA site.

     

    At first time, the PWA was created but when i click the URL, it said" An unexpected error occurred "(I translate the chinese into english).

     

    I guest that may because the error that appear when i use guide to configuration a sharepoint farm :

     

    发生错误Unexpected error occurred。

    由于下列错误无法设置服务应用程序代理because of the following errors the  “User Profile Service Application” cannot been settled: 无法识别的属性unrecognized property“allowInsecureTransport”。请注意属性名称区分大小写please note camel  。 (C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\WebClients\Profile\client.config line 56)

    Corelation Id: b49e311c-e976-42a4-973f-c24ac60cd847

    hi, I tried again. The error didnot appear this time, and a new PWA was created. but the URL still can't work..... it saids"Unexpect error occurred"
    Thursday, May 13, 2010 6:21 AM
  • Hi,

    I am assuming you are running either the Beta or RC of Project Server 2010? 

    The allowInsecureTransport issue in the error message usually points to a missing hotfix on your server environment. 

    Check out this blog post for details:

    http://blogs.msdn.com/opal/archive/2009/11/16/installation-notice-for-sharepoint-2010-public-beta.aspx

    excerpt...

    Install WCF FIX: A hotfix that provides a method to support the token authentication without transport security or message encryption in WCF is available for the .NET Framework 3.5 SP1 (Windows Server 2008Windows Server 2008 R2) . Please note the 2008 fix also applies to Vista, while the 2008 R2 fix also applies to Windows 7.
    If you don't have this fix installed, you will get "Unrecognized attribute 'allowInsecureTransport'" error in ULS log. And most of the service applications will not run properly. 

    It might be worth installing this hotfix and reinstalling SharePoint and PS. 

    Please note this was an issue in the Beta and RC only. The RTM version of Project Server 2010 installs this fix as part of the server prerequisites. 

    Hope this helps,

    Alex


     



    Alex Burton www.epmsource.com
    • Marked as answer by demospider Friday, May 14, 2010 4:08 AM
    Thursday, May 13, 2010 10:24 PM
  • Thanks a lot!

     

    I downloaded the hotfix you mentions and successed finally!

    The process was :

     

    windows server 2008  R2

    AD

    SQL server 2008

    SQL server 2008 sp1&CU5

    ".NET Framework 3.5 SP1" & "ADO.NET Data Services Update for .NET Framework 3.5 SP1"

    Sharepoint server 2010 beta(do not start the wizard)

    "MicrosoftGenevaFramework.amd64"&“MSChart” &“sqlncli”&“Synchronization”&“Windows6.0-KB971831-x64”

    Project Server 2010 beta(star the wizard)

     

    Demospider

     

     

     

    Friday, May 14, 2010 4:16 AM