locked
Can't connect to Windows Server 2016 from particular networks (4G/WiFi) RRS feed

  • Question

  • Bear with me, this requires some explanation but this is really our last shot.

    We are a software company that delivers apps, we have a couple of VPSs hosted by TransIP (transip.nl) and have multiple APIs running to connect to our services.

    In February we started experiencing some connection problems to a particular VPS. It all started when I couldn't connect to the API (or really anything running on this VPS) from my home network. Then a couple of weeks later my mobile network (which is on the KPN network) also had the same issues. More days passed and some of our clients also started experiencing the same issues. (For them we have some dirty workarounds but we need to get back to normal service).

    We are no server gurus so we contacted our admin at TransIP. We've been talking back and forth since then (for like 2 months) and they assure us that nothing is broken on their side and that our issue has to be a local network error. They told us to run some MTR tests which we did, but weirdly enough the MTR test gave no result, absolutely nothing. So they checked with their engineers and they are still absolutely sure that the problems exists in the network which tries to connect to the VPS. They also ran tests from every corner they had and they all came back positive. However the problem exists on 4G networks and seemingly start at random for new networks.

    So we really tried everything and have talked to multiple professionals about what this problem could be, nobody really knows.

    • KPN mobile network fails but only on some phones
    • Some home networks fail
    • Randomly mobile networks that didn't work before started working again.
    • Other way around, networks that worked, stopped working after some time

    We are running Windows Server 2016 with IIS.

    Also note that there is NOTHING in the VPS logs about any devices trying to connect for the devices that can not connect.

    From networks where you cannot connect: if I enable a VPN (NordVPN for example) it magically works.

    This morning one of our employees started experiencing the problem from the 4G network on their Android phone (OnePlus 6T). It didn't work at all, no connection was possible to the VPS. But then we switched the SIM card to the 2nd SIM slot and now it works on the 2nd SIM slot. Switching back to the original SIM slot and it magically starts working again as well.

    Conclusion:

    Problem: From a network user can not connect to our VPS. Local or mobile networks. Hosting party can not find the problem. Should be a problem on the VPS. VPS does not have firewall enabled (for testing) and devices that try to connect but are rejected (timeout on client side) and do not show up in the VPS logs (which they should if they would get blocked?).

    Solution: A pointer to where the blockade is happening and how we can resolve the issue. Experienced people might've stumbled upon this problem before and might also be able to point us into a direction.

    If you have any clue, everything is welcome. Any pointers would help us tremendously.

    Tuesday, July 30, 2019 2:42 PM

All replies

  • Hi,

    Thanks for sharing your issue in the forum.

    According your description, since your local network is fine, I think the issue is caused by VPS. I believe that troubleshoot the issue requires some hands on access.  I recommend you ask your VPS provider for help. Or you can contact Microsoft Support to get them involved in checking your configuration. Thanks for your understanding.

    Best regards,

    Hollis



    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 31, 2019 6:54 AM
  • Hi, @Hollis Huang

    We have been in contact with our hosting party back and forth. The problem is that they will only look at network issues that may be caused by their servers but NOT at internal issues that might occur within the VPS. So we might've moved a setting somewhere sometime but we don't know where or when. That is the problem


    • Edited by Roy Berris Thursday, August 1, 2019 8:47 AM
    Thursday, August 1, 2019 8:47 AM
  • Hi,

    Thanks for your update.

    Based on the current situation, I am afraid that we have no better ideas. I recommend you contact Microsoft Support to open a case.

    Appreciate your patience.

    Kind regards,

    Hollis


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 2, 2019 5:53 AM