none
Getting FIM MA "Stopped Server" error in Synchronization Server Manager FIM RRS feed

  • Question

  • After migrating the 3 FIM DBs to a new SQL Server (2012) using the following migration process, we noticed an issue with FIM MA in the Management Agent Operations, specifically with FIM MA running Export and Delta Import:

    1. We took a full snapshot (VM) and backup of our FIM server

    2. On our FIM server:

    a. Disabled any scheduled FIM tasks (FIM Delta/Full) in Task Scheduler

    b. Ensured that all Management Agents had a "Idle" status before proceeding

    3. RDP'ed into our old SQL Server

    a. Backed up all FIM related DBs

    i. FIMService

    ii. FIMSynchronizationService

    iii. FIMSyncPortal

    b. Copied all backup copies of the FIM DBs to the new SQL Server location

    4. On the FIM server

    a. Stopped the Forefront Identity Manager Sync Service and Forefront Identity Manager Service

    5. RDP'ed into new SQL server

    a. Restored all 3 FIM DBs on the new SQL Server

    b. Created the necessary service accounts on the new SQL server, mapped to the 3 FIM DBs w/ appropriate permissions:

    i. domain\SVC_FIMSync

    ii. domain\SVC_FIM

    iii. domain\SVC_FIMMA

    6. Back on our FIM Server, went into REGEDIT to point FIM to our new SQL Server:

    i. Navigated to HKEY LOCAL MACHINE>SYSTEM>Current Control Set>Services>FIMSyncService>Parameters

    ii. Changed the Server Property value to: [New SQL Server]

    iii. Navigated to HKEY LOCAL MACHINE>SYSTEM>Current Control Set>Services>FIM Service

    iv. Changed the DatabaseServer to: [New SQL Server]

    7. Started the FIM Services that were stopped in step 4

    a. Ensured the FIM Sites were started in IIS, if not clicked Manage Sites>Start

    i. Sites SharePoint-80 (IdentityManagement), FIM Password Registration, FIM Password Reset

     8. Opened FIM Synchronization Service Manager, ensured Management Agents appeared and that I could see the Run History in the Operations tab

    9. Re-enabled the FIM tasks (Delta/Full) in the Task Scheduler

    Everything seemed to be working as it should however we noticed that FIM MA, specifically Export and Delta Import, was giving us a "Stopped Server" error.  All other Operations are running as they should.  More specifically, the Export operation is the one that is giving us trouble.  

    Please help!


    • Edited by discjedi Wednesday, September 9, 2015 2:06 PM
    Wednesday, September 9, 2015 1:42 PM

Answers

  • After much research and triage, we found the fix:

    1. RDP into your FIM Server, open Synchronization Service Manager

    2. Click on the Management Agents icon/tab (up top)

    3. Choose FIM MA, make sure all agents are IDLE, right click FIM MA and choose Properties

    4. Click on Connect to Database

    i. Server: [new SQL Server]

    ii. Database: fimservice (same as previous value)

    iii. FIM Service base address: should be something like http://[name of FIM server]:5725

    iv. SQL Authentication: Windows integrated, username SVC_FIMMA, pw and correct domain, click OK.  If it takes, the FIM MA Operation is now correctly configured with your new SQL Server.  IF not, check the credentials for the FIMMA service account, reset in AD if necessary.  Also verify the correct name of your new SQL Server or instance.  Go to this article to run a PS script and ensure your FIMMA is properly configured: http://social.technet.microsoft.com/wiki/contents/articles/2059.how-to-use-powershell-to-test-the-fim-management-agent-account.aspx

    5. Then run these steps to refresh and cycle through the FIM MA operations:

    i. Restart the Forefront Identity Manager Synchronization Services in the Services.msc 

    ii. Stop the Forefront Identity Manager Service in Services

    ii. On the new SQL Server, run the Sync.ClearExport stored procedure on the FIMService db:

    a. RDP into your new SQL Server, in Microsofft SQL Server Management Studio, find the FIMService database and expand it

    b. Under Programmability, expand Stored Procedures, locate Sync.ClearExport

    c. Right click Sync.ClearExport and choose Execute Stored Procedure, leave as default values/parameters and click OK.

    d. Go back into your FIM server:

    i. In Synchronization Server Manager, click on Management Agents

    ii. Right click FIM MA and choose run:

    a. Run Delta Import, check Operations and ensure it ran successful, then 

    b. Run Delta Synchronization, check Operations and ensure it ran successful, then 

    c. Run Export, check Operations and ensure it ran successful, then 

    d. Run Delta Import, check Operation and ensure it ran successful

    Voila!  That fixed it for us, I hope this works for you!

    Best


    • Marked as answer by discjedi Wednesday, September 9, 2015 2:06 PM
    • Edited by discjedi Wednesday, September 9, 2015 4:19 PM
    Wednesday, September 9, 2015 2:05 PM