none
Switch database over failed

    Question

  • Hello , 

    I have Exchange 2013 CU9  on 2 combined servers  CAS+Mail with DAG during switch the database over i got the following errors and it failed.


    Database availability health check failed.
    Database copy: Default MB2
    Redundancy count: 1

    Error: There were database availability check failures for database 'Default MB2' that may be lowering its availability. Availability Count: 1. Expected Availability Count: 2. Detailed error(s): 


            phq01-cas02:
            Database 'Default MB2' does not have enough copies configured to meet the validation criteria.
            

    ================
    Full Copy Status
    ================

    ----------------
    Database Copy : Default MB2\phq01-cas02
    ----------------
    WorkerProcessId            : 13676
    ActivationPreference       : 1
    CopyStatus                 : Mounted
    Viable                     : False
    ActivationSuspended        : False
    ErrorEventId               : 0
    LastStatusTransitionTime   : 1/1/0001 12:00:00 AM
    StatusRetrievedTime        : 6/14/2016 12:51:24 PM
    InstanceStartTime          : 12/19/2015 1:18:19 PM
    LowestLogPresent           : 0
    LastLogInspected           : 0
    LastLogReplayed            : 0
    LastLogCopied              : 0
    LastLogCopyNotified        : 0
    LastLogGenerated           : 0
    LastLogGeneratedTime       : 1/1/0001 12:00:00 AM
    LastCopyNotifiedLogTime    : 1/1/0001 12:00:00 AM
    LastInspectedLogTime       : 1/1/0001 12:00:00 AM
    LastReplayedLogTime        : 1/1/0001 12:00:00 AM
    LastCopiedLogTime          : 1/1/0001 12:00:00 AM
    LastLogInfoFromClusterGen  : 0
    LastLogInfoFromClusterTime : 1/1/0001 12:00:00 AM
    LastLogInfoFromCopierTime  : 1/1/0001 12:00:00 AM
    LastLogInfoIsStale         : False
    ReplayLagEnabled           : Unknown
    ReplayLagPlayDownReason    : None
    ReplayLagPercentage        : 0

    Please advise.

    Regards,

    Bahloul.



    • Edited by M.Bahloul Tuesday, June 14, 2016 12:57 PM
    Monday, June 13, 2016 11:37 AM

Answers

  • Hi Bahloul,

    Did Event 4138 occur on all databases?

    Because we know this issue occur on the default MB2 from your post, we suggest you run the following command with default MB2 to check if the default MB has add a mailbox database copy and it has same result with “Psau-db”:

    Get-MailboxDatabaseCopyStatus “Default MB2” 

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Wednesday, June 15, 2016 8:54 AM
    Moderator

All replies

  • Thats hard to read but it looks all your DBs are not healthy, so I would follow up on that.

    Also, you should be on CU12.


    Blog:    Twitter:   

    Monday, June 13, 2016 1:41 PM
  • HiBahloul ,

    Welcome to our forum.

    Are there any other databases in DAG?

    After we create DAG and add Exchange mailbox to the DAG member, we should add mailbox database copy for database. For this case, we should add database copy for “Default MB2 by the following link:

    https://technet.microsoft.com/en-us/library/dd298080(v=exchg.150).aspx 

    If you have done above steps, please run the following command and post result to us for troubleshooting:

    Get-DatabaseAvailabilityGroup

    Get-MailboxDatabaseCopyStatus “Default MB2”

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Tuesday, June 14, 2016 3:32 AM
    Moderator
  • all database are healthy i also update the errors 
    Tuesday, June 14, 2016 12:55 PM
  • hello Jim,

    Please check the below screen :-

    Please advise.

    Tuesday, June 14, 2016 1:08 PM
  • Please run Test-ReplicationHealth on the server, It will give you the exact reason of this error.

    http://exchangeserverpro.com/exchange-2013-test-replicationhealth/

    Regards, Sourabh Kumar Jha | Please mark it as an answer if it solves your problem or vote as helpful if you like it. |

    Tuesday, June 14, 2016 6:54 PM
  • Wednesday, June 15, 2016 7:23 AM
  • Hi Bahloul,

    Did Event 4138 occur on all databases?

    Because we know this issue occur on the default MB2 from your post, we suggest you run the following command with default MB2 to check if the default MB has add a mailbox database copy and it has same result with “Psau-db”:

    Get-MailboxDatabaseCopyStatus “Default MB2” 

    Best Regard,

    Jim Xu

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Wednesday, June 15, 2016 8:54 AM
    Moderator