none
WMI error - Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) RRS feed

  • Question

  • Hello everyone! I have got an error, 0x80070005 (E_ACCESSDENIED)), when trying to collect some data by using WMI remotely (using PowerShell). I have made changes to DCOM (I gave the user Remote Launch and Remote Activation permissions in dcomcnfg and do the same with "Windows Management Instrumentation"), but it's didn't helped. I am using admin rights, so permissions isn't an issue (I guess). What I need to do else?
    • Edited by Net Ranger Friday, September 11, 2015 8:22 AM
    Friday, September 11, 2015 8:21 AM

Answers

  • I have figured out, that's icm .. -scriptblock {gwmi ...} is working (no errors, except if a target PC is turned off). Different ports or services? Don't sure. But at least I got workable solution. Thanks for help.
    • Edited by Net Ranger Monday, September 14, 2015 8:41 AM
    • Marked as answer by Net Ranger Monday, September 14, 2015 8:42 AM
    Monday, September 14, 2015 8:41 AM

All replies

  • The user can access WMI but still has no access to the resource.

    I bet it is Win2_Service. Give the user access with the service manage security.


    \_(ツ)_/

    Friday, September 11, 2015 11:12 AM
  • Give the user access with the service manage security.


    \_(ツ)_/

    How?
    Friday, September 11, 2015 11:24 AM
  • Assign permission with te service control manager.


    \_(ツ)_/

    Friday, September 11, 2015 12:23 PM
  • I have figured out, that's icm .. -scriptblock {gwmi ...} is working (no errors, except if a target PC is turned off). Different ports or services? Don't sure. But at least I got workable solution. Thanks for help.
    • Edited by Net Ranger Monday, September 14, 2015 8:41 AM
    • Marked as answer by Net Ranger Monday, September 14, 2015 8:42 AM
    Monday, September 14, 2015 8:41 AM