locked
Basic Service Monitor: "Alert only if service startup type is automatic" option doesn't work RRS feed

  • Question

  •  

    When I create a Basic Service Monitor and I try to overridden "Alert only if service startup type is automatic"
    the "Parameter type" is STRING
    in the description is write ("Parameter Description: This may only be set to 'true' or 'false'. If set to 'false', then alerts will be triggered no matter what the startup type is set to. Default is 'true'.")

    you can write in the "Override setting" false or true and the parameter did't work

    Maybe the "Parameter type" is wrong it have to be BOOLEAN like "Generate Alerts"


    Reference:

    https://connect.microsoft.com/OpsMgrFeedback/feedback/ViewFeedback.aspx?FeedbackID=346594&wa=wsignin1.0

     

    Someone have a fix or efective workaround to this problem?

     

    Rgds,

     

    Victor Walter

    Wednesday, July 30, 2008 2:28 PM

Answers

  • I answer myself :-)

     

    I open incident in Microsoft and get workaround:

     

    1.            Create the basic service Monitor in a new empty Management Pack (if you create a new empty MP for the monitor its easier to edit it later).

    2.            Set it to enabled and set the override „Alert only if service startup type is automatic” to false.

    3.            Export the management pack and delete it.

    4.            Open the exported management pack and edit it in the following way (add the CheckStartupType true parameter):

    --------------------

    WRONG setting:

    --------------------

     

    <Configuration>

              <ComputerName>$Target/Property[Type="MicrosoftWindowsLibrary6062780!Microsoft.Windows.Computer"]/NetworkName$</ComputerName>

              <ServiceName>Spooler</ServiceName>   

            </Configuration>

     

    -----------------

    GOOD setting:

    -----------------

     

    <Configuration>

              <ComputerName>$Target/Property[Type="MicrosoftWindowsLibrary6062780!Microsoft.Windows.Computer"]/NetworkName$</ComputerName>

              <ServiceName>Spooler</ServiceName>

                      <CheckStartupType>true</CheckStartupType>

            </Configuration>

     

    5.            Save the settings and import the management pack back

     

    After this setting the monitor will trigger alert when the service type is set for example to manual.

     

     

    I tested it and it works. I think it is easier than build management pack template...

     

    Saturday, August 30, 2008 7:28 AM

All replies

  • Hi Victor,

    The parameter type is "string" means you can type the character.

    You can select "Alert only if service startup type is automatic", type "true" or "false" in the "override setting" column, then apply the setting.

    --------------------
    Regards,
    Eric Zhang



    Monday, August 4, 2008 9:35 AM
  • Hi Eric,

     

    I can type "false" but the basic service monitor doesn't alert me.

    If the service monitor was created by "Management Pack Templates" it alerts OK.

     

    Rgds,

     

    Victor Walter

     

     

     

     

     

    Monday, August 4, 2008 12:39 PM
  • Hi Victor,

    The alert will be triggered when the service is stopped.

    Also, please make sure you save this monitor under "entity health" in  "default management pack" or custom MP which is unsealed, and the target of this monitor is "agent"

    --------------------
    Regards,
    Eric Zhang





    Tuesday, August 5, 2008 10:48 AM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!
    --------------------
    Regards,
    Eric Zhang

    Friday, August 8, 2008 9:39 AM
  • I have exactly same problem. I tried different targets, but it does't help. Everything works, when startup type is "Automatic". But when I change it to "Manual", it's won't trigger alerts anymore.

    Best regards,
    Ken
    Monday, August 25, 2008 1:47 PM
  •  

    I have the same problem

     

    Alert only if service startup type is automatic - doesn't work

     

    Alex

    Friday, August 29, 2008 2:36 PM
  • I answer myself :-)

     

    I open incident in Microsoft and get workaround:

     

    1.            Create the basic service Monitor in a new empty Management Pack (if you create a new empty MP for the monitor its easier to edit it later).

    2.            Set it to enabled and set the override „Alert only if service startup type is automatic” to false.

    3.            Export the management pack and delete it.

    4.            Open the exported management pack and edit it in the following way (add the CheckStartupType true parameter):

    --------------------

    WRONG setting:

    --------------------

     

    <Configuration>

              <ComputerName>$Target/Property[Type="MicrosoftWindowsLibrary6062780!Microsoft.Windows.Computer"]/NetworkName$</ComputerName>

              <ServiceName>Spooler</ServiceName>   

            </Configuration>

     

    -----------------

    GOOD setting:

    -----------------

     

    <Configuration>

              <ComputerName>$Target/Property[Type="MicrosoftWindowsLibrary6062780!Microsoft.Windows.Computer"]/NetworkName$</ComputerName>

              <ServiceName>Spooler</ServiceName>

                      <CheckStartupType>true</CheckStartupType>

            </Configuration>

     

    5.            Save the settings and import the management pack back

     

    After this setting the monitor will trigger alert when the service type is set for example to manual.

     

     

    I tested it and it works. I think it is easier than build management pack template...

     

    Saturday, August 30, 2008 7:28 AM