locked
Update-SPProfilePhotoStore not working after SP1 + CU June 2011 RRS feed

  • Question

  • After SP1 and CU June 2011 the -CreateThumbnailsForImportedPhotos is not working.

    "Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos 1 -MySiteHostLocation http://<YourServerName>/my/"
     
    Update-SPProfilePhotoStore run without error but the <GUID>.jpg in User Photo Library remain unchanged.
     
    My environment:
     - SP2010 English installation with Norwegian Language Pack
     After some more testing I have experienced the following:
     - If the Mysite sitecollection is with English language it work OK.
     - If the Mysite sitecollection is with Norwegian language it fail.
     - The problem actually occurs after SP1+June CU, working OK after just SP1.
     - Have tried this in 3 different server farms with same problem.

    If I compare the content of folder in /User%20Photos/ library before and after CU June I see som strange behavior (Norwegian sitecollection):
    Before:
    "Profile Pictures"

    After:
    "Profile Pictures"
    "Profilbilder"           (new additional one in but in Norwegian language)

    After a full sync the <GUID>.jpg pictures is placed only in "Profilbilder"
    After -CreateThumbnailsForImportedPhotos nothing happens within this folder
    After -CreateThumbnailsForImportedPhotos it don't update picture url in UserProfile for users where I have added a new photo


    Anyone ?


    Friday, August 19, 2011 4:09 PM

Answers

  • Wow - after CU Dec 2011 working OK for me now regarding 1 post in this thread.

    Have tested a mysite host with Norwegian language.

     

    Arnstein Fuglemsmo
    www.enable.no

     


    Saturday, January 7, 2012 4:18 PM

All replies

  • We have a SP1+CU June 2011 enviroment with Swedish language pack and Swedish mysite site collection. Same behavior here, we get the guid-named pictures placed in the folder "profilbilder" but the pictures are not scaled or mapped to the user profiles. No error messages in windows application log or ULS logs when running Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos..

     

     

     

     

     

     

     

    Monday, August 22, 2011 9:28 AM
  • Hi. I have the same situation using a german MySiteHost

    Environment:

    English SharePoint 2010 SP1 + June CU

    German Language Pack

    Tuesday, August 23, 2011 11:42 AM
  • I am having the same isue in my environment.

     

    SharePoint 2010 Server + SP1 + June 2011 CU

    English language

    It's a pressing issue, since we use SharePoint profile photos to export to AD - if the thumbnails aren't in SharePoint, AD cannot reference them.  This entire SP1 + June CU has been extremely frustrating, thanks to FIMsync going off the rails and trying to eat my Profile DB due to ambiguous joins - however that's unrelated to this topic.  Just wanted to keep this post alive and hope it gets fixed soon so we can have thumbnails back.

    Tuesday, August 23, 2011 11:23 PM
  • SP 2010 Server + SP1 + June 2011 CU, never had any previous version (updated binaries were installed before building out the farm and migrating our content).  English only.  We also had to rebuild our SSP into a brand new User Profile service as there was an unrecoverable error that PSS could not help us with (apparently a remnant from our 2003 - 2007 migration).

    Just completed our content db attach migration from 2007 and we are running into what appears to be this same issue.  Using our farm account I run PS as an administrator and then run the command:

    Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos 1 -MySiteHostLocation https://ourportalsite.domain.name/mysite

    The command completes with no errors, and runs pretty quickly.  If I look at a mysite profile page I can see the picture in the old location (/personal/username/Shared%20Pictures) with no thumbnail, but if you click on it it becomes viewable.  There is no picture nor thumbnails in the new location.

    I'm also not able to find any relevant log, but the command did appear to complete successfully.

    Wednesday, August 24, 2011 2:59 PM
  • We were having the same issue in our environment, attempting to run the Update-SPProfilePhotoStore -CreateThumbnailsForImportedPhotos 1 -MySiteHostLocation http://mysitehost cmdlet to complete picture updates on SP 2010 Server + SP1 + June 2011 CU refresh (French and Chinese (Simp) language packs).

    After digging into the issue, it appears as though the cmdlet uses the WCF service ProfilePropertyService.svc, so I gave the Admin account 'Full' Sharing Connection permissions for the UPS application, and viola, the cmdlet succeeded and pictures were updated as expected.

    Christopher Gill

    MCITP: Enterprise, Server, Lync 2010 & SharePoint 2010 Administrator | MCPD: SharePoint Developer 2010 | MCTS: SQL 2008 (I&M), MOSS 2007, & WSS 3.0 Config

    • Proposed as answer by cgillnp Wednesday, August 31, 2011 8:10 PM
    • Unproposed as answer by cgillnp Wednesday, August 31, 2011 8:11 PM
    Wednesday, August 31, 2011 8:09 PM
  • cfgill - That sounds great

    Could you be more spesific about what you mean by "I gave the Admin account Full Sharing Connection permissions for the UPS applicaton"

    What account ?

    How to make the admin account Full Sharing Connection permissions ?

     

    Arnstein Fuglemsmo

    www.enable.no

     

    Wednesday, August 31, 2011 8:24 PM
  • Some clarification - In CA, click Manage Service Applications, then highlight [Your UPS Application] in the list, and select 'Permissions' from the ribbon.  Make sure (add, if necessary) the Server Farm Account/Administrator, and confirm that the account has been granted Full access.  It is worth noting that this particular account MUST be the one issuing the cmdlet via powershell (must be the logged-in user, or credentials used via run-as for SharePoint Management Shell), or else the update will continue to fail.
    Christopher Gill MCITP: Enterprise, Server, Lync 2010 & SharePoint 2010 Administrator | MCPD: SharePoint Developer 2010 | MCTS: SQL 2008 (I&M), MOSS 2007, & WSS 3.0 Config
    Wednesday, August 31, 2011 9:33 PM
  • cfgill - Thanks, you are the first one who come with a solution but unfortunately didn't make any difference for me.

    I still have the same problem.

    Hopefully somebody else looking for this thread can test and respond the result.

     

    Arnstein Fuglemsmo

    www.enable.no

     

    Wednesday, August 31, 2011 11:04 PM
  • hi @all

    we have the same problem with the picture update -> german Sharepoint SP1 and Juni CU

    the solution from cfgill doesn't work for me. same problem

    here is a link for a german tread with the same problem:

    http://social.technet.microsoft.com/Forums/de-DE/Sharepointde/thread/77af9443-334c-4b89-87b3-d27b71781632/?prof=required

     

    hope in the near future ms will correct this issue

    Dani

    Monday, September 5, 2011 9:14 AM
  • After the release of August CU I had som expectations regarding this problem,

    but this update make no difference for me. Still same problem.

     

    Arnstein Fuglemsmo

    www.enable.no

     

    Saturday, September 10, 2011 2:35 AM
  • Same problem here - Danish Language pack.

    Breaks after June CU update...

     


    Palle-DK
    Tuesday, September 13, 2011 7:58 AM
  • We're having the same problem.

    SP1 + Aug CU and Swedish language pack.

    Tuesday, October 18, 2011 9:18 AM
  • Hi All,

    same issue with German Sharepoint.

    SP1 applied (no CU until now), but also not working. The 3 Thumbnail Files are not created, only the Picture from AD is imported and that's all.

    When you search then you find hundred's of articles how to do it and that it is always working fine, but i think they all have everything in English installed.

    I have a Profile Pictures and Profilbilder Directory under  the My Site, but nothing works at all. You can copy the pictures from one location to another, nothing works. I even tried to put the URL of the Picture into the ProfileDB in the PictureURL column, but it is still not loaded.

    There seems to be an open call at MS, so hopefully some CU in the future will fix this.

    Bye, Peter

    Monday, October 31, 2011 1:48 PM
  • After CU October 2011 the situation is even worse.

    Now the result after UserProfileSync is no pictures in /User%20Photos/ library.

    I have tested with both English and Norwegian MySite Hosts.

    Microsoft - Shame on you - this is very bad !!

     

    Arnstein Fuglemsmo

    Saturday, November 19, 2011 11:28 AM
  • Same issue here, with 18 (yes, 18) Language packs installed. Still worse, thumbnails have been correctly created for about 80% of the profiles, and the other have been left untouched...

     

    Regards

    Roberto

    Monday, December 5, 2011 11:38 AM
  • SP1 and August CU, norwegian languagepack. I got it working inspired by this dane's blog http://sites.wizdim.com/andersrask/powershell/using-regional-locale-on-your-my-site-host-breaks-user-profile-thumbnails/

    In our environment the sync pulls the thumbnailphotos from AD DS, and places them in user photos\profilbilder

    the format is <userProfileManager.PartitionID>_<userProfile.recordId>.jpg , as expected.

    Now, the -CreateThumbnailsForImportedPhotos is looking for files with this format in another directory: brukerbilder\profilbilder

    This folder did not exist in my environment, so I created it, and made a PS-script that moves all imported pictures from user photos\profilbilder to brukerbilder\profilbilder (Anders' solution from the link above)

    Now the -CreateThumbnailsForImportedPhotos gets som material to work with and thumbnails are beeing created. BUT, the job puts the thumbnails back in the folder where the sync originally placed the imports: user photos\profilbilder

    OK great, so now I have my 3 thumbnails per user in sharepoint2010 style. Only they are still in the wrong folder.

    Sharepoint itself looks for users' thumbnailphotos in user photos\profile pictures , so I move the pictures from user photos\profilbilder to user photos\profile pictures, and voila, it works.

    Its a messy operation, but it works.

    ad ds sync: puts <userProfileManager.PartitionID>_<userProfile.recordId>.jpg in user photos\profilbilder

    createthumbnailsfor...: searches in brukerbilder\profilbilder

    createthumbnailsfor...: places the thumbnails created in user photos\profilbilder

    sharepoint 2010: looks for users thumbnails in user photos\profile pictures

     

    Thanks to Anders Rask for providing the solution in the blog linked above.

    cheers,

    -sigmund

    Wednesday, December 7, 2011 1:03 AM
  • We had a support case regarding this at Microsoft and they confirmed that is was a bug. It's solved in the October CU.

    /Markus

    Friday, December 9, 2011 8:56 AM
  • I'm having this issue - no language packs - and December 2011 CU installed.

    Is anyone else still having this issue now, or did the October CU fix for everybody?

    Thanks..


    Alasdair Marshall
    Thursday, January 5, 2012 12:00 AM
  • Wow - after CU Dec 2011 working OK for me now regarding 1 post in this thread.

    Have tested a mysite host with Norwegian language.

     

    Arnstein Fuglemsmo
    www.enable.no

     


    Saturday, January 7, 2012 4:18 PM