none
MDT 2013 USMT not Restoring Data RRS feed

  • Question

  • I have being trying to get USMT to work on backing up and restoring user profiles and I am unable to get it to restore.

    This is what I have in my customsettings.ini

    [WIN10X64-TEST]
    SkipCapture=YES
    SkipUserData=YES
    UserDataLocation= Network
    UDShare=\\SERVER\deploymentshare$\USMTData
    UDDir=%HOSTNAME%
    SkipComputerBackup=YES
    ComputerBackupLocation=NETWORK
    BackupShare=\\SERVER\deploymentshare$\USMTData\%HOSTNAME%
    BackupDir=%HOSTNAME%-Backup
    BackupFile=%HOSTNAME%.wim
    SkipBitLocker=YES
    SkipComputerName=YES
    DoCapture=NO
    OverrideProductKey=PRODUCT KET
    SkipDomainMembership=YES
    JoinDomain=ad.DOMAIN.com
    DomainAdminDomain=ad.DOMAIN.com
    WSUSServer=http://SERVER:8530

    It will backup the file in that folder under the PC name but after it reimages the pc and goes to restore the user state it never restores and this is in the BDD.log

    <![LOG[No user state to restore, exiting.]LOG]!><time="17:49:22.000+000" date="09-06-2016" component="ZTIUserState" context="" type="1" thread="" file="ZTIUserState">

    If I change my Custom Settings to this it will backup and restore fine:

    [WIN10X64-TEST]
    SkipCapture=YES
    SkipUserData=YES
    UserDataLocation= \\SERVER\deploymentshare$\USMTData\
    SkipBitLocker=YES
    SkipComputerName=YES
    DoCapture=NO
    OverrideProductKey=PRODUCT KET
    SkipDomainMembership=YES
    JoinDomain=ad.DOMAIN.com
    DomainAdminDomain=ad.DOMAIN.com
    WSUSServer=http://SERVER:8530

    but I need it to save them by PC name so we can do Multiples at the same time this causing the profile backup to be located at

    \\SERVER\deploymentshare$\USMTData\USMT\USMT.MIG

    instead of

    \\SERVER\deploymentshare$\USMTData\%HOSTNAME%\USMT\USMT.MIG

    Can anyone help me figure this out?

    Friday, September 9, 2016 7:22 PM

Answers

  • Use:

    UDDir=%OSDComputerName%


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Monday, September 12, 2016 2:16 PM

All replies

  • Use:

    UDDir=%OSDComputerName%


    If this post is helpful please vote it as Helpful or click Mark for answer.

    Monday, September 12, 2016 2:16 PM
  • Hello

    I am having the same issue:

    UserDataLocation=Network
    SkipUserData=Yes
    USMTMigFiles001=MigApp.XML
    USMTMigFiles002=Miguser.XML
    USMTMigFiles003=Migdocs.XML
    ScanStateArgs =/v:5 /o /c /uel:7 /ui:HRSA\
    LoadStateArgs = /v:5 c
    UDSHARE=\\192.168.203.14\Data\MDT-USERS-DATABackup\DataBackup
    UDDir=%ComputerName%

    MDT is creating the folder with computer name and puts the usmt.mig file there, but nothing is being restored

    Have you fix this, and how

    thanks

    Tuesday, February 6, 2018 9:24 PM
  • Your loadstate argument is invalid.

    Change c to /c

    Your Scanstate is only going to backup an account that logged in within the last 7 days, could be an issue if they haven't rebooted in a while. If HRSA is your domain and you want all users from the domain then be sure to add * after HRSA\


    Daniel Vega

    Tuesday, February 6, 2018 9:31 PM