locked
Concurrent Licensing Not working RRS feed

  • Question

  • Hello, I currently have concurrent licensing set to two licenses. I experienced a problem where only one license would work, the other user could not launch the application. Now I am experiencing both licenses being unavailable. In the license table it is showing that there are two licenses available?


    I've also tried rebooting the client who last successfully launched the application but still no joy.
    Wednesday, March 3, 2010 3:18 PM

Answers

All replies

  • Hello,

    With what error message is the user presented?

    /Znack
    Wednesday, March 3, 2010 7:57 PM
  • Hi Znack, I can't answer that because we modified the XML file to give the user a better description of the problem. The SQL table says that licenses are available.
    Thursday, March 4, 2010 12:14 PM
  • Such a problem *should* only happen if you lost the management server while the license was out.  Try restarting the server again.

    If not, the following might work but is a really last resort and not supported by anyone (especially me or Microsoft) - back up everything first!
    Shutdown the servers.
    In the database, Manual deletion of records in the USER_LICENSE_KEYS table, and manipulation of Avail_qty in the LICENSE table.
    Restart.

    More likely, create a new license and assign the app to it.  Then delete the old.
    Thursday, March 11, 2010 11:47 PM
    Moderator
  • Hello, this is the error code I get: 4513CDC-1690150A-20000193

    I cannot shutdown the server at the moment because it is live.

    In my USER_LICENSE_KEYS table I don't have any data at all and my Avail_qty in the LICENSE table isn't a problem, they are showing the right number of licenses that should be available. 

    I've tried creating a new license and I'm getting the same experience.   

    Monday, March 15, 2010 9:46 AM
  • Hello,

    See this KB-article for further troubleshooting;
    http://support.microsoft.com/?kbid=930617

    /Znack
    Monday, March 15, 2010 9:57 AM
  • In relation to this article, the application is available to domain users of which I am. If licensing is removed from the application then I can launch it fine.


    Is there any possibility there could be a communication issue with our VAS servers causing this? We have our Manager and the database on the same box, we then have 5 VAS servers located at different locations but on a fast link.

    In our test environment licensing works great but we have no remote VAS servers. 

    Monday, March 15, 2010 10:44 AM
  • Hello,

    just asking - as it works in your test environment;
    Is the provider policy setup in the production environment?

    /Znack
    Monday, March 15, 2010 12:01 PM
  • Hello, yes provider policy is setup in the production environment. Licensing is enables and set to Enforce License policies the same as our test server.
    Wednesday, March 17, 2010 8:41 AM
  • Hello Znack, I noticed you had a similar conversation with Gareth Wilson regarding a licensing problem last year:

    http://social.technet.microsoft.com/Forums/en-US/appvserverandmanagement/thread/13017bd0-2da0-4c12-b968-9bce4f045a71

    I think I might go down the route of doing a repair because his symptoms sound very similar to mine. Will let you know how I get on.

    Thanks for your help.

    • Proposed as answer by znack Saturday, March 20, 2010 9:05 AM
    • Marked as answer by Aaron.ParkerModerator Saturday, November 17, 2012 1:45 PM
    Wednesday, March 17, 2010 10:32 AM
  • Hello, ok I tried doing a repair but my licensing is still not working.

    I noticed that the stats in the database table just aren't updating.

    I've now disabled licensing completely and have started to clear my license table. I've tried to remove licenses and I'm getting the following error:

    Unexpected Error

    Unable to delete the specified Application license.

    Error Code: 0000B024

    I'm at a loss on what to do now. If anyone has any suggestions, my only option now would be to create a new database and have to put all our applications back in. Can the VAS server be pointed at the new database or will the service need reinstalling?

     

     

     

     

     

    Tuesday, March 23, 2010 12:06 PM