none
PXE - E51 error while 2008 R2 HyperV Guest OS Deploy RRS feed

  • Question

  • Here is my lab setup!!

    Installed Windows 2008 R2

    Added Microsoft Loopback adapter (No any other Network Adapter available)

    Configured TCP/IP

    Promoted as DC

    Installed roles DNS, WDS, DHCP and Hyper-V too.

    nslookup resolves the hostname correctly.

    WDS configured with all needed settings.

    DHCP is configured with Scope and Option 60 also configured.

    Referred blog site to configure Legacy Network Adapter to boot PXE for Guest OS

    Error noticed while Guest OS deploy: PXE-E51: No DHCP or proxyDHCP offers were received.

    Requesting experts support as well as solution....

    Monday, May 11, 2015 7:53 AM

Answers

  • Hi Manohar,

    I get that you are trying to save resources. But as I pointed out earlier, you are in a unsupported scenario, which would mean this could result to an undesired behavior and product might not work as expected ,even when all settings\config are correct.

    Secondly it might give you some results in lab, that might not work in production supported scenarios, leading your understanding and efforts in vain.

    Connection between the Host and the VM are not similar to two VMs connecting to each other using same VLAN.

    Now lets try to sort out your issue:

    On the PXE Response Settings tab:  What is selected?

    Respond to all (known and unknown) client computers (alternatively you can add known computers to the domain with the AD Users and Computers tool and select the Respond only to known client computers option).

    Is this configured?

    An example for one purely windows environment:
    dhcpmgmt.msc
    find the scope you're interested in
    edit option 066 to contain the ip address of your tftp server
    edit option 067 to contain WDSNBP.COM

    Which guide are you using to deploy OS.

    References:

    Walkthrough: Deploy an Image by using PXE


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by manohar bhat Tuesday, June 30, 2015 7:43 AM
    Tuesday, May 12, 2015 9:50 AM

All replies

  • Hi Manohar,

    Let me see if I have got this right.

    You have a physical machine with Win2008R2 installed.

    This box has roles Hyper-V, DC,DNS,DHCP, WDS.

    You have a Guest VM created inside the Hyper-V manager, with network adapter to Host-Only Mode. You are not able to deploy guest OS using PXE Boot of the host server WDS.

    If this is the case, you are in a unsupported scenario. There is not much point of troubleshooting this.

    Issue:Roles other than Hyper-V are enabled on this server.

    Impact: The Hyper-V role should be the only role enabled on a server.

    This best practice is recommended because it helps keep the management operating system free of components (such as roles, features, and applications) that are not required to run Hyper-V.

    Resolution: Use Server Manager to remove all roles except Hyper-V.

    But in your case it will be complicated as you have the DC installed as well. Better do a fresh re-install of the OS and start from scratch.

    Recommended Lab setup would be:

    Physical Host with Hyper-V

    Guest VM with DC,DNS

    Guest VM with WDS etc.

    Guest VM for OS deployment.


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Monday, May 11, 2015 10:04 AM
  • Hi Satyajit,

    You are perfectly correct to understand my lab setup for TRAIL except "You have a Guest VM created inside the Hyper-V manager, with network adapter to Host-Only Mode"

    Virtual Network Adapter is not just HOST-ONLY, it also serve as Shared and can be controlled by Host-OS

    Few mode details;

    I do get IP when for guest OS PXE boot when I "Enable Share Virtual Network Adapter on HyperV Settings". But PXE server does not push image to boot.

    Guest OS PXE boot screen wait for PXE Server to respond and keeps on waiting.....

    In case when I "Disable Share Virtual Network Adapter on HyperV Settings" Guest OS PXE boot client do not get IP at all!! 

    Tuesday, May 12, 2015 5:03 AM
  • Hi Manohar,

    I get that you are trying to save resources. But as I pointed out earlier, you are in a unsupported scenario, which would mean this could result to an undesired behavior and product might not work as expected ,even when all settings\config are correct.

    Secondly it might give you some results in lab, that might not work in production supported scenarios, leading your understanding and efforts in vain.

    Connection between the Host and the VM are not similar to two VMs connecting to each other using same VLAN.

    Now lets try to sort out your issue:

    On the PXE Response Settings tab:  What is selected?

    Respond to all (known and unknown) client computers (alternatively you can add known computers to the domain with the AD Users and Computers tool and select the Respond only to known client computers option).

    Is this configured?

    An example for one purely windows environment:
    dhcpmgmt.msc
    find the scope you're interested in
    edit option 066 to contain the ip address of your tftp server
    edit option 067 to contain WDSNBP.COM

    Which guide are you using to deploy OS.

    References:

    Walkthrough: Deploy an Image by using PXE


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    • Marked as answer by manohar bhat Tuesday, June 30, 2015 7:43 AM
    Tuesday, May 12, 2015 9:50 AM