locked
Media Center using HDMI Audio = Bug RRS feed

  • Question

  • Here is a run down of my set up and something interesting at the end.

    My main PC in my office has 6TB of drive space. It stores about 200 DVD's of my 1000 collection. I have 4 XBOX 360's in my home and my home is completely wired in cat6.
    The movies are stored as mpegs so the 360 units can stream them. I use Media Center with MyMovies2 for the collection interface. I was never happy with the picture quality and loss of bonus features with the mpegs. So it was time to build a killer streamer. The HTPC I just built , specs below, is to stream from the 6TB PC as well as play any discs I have not ripped yet. MyMovies2 also has the ability to stream Blu-Ray and HD-DVD ISO files when used in conjunction with Power DVD, AnyDVD and Daemon Tools.

    HTPC:
    Asus PQ5-EM Motherboard-Intel G45 Chipset onboard HDMI Video /Audio
    Intel E8600 CPU
    ADATA DDR2-800 4GB
    Asus Blu-Ray Drive

    Currently the Asus P5Q-EM is running Vista 64, MyMovies2(client), AnyDVD, Daemon Tools and Power DVD 7.3.

    If you open up available HDMI Audio Devices I have 2. One is the Intel that Actually works and the other is a Microsoft that says it works, but even if I set it as default it gives nothing. So the Intel HDMI Audio is Default.
    I have it configured to 7.1 speaker set up.

    In this Set up Power DVD and Media player work great. I can stream Blu-Ray and play anything at all in 7.1 or 5.1 what ever the source has to offer.

    Now in Media Center I go to configure the audio set up and the first question it asks is what type of connector are you using for audio. RCA, SPDIF, Coax ETC... but no HDMI.
    Whatever I choose give me no audio in media center and the videos will lock up in about 1 minute.
    So I start the set up and then cancel. Once you lose the audio it is gone for navigation within Media Center also. Restarting Media center gives you back your navigating audio.

    Now if I go back to Audio Devices available and select Intel HDMI and change it to 2CH. I then get full audio and 5.1 from the mpeg movies through Media center. But now Blu-Rays only give 2CH no matter what, whether streamed or from the disc.

    Ok, here is the funny thing.... After playing with settings and drivers for awhile, I had the Intel HDMI set for 7.1 and then tried Power DVD both from disc and streaming Blu-Ray, worked perfectly, Tried Media Player with the Mpegs, worked perfectly, Opened Media Center then My Movies2 and loaded up a Blu-Ray stream, It worked perfectly. The I loaded up an mpeg movie in my movies and it played perfectly in 5.1. I then tried several mpegs and they all worked.

    What I found is when you go into Media Center, If the first thing I play is a Blu-Ray stream it somehow tells media center how to hook up correctly to the HDMI Audio. Once I stop the Blu-Ray stream I can play any movie I have stored on the 6TB server with no problem through Media Center. Once I close Media Center it goes back to wanting 2CH. As long as I play A Blu-Ray first in Media center then everything will work like it is supposed to.

    So, If I had to guess I would say this is a Media center issue. It does not appear to be finding the HDMI audio correctly.

    Anyone feel free to chime in on this issue. God knows I could use the help....
    Tuesday, August 26, 2008 6:39 AM

All replies

  • I am having the same problem, but I do not have the blu-ray player to help fix the issue. If anyone knows anything about this I would appreciate your help.
    Sunday, May 10, 2009 11:18 PM
  • hey guys, I have the same set up and have been trying to stream bluray and h264 from my livingroom computer to my bedroom through media center.  I have a dlink 655 extreme.  I am trying to stream everything wirelessly.   I get 300Mbps in the bedroom and 150Mbps in the livingroom.  I use media center with powerdvd also. except i use media browse as the extra instead of mymovies.  My problem is the movies studder constantly.  Is there anything I can do to fix this?

    Friday, July 3, 2009 1:37 AM