locked
FEATURE_HTTP_USERNAME_PASSWORD_DISABLE works for 64bit IE 8 but not 32bit IE 8 RRS feed

  • Question

  • When doing the below to allow entering a userid and password in IE address bar - (user:pass@www.mysite.com) the settings take effect for 64bit only, but not 32bit version of IE. (on Windows7).  How can I make this work for both versions? 

    below instructions are from MSDN article:

    How to disable the new default behavior for handling user information in HTTP or HTTPS URLs

    To disable the new default behavior in Windows Explorer and Internet Explorer, createiexplore.exe and explorer.exe DWORD values in one of the following registry keys and set their value data to0.
    • For all users of the program, set the value in the following registry key:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_USERNAME_PASSWORD_DISABLE
    • For the current user of the program only, set the value in the following registry key:
      HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_HTTP_USERNAME_PASSWORD_DISABLE

    ...and when I do this, the 64bit version allows Username and Password on the address line, but the 32 bit version still does not.

    mp


    mp
    Wednesday, October 13, 2010 3:52 PM

Answers

  • To fix this on a 64-bit install of Windows, you need to make the change for the following registry keys:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_HTTP_USERNAME_PASSWORD_DISABLE]
    "iexplore.exe"=dword:00000000
    "explorer.exe"=dword:00000000

     

    The important bit in there is the "Wow6432Node" which is the branch of the registry that all 32-bit programs will read from.

    This works for IE9 for sure, but I'm guessing it should also work for IE7 and IE8 as well.

    • Proposed as answer by Steven Nusser Monday, August 15, 2011 6:06 PM
    • Marked as answer by MarvinPerkins Monday, August 15, 2011 7:14 PM
    Monday, August 15, 2011 6:06 PM

All replies

  • To fix this on a 64-bit install of Windows, you need to make the change for the following registry keys:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Internet Explorer\MAIN\FeatureControl\FEATURE_HTTP_USERNAME_PASSWORD_DISABLE]
    "iexplore.exe"=dword:00000000
    "explorer.exe"=dword:00000000

     

    The important bit in there is the "Wow6432Node" which is the branch of the registry that all 32-bit programs will read from.

    This works for IE9 for sure, but I'm guessing it should also work for IE7 and IE8 as well.

    • Proposed as answer by Steven Nusser Monday, August 15, 2011 6:06 PM
    • Marked as answer by MarvinPerkins Monday, August 15, 2011 7:14 PM
    Monday, August 15, 2011 6:06 PM
  • Perfect!

    Thanks so much!  I certainly never would have thought to look under "Wow6432Node", but I just tried it and it works like a charm.

    Wonderful to get an answer on a question I had pretty much given up on.

    Answer=YES.


    mp
    Monday, August 15, 2011 7:16 PM
  • Just curious to know if this would work for settings username and password for a proxy under proxy settings in IE9?

     

    Thanks,

    Ben

    Wednesday, January 25, 2012 10:20 AM