none
external DynDNS error

    Question

  • Hallo!

    I am a little desperate because despite the fact my job is IT I don't get it to work. My homeserver is running Server 2012 R2 Essentials and because somehow the AD and file shares did not work properly anymore I decided to reinstall the OS from scratch. After reinstallation I reconfigured anywhere access and reobtained my remotewebaccess.com-subdomain which worked fine except for the the remotedesktopgateway did not get the certificate properly which I fixed with this guide here. This step was not necessary when I installed the OS some years ago for the first time.

    Up until the first forced reconnect from my ISP the IP-adress of my router matched with the one in the DNS-record. But after that it did not refresh anymore. The error message in the Dashboard says (I hope this matches the english version of the message): The dynamic DNS information cannot be updated. Details to this message says furthermore: The DNS-information cannot be updated because no connection to the domain name provider can not be established. Contact your domain name provider. And after the lifespan of the DNS-record expires additionally the error message appears that the domain name can not be resolved...Unsurprisingly.

    The weird thing is that DynDNS for AnywhereAccess/RemoteWebAccess has never been an issue with the old and now overwritten OS installation. In desperation I made a bare metal recovery from the old OS installation to check the behaviour of DynDNS which worked still just fine. A second WS2012R2E-installation inside a VM was a bit contradictory. The original remotewebaccess.com-domain could not be reinstated but a new one registered. Though I haven't checked if the new domain can update the DNS-record.

    Now with the once again reinstalled OS DynDNS acts as described above. Port forwarding (Port 443) on my router has been set up for testing purposes both via UPnP and after that manually. Didn't matter before reinstallation because it worked both ways. I deliberately left out Port 80 for security reasons.

    I have searched through the eventlog and the Internet, to no avail. The only remotely useful hint was to change the Windows Live-password, had no effect. And the Eventlog is so overwhelmingly packed with events of any kind. I also ran several times the repair wizard from the Dashboard with always the same error. I even was unable to release my subdomain through the configuration wizard.

    I can imagine that the public certificate from GoDaddy needs to be imported somewhere for authentication to make DNS-record updates possible. But that would make the Windows Live-login obsolete.

    Has someone any advice how I can get the DynDNS-service back up running? Or where I have to search for more detailed hints for the cause? I have already considered that it is not a "broken service" of the OS but rather an external issue beyond my control (which suggests the error message). But that contradicts the fact that the recovered installation was able to update the external DNS-record. If the cause is really external who is the correct contact? GoDaddy or Microsoft?

    Maybe do I miss some windows updates or update rollups that do not come through Windows Update? I have updated the OS only via the OS-internal Windows Update function and right after installation some with wsusoffline.


    • Edited by Besieger Tuesday, October 10, 2017 6:56 AM
    Tuesday, October 10, 2017 6:24 AM

All replies

  • Hi,

    According to your description, my understanding is that it prompts “The dynamic DNS information cannot be updated” for RWA on newly install OS.

    >The DNS-information cannot be updated because no connection to the domain name provider can not be established. Contact your domain name provider.
    Please try to install the latest Update Rollup on your server. re-start the system and check the result:
    https://support.microsoft.com/en-us/help/4041693

    If problem persists, please provide me the log files - %programdata%\Microsoft\Windows Server\Logs. As it is a newly installed server, you can package “Logs” folder.

    You can upload file to OneDrive (https://onedrive.live.com/), share it and provide me the access link.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, October 11, 2017 9:37 AM
    Moderator
  • Hallo!

    thank you for your answer and your advice! Installing the update rollup had no effect. is this rollup supposed to adress this issue?

    But meanwhile I figured out that the remotewebaccess.com-subdomain was not registered anymore contradictoy to that what the dashboard stated. I have reregistered the domain. But that only fixed an certificate issue I encountered. The issue with the DynDNS-update is still persisting. I have uploaded the logs to OneDrive: https://1drv.ms/u/s!AM_NesRYMb7egk8

    I hope that helps to find the cause of that issue. Thank you very much for your effort!

    Best Regards,

    J.Arnold


    • Edited by Besieger Wednesday, October 11, 2017 8:17 PM
    Wednesday, October 11, 2017 8:11 PM
  • Has noone any advice on this topic? :-(
    Thursday, October 19, 2017 10:01 AM