locked
App-V packages won't run until they are fully download - App-V 5.0 SP2 RRS feed

  • Question

  • Hey guys

    we're using App-V 5.0 in our Pooled VDI environment
    we waited for HF4 for a long time to be able to upgrade from SP1 to SP2

    now we have a new Base Image with that client and with %APPDATA% folder redirection (unlike the Base Image with SP1 client that the %APPDATA% is local

    we're facing a weird issue that I couldn't find any solution for it

    When user logs on to the SP2 HF4 image, it takes FOREVER until we see App-V package shortcuts and can start using them (Some of the packages are a few GBs).

    Finally when the packages fully arrive I see on the App-V Client UI that the package is ready for offline use! though we never check the Force application(s) to be fully downloaded before launching (recommended for low/WAN networks) during the streaming phase while sequencing

    when I go to the Event viewer I see thousands of these:
    it's like there's an event for each file in each package

    The same user with the same permission logs on to an image with SP1 client and he can start use App-V packages immidiately.
    even if we load the packages manually it doesn't take so much time like it does on the logon refresh

    nothing has changed in our client configuration settings between the versions

    any suggestions?

    thanks


    Tamir Levy

    Tuesday, June 17, 2014 5:29 AM

All replies

  • Hi Nicke

    thanks for your reply

    We do use Autoload=1 which should load only the previously used apps. though this setting is the same on the App-V 5.0 SP1 image and the App-V 5.0 SP2 image and they act differently

    as I mentioned, the SP2 image have the same policy but the %APPDATA% which is redirected to a network share. I don't know if it connected somehow, cause I know all the pointers and the loading is to %LOCALAPPDATA% which is identical

    I'll try to change the setting to 0 and see how it goes, though it still doesn't make sense to me

    If I have 7 apps and one of them is previously used and one of them weight 2GB, when I logon, if the this is the second app that streamed from server, I won't have the shortcuts of apps 3 to 7 until the full stream has finished?


    Tamir Levy

    Tuesday, June 17, 2014 9:54 AM
  • Any progress? Did changing the setting have any effect?

    Brandon
    MDOP on the Springboard Series on TechNet

    Tuesday, July 8, 2014 4:52 PM
    Moderator
  • Hi Brandon

    thanks for asking

    unfortunately, changing the value didn't improve anything :/

    when I login, if I have a package that weight 4GB it takes forever for the publishing to finish

    I reset the client's profile so I know for sure it has nothing with it

    what is even weirder - is that I tried to change the App-V client policy to run in SharedContentMode so theoretically there shouldn't be any streaming of the package. just the creation of the local symbolic links.

    I don't know if it is related but does anyone know if I need to delete all the local cache when I change the client to sharedcontent mode?


    Tamir Levy

    Wednesday, July 9, 2014 6:36 AM
  • Hi Guys

    Still waiting for an answer.

    we're experience this behavior for a while and we also upgraded to HF5

    when I sync my client I see thousands of messages in the event viewer with the 14024 eventid

    and it is not just a single package, it is for every large package (Office 2013, Visio, PaintShop Pro...)

    I tried to remove all the client cache, uninstall the client and reinstall everything back again - still the same result


    Tamir Levy

    Wednesday, July 30, 2014 7:14 AM
  • Tamir,

    A few points.

    The screenshot you provided from the operational logs are normal, they are not errors.

    Are you running a non persistent (clean machine every time) VDI environment?  If so, in your master image do you have any C:\ProgramData\App-V\ folders?
    Are you excluding %Appdata%\Microsoft\App-V\Client\Catolog\ from roaming in user profiles?

    Are you definitely having apps cache fully at logon, or is it the sparse file creation in large packages that is taking a long time? Do your packages have any add or publish scripts?

    As for the event IDs, that is normal in my opinion, they aren't error or warning logs, just information logs.  It might be indicative of downloading happening at publish time (since you have so many), but they aren't errors or anything.

    Wednesday, July 30, 2014 12:55 PM
  • Hi Agalucci

    thank you for your reply. I know this is not an error. it's just there's event for every file of every unsynced package and it can take an hour until the sync completes.

    * my environment is non-persistant VDI

    * We do have some Applications on the master image so it includes C:\ProgramData\App-V

    * This is a tricky one. I use standard folder redirection on my %APPDATA% folder, so... you tell me. I use citrix UPM for roaming. from my understanding it is useless to exclude the catalog folder from there as %APPDATA% is not managed via UPM.  tried to find what is the best practice in this case and couldn't find a documentation about running a logoff script that will delete this folder.

    we don't update our master image very often so there are some applications that are synced only when the users logon (BTW, we also use Share Content Mode)

    but my complain is about the fact that Office 2013 for example, it can take 20 minutes to sequence, which in fact it doesn't need to download the package as we use Shared Content Mode so I don't uderstand why it is taking so long


    Tamir Levy

    Thursday, July 31, 2014 4:59 AM
  • Hmm so now I'm a little more confused...

    The example with Office 2013 is interesting because even downloading in full shouldn't take 20 mins for it to come down. 

    Does this delay happens with clean profiles, not just with 'dirty' ones?  If so then its likely not a roaming issue.

    Also I just want to double check...

    When you log in and office has taken the 20 mins, if you check in powershell it says the package is 100% loaded?

    Are you excluding the C:\ProgramData\App-V folder from your AV?  We had MAJOR delays with sparse file creation until we excluded that.

    Other then that not coming up with anything particularly helpful... I'll keep trying to think of something though.  It might be worthwhile for troubleshooting to include some exclusions, here is a post made by a user here who uses UPM -- Look at the answer by CodyLambert

    http://social.technet.microsoft.com/Forums/en-US/c859338d-cb9a-49b2-b9a6-3a9681ab3a15/appv-50-sp2-client-cant-synchronize-after-initial-login-with-profile-management-error-070000000b?forum=mdopappv

    Thursday, July 31, 2014 2:33 PM
  • Agallucci, thank you so much for your time

    I appreciate your effort of trying to help me and for your technical answers

    I haven't checked anything with antivirus so far. I know that 4.6 has best practice recommendations regarding to antivirus but nothing about 5.0

    the slow sync is also on a clean computer. I will try to simulate it on an image without McAfee agent installed and compare the results.  it does sound something that can interrupt. another option I will try to remove the WebSense client which also controls the network traffic.

    will update you as soon as possible


    Tamir Levy

    Monday, August 4, 2014 7:48 AM
  • Hi, I'm seeing this behaviour, disabling Mcafee makes no difference. I'm seeing this with big packages like the adobe products. The applications will not load until 100% cached locally.
    Monday, August 4, 2014 2:32 PM
  • Ian,

    What streaming options did you choose at sequence time?  You are seeing this with only with large packages and not all?
    What about the autoload keys as posted above?

    Monday, August 4, 2014 7:10 PM
  • Can you give some more detail on the infrastructure please.

    1.  Full AppV Infrastructure, SCCM or standalone?

    2.  List of current AppV related UPM exclusions

    3.  Provisioning technology and version

    4.  Get-AppVClientConfiguration output

    5.  Get-AppVPublishingServer output (minus the personally identifiable data)(If you are using the full infrastructure)

    Monday, August 4, 2014 7:22 PM
    Moderator
  • Hello, I think I need to clarify that our problem is mainly with the Adobe CS6 products. Launching other software of say 150MB seems to load fine. I have a standalone app-v 5 server running on hyper V. It has about 4GB Ram, it's no beast but in comparison to our 4.5 live servers it matches them.

    I just find the Adobe Products are very sluggish, they will launch before reaching 100% but they are very sluggish. If a user logs off and back on the applications still aren't that great to launch and that's with them 100% cached.

    Our Autoload is set to 1.

    The streaming option we choose is we are a fast network so we don't need the application fully streamed down.

     

    Wednesday, August 6, 2014 8:52 AM
  • Ian,

    Can you try Shared Content Store?  Does the app behave better once it is fully downloaded?

    Tim Mangan did a really great job on his performance white papers, they are worth the read.

    http://www.tmurgent.com/appv/index.php/resources/research/293-deploymentperformance

    Wednesday, August 6, 2014 2:43 PM