locked
Lightweight Gateway Fails to Start-Sequence contains more than one element RRS feed

  • Question

  • Hi All,

    I've recently completed the deployment of a large number of ATA lightweight gateways in our environment.  All of them are working great, except for one. The service hangs on starting for a long period of time and then fails to start. This is a server 2008r2 standard domain controller, and the recurring error I can find in the Microsoft.Tri.Gateway-errors file is below:

    2017-07-07 20:20:57.4359 2604 5   00000000-0000-0000-0000-000000000000 Error [Enumerable] System.InvalidOperationException: Sequence contains more than one element
       at System.Linq.Enumerable.Single[TSource](IEnumerable`1 source)
       at async Microsoft.Tri.Gateway.Resolution.DirectoryServices.DirectoryServicesClient.ConnectDisconnectedDomainControllersAsync(?)
       at async Microsoft.Tri.Gateway.Resolution.DirectoryServices.DirectoryServicesClient.OnInitializeAsync(?)
       at async Microsoft.Tri.Infrastructure.Framework.Module.InitializeAsync(?)
       at async Microsoft.Tri.Infrastructure.Framework.ModuleManager.OnInitializeAsync(?)
       at async Microsoft.Tri.Infrastructure.Framework.Module.InitializeAsync(?)
       at async Microsoft.Tri.Infrastructure.Framework.Service.OnStartAsync(?)
       at Microsoft.Tri.Infrastructure.Framework.Service.OnStart(String[] args)

    I've uninstalled/reinstalled, reset performance counters, rebooted, etc.  And I'm out of ideas.  Any help would be greatly appreciated.  Thanks!

    Monday, July 10, 2017 2:24 PM

All replies

  • Which version of ATA?

    Can you share the full textual logs files with us?

    You can contact us via ATAEval at Microsoft.com

    And ask to get contacted with me.

    Monday, July 10, 2017 9:01 PM