locked
Marvell Yukon Gigabit NIC only runs at 10/100 RRS feed

  • Question

  • I know there were some issues with the Marvell Yukon embedded NIC in the early beta stages of VISTA, however posts indicate that this has been sorted.

    However I have a Marvel Yukon 88E8056 embedded gigabit NIC (Gigabyte motherboard) running on a full-version of VISTA Home Premium edition and it will only run at 10/100!?

    I updated to the latest Marvell driver - 10.14.6.3 - and still no luck.

    Any takers!?

    Saturday, June 16, 2007 9:21 PM

Answers

  • I HAVE FOUND THE ANSWER... one of more of the ROM's that make up the NIC, needed updating. Just saw that a new BIOS version for my motherboard was released. It stated that the improvements were "...Add support for new super IO version".

     

    Anway, updated the motherboard and *bingo* my PC is now running at Gigabit speeds!  *yay*

     

    So, the issue was hardware based, not software/driver based. 

    Saturday, July 7, 2007 11:16 PM

All replies

  •  

    UPDATE... Marvell have released some new drivers in the last few days - 10.15.7.3/10.15.9.3.

     

    I have the latest installed, but still no joy!?

     

     

    Saturday, June 30, 2007 11:19 PM
  • By default the inbox driver has the flow control flag turned off. Turn it back on via Device Manager and reboot to see if the issue is resolved.
    Thursday, July 5, 2007 6:30 AM
  •  

    Nope... that's not it. If 'Flow Control' is disabled, you often get your NIC not working at all. Mine was enabled by default.

    Saturday, July 7, 2007 3:45 AM
  • Have you tried going back/rolling back to the in-box driver, enable flow control (disabled by default), & rebooting to see if the in-box driver is a better driver? 

     

    Driver vendors turn on flow control for out-of-box drivers.

    Saturday, July 7, 2007 2:48 PM
  • I HAVE FOUND THE ANSWER... one of more of the ROM's that make up the NIC, needed updating. Just saw that a new BIOS version for my motherboard was released. It stated that the improvements were "...Add support for new super IO version".

     

    Anway, updated the motherboard and *bingo* my PC is now running at Gigabit speeds!  *yay*

     

    So, the issue was hardware based, not software/driver based. 

    Saturday, July 7, 2007 11:16 PM
  • I recently flashed my bios with the latest version for vista SP1, but unfortunately, no luck.  Could you tell me what MB you're using?  I'll also go back out and check if there's a newer version of the bios. 
    Monday, March 24, 2008 12:17 PM
  • Well, I double checked last night, and I have the latest version of the BIOS.  I tried the new drivers from Marvell, no luck.  I just saw a post about the NetworkThrottlingIndex in the registry, and I might try that tonight.  I would really like to be transfer files across my local network at gig-e, so I hope that this works.  I am considering just buying an Intel gig NIC, but I would hate to spend the money if I didn't have to.

    Any help with this situation would be greatly appreciated.

    Thanks
    Tuesday, March 25, 2008 9:04 PM