none
MAP TK install failed on Win 2016/SQL Server 2017 RRS feed

  • Question

  • Attempted to install MAP TK 9.9.13 on SQL Server 2017 Std on Windows 2016 Std.  I first created a named instance “MAPS”.  Install failed with error: “Assertion failed”.  Repair failed.  Uninstall failed.  It seems like MAP can't access the MAPS named instance.  My account is local admin and SQL sysadmin. The default instance MSSQLSERVER is listening on a non-default port.  I did the original MAP install with the MAPS named instance listening on "All IPs".  Then, I also tried the uninstall and repair operations after configuring MAPS instance to listen on another non-default port.  No luck.  The only thing I can think of at this point is that MAP requires TLS 1.0 which is not enabled on my server; only TLS 1.1 and 1.2 are enabled.  

    Tuesday, April 16, 2019 10:17 PM

All replies

  • Facing exactly the same issue with MAP 9.9.13 on SQL 2016 express on Win 2012 R2. First created the instance "MAPS". Install failed with error : "Assesrtion Failed", Cant repair or clean unsintall.

     Tried uninstalling via Uninstall String in Registry however that says product not found. MAP toolkit appears in the installed software though but then while launching gives error that "A failure occured while validating the MAP Toolkit configuration database.

    Uninstalled the localdb "MAPToolkit" and deleted the residue folder "C:\Users\"current user"\AppData\Local\Microsoft\Microsoft SQL Server Local DB\Instances\MAPToolkit"

    Tried Reinstalling MAP TK but same "Assertion Failed" Error. Checking internally.


    Wednesday, April 17, 2019 9:06 PM