locked
Exchange 2010 - how to troubleshoot intermittent Outlook slowness RRS feed

  • Question

  • I'm having users report intermittent Outlook slowness 2007.  I can't repeat the issue exactly but I have seen it -- you get a message that says "Outlook is trying to retrieve data from <Exchange Server>" and it takes it a noticeable amount of time.  One of the difficulties in troubleshooting this is that I haven't seen it on my own machine, nor can I find the way to replicate the issue consistantly.

    We actually just upgraded from Exchange 2003 to Exchange 2010 and never had these issues in the past.   I've run a process monitor on the server (which is about 8 times better than our old Exchange 2003 server - 2 quad-core procs and 12 GB of RAM for about 250 mailboxes) and find nothing abnormal in terms of CPU time or network bandwidth usage (4 teamed 1 GB/s connections).  I have also monitored several of the Exchange RPC items, and Client: RPCs but Client:RPCs does not return anything at all (just 0 the whole time).   Are there other things I should be looking at with PerfMon?


    I'm at a point where I'm not sure where to take my troubleshooting.  Does anyone have any ideas?  The fact that I (and most other users I've asked) never experience the issue leads me to believe that it might have something to do with a local computer issue rather than a server issue, but I'm hearing reports from people with both Outlook 2007 and Outlook 2010.  The other somewhat common thread is that

    Outlook is NOT running in cached exchange mode, but it wasn't when we were on the 2003 server either and we did not have this issue.   Our Exchange 2010 Server is now running the new UM role, however, and we were using Cisco Unity before. 

    I have already disabled all Outlook add-ins and disabled anti-virus (client, but not Nod32 for Exchange).

    Thanks, any ideas would be appreciated.

    Wednesday, March 16, 2011 7:40 PM

Answers

  • Forgot you're using 2010, the item counts are much more laxed, 100,000 per folder compared to 5000 in Exchange 2007. For your Outlook 2007 clients, can you confirm you're up to date on the last post hotfixes as of Feb 2011? Also I would disable caching of shared calendars in outlook. Also note that outlook 2010 caches all shared mailboxes by default.

     

    1. Turn off calendar caching. If you have Exchange in use then Outlook 2007 may well have the caching of people’s calendars turned on. This means that when you open a calendar you have to wait for the cache to populate, which can slow things down a bit sometimes. To do this:
    2. Go to the Tools Menu and select Account Settings
    3. Select your Exchange Account and press the change button
    4. Press the more settings button
    5. Select the 2nd tab (Advanced)
    6. Un-tick the “Download shared folders” option. Note that this will stop cached Sharepoint folders from downloading into Outlook as well.
    7. Press OK until all options are saved.

     

    Description of the Office Outlook 2007 hotfix package (Outlook-x-none.msp): February 22, 2011
    http://support.microsoft.com/kb/2475891

    Description of the Outlook 2010 hotfix package (outlook-x-none.msp): February 22, 2011
    http://support.microsoft.com/kb/2475877


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Gen Lin Tuesday, March 29, 2011 1:34 AM
    Friday, March 18, 2011 12:25 AM

All replies

  • How are you sites layed out? I would investigate if you need to use the closestGC reg key. It seems you did some adequate toubleshooting already, sample some of the users computers that are experiencing the slowness and ctrl + right click their outlook icon and select connection status, see if their using a local GC to their site and not the Exchange server in the datacenter.

    Also, if there is no server side latency (rpc latency times, disk bottlenecks etc) and it's always the same users, make sure their item counts in outlook do not exceed 5000 per folder. Also check to see if these users are also opening shared mailboxes.

    Run Exchange Best Practice Analyzer as well.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Wednesday, March 16, 2011 8:27 PM
  • How are you sites layed out? I would investigate if you need to use the closestGC reg key. It seems you did some adequate toubleshooting already, sample some of the users computers that are experiencing the slowness and ctrl + right click their outlook icon and select connection status, see if their using a local GC to their site and not the Exchange server in the datacenter.

    Also, if there is no server side latency (rpc latency times, disk bottlenecks etc) and it's always the same users, make sure their item counts in outlook do not exceed 5000 per folder. Also check to see if these users are also opening shared mailboxes.

    Run Exchange Best Practice Analyzer as well.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com


    Thanks James.

    We actually only have one site with a single GC, so the GC will always be the same and the closest possible since it is the only one.

    It seems like a lot of the users experiencing the issue have large calendars with a lot of items, but others have extremely small exchange accounts (but do connect to several large Shared Calendars).  It is strange that it is always the same users.

     

    Thursday, March 17, 2011 7:06 PM
  • How big is the mailbox that's setup on that Outlook? Try opening a mailbox that does not have much data in it. Also, is that Outlook in cache mode?
    Thursday, March 17, 2011 7:21 PM
  • Forgot you're using 2010, the item counts are much more laxed, 100,000 per folder compared to 5000 in Exchange 2007. For your Outlook 2007 clients, can you confirm you're up to date on the last post hotfixes as of Feb 2011? Also I would disable caching of shared calendars in outlook. Also note that outlook 2010 caches all shared mailboxes by default.

     

    1. Turn off calendar caching. If you have Exchange in use then Outlook 2007 may well have the caching of people’s calendars turned on. This means that when you open a calendar you have to wait for the cache to populate, which can slow things down a bit sometimes. To do this:
    2. Go to the Tools Menu and select Account Settings
    3. Select your Exchange Account and press the change button
    4. Press the more settings button
    5. Select the 2nd tab (Advanced)
    6. Un-tick the “Download shared folders” option. Note that this will stop cached Sharepoint folders from downloading into Outlook as well.
    7. Press OK until all options are saved.

     

    Description of the Office Outlook 2007 hotfix package (Outlook-x-none.msp): February 22, 2011
    http://support.microsoft.com/kb/2475891

    Description of the Outlook 2010 hotfix package (outlook-x-none.msp): February 22, 2011
    http://support.microsoft.com/kb/2475877


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Gen Lin Tuesday, March 29, 2011 1:34 AM
    Friday, March 18, 2011 12:25 AM
  • Calendar caching is actually already off, that doesn't seem to be the issue...

     


    Wednesday, May 4, 2011 7:02 PM
  • I am now using Outlook 2010 and still seeing the same issues.

     

    Strangely, my Outlook 2007 clients are in non-cached mode, and the 2010 clients are in cached mode.  The issue is still occuring.

     

    Also strange, the issue only seems to happen for certain users, but not at all for others.  It is still intermittent.

     

    Any ideas?  This is still not solved...

    Thursday, May 5, 2011 8:50 PM
  • We seem to be experiencing the same thing for the last 3 weeks or so. Certain users waiting for Outlook to connect to the server.  The server has plenty of resources and does not show errrors in the logs.    It seemed to have started a week or so after I installed the "Update Rollup 2 for Exchange Server 2010 Service Pack1" update and other server patches about a month ago.  The server has more than enough resources with only about 250 mailboxes.  (We Virualized the Server and migrated of of Exchange 2003 about 9 months ago.) It is running on vSphere 4.1 and has 2 processors and 12GB of RAM.  I could throw more processor and RAM at the server but I'm sure it doesn't need it.   The majority of our users are using Outlook 2007 with a few of us on Outlook 2010.  We don't use "Cached Mode"

    Since this is such a random thing it is very hard to troubleshoot.   Any Ideas on would be appreciated!

    We're not sure where to go from here.....Thanks!

    Tuesday, May 17, 2011 8:59 PM
  • Does this hotfix (http://support.microsoft.com/kb/2475891) have any fixes for slow calendar performance? 

    I didn't see any mention on the hot fix page?

    Wednesday, March 14, 2012 3:49 PM
  • So I have a similar issue with one of my user. She continue to have latency issue where outlook locks out when either typing a big email. She is connected to her boss mailbox as well as his calendar.
    Tuesday, January 7, 2014 7:18 PM