Errors in programlog.txt (FSE SP2 Rollup 1)


  • Can someone please explain why notifications can't be sent?

    I did some research here and it looks like it only affects our CMS. We have 2 CMS on 4 nodes at this point and I see errors in programlog.txt file:

    First this:

    Fri May 07 15:32:45 2010 ( 7384- 5452), "ERROR: muiresource.cpp::MuiResource::FormatString(): Unable to access resource.  ID:272  Module:"C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\GetEngineFiles.exe"  Error Code:1814  Error:"(0x00000716) The specified resource name cannot be found in the image file.  Failed to load string 272 from resource 0x00400000, filename "C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\GetEngineFiles.exe"""

    Then this:

     Fri May 07 15:32:47 2010 (7056-   5), "INFORMATION: Attempting to send mail using input file C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\Pickup\26.eml"
    Fri May 07 15:32:47 2010 (7056-   5), "INFORMATION: Found <HUB_server_FQDN> as the next server"
    Fri May 07 15:32:47 2010 (7056-   5), "INFORMATION: Failed to send a message from the file C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\Pickup\26.eml. Microsoft.FSE.MailPickup.UnexpectedSmtpServerResponseException: Unexpected SMTP server response. Expected: 250, actual: 454, whole response: 454 4.7.0 Temporary authentication failure because negotiated Tls cipher strength is too weak

       at Microsoft.FSE.MailPickup.SmtpTalk.CheckResponse(ServerResponseInfo response, Int32 expectedCode)
       at Microsoft.FSE.MailPickup.SmtpTalk.Command(String protocolText, Byte[] binaryData, SmtpCommandType command, Int32 expectedCode)
       at Microsoft.FSE.MailPickup.SmtpTalk.Ehlo()
       at Microsoft.FSE.MailPickup.SmtpClient.Submit()
       at Microsoft.FSE.MailPickup.SmtpStrategy.ProcessFile(String fileName)"

    Fri May 07 15:32:47 2010 (7056-   5), "ERROR: Unexpected exception"
    Fri May 07 15:32:47 2010 (7056-   5), "INFORMATION: Renaming message file C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\Pickup\26.eml to C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\Pickup\26.634088431676898073.bad"

    One of these messages means that notification can't be sent. It works fine on our HUB servers though. This problem is only on clustered mailbox server. I've tried to add it to our SMTP relay pool in case FSE is using SMTP to send notifications but it didn't help.

    Also when I try to update Kasperski scan engine I get this error:

    Fri May 07 14:52:00 2010 ( 6892- 9324), "INFORMATION: Attempting to download the Kaspersky5 scan engine package from"
    Fri May 07 14:57:14 2010 ( 6892- 9324), "ERROR: Failed to extract the file(s) from 'R:\ForefrontCluster\Engines\x86\Kaspersky5\Package\Staging\': 8: Failure writing to target file. CAB is readable. "
    Fri May 07 14:57:14 2010 ( 6892- 9324), "INFORMATION: The Kaspersky5 scan engine has been rolled back."

    This one might be related to the timeout which I'll increase later on tonight when servers are not as busy.

    Another odd thing is that I don't see anything happening on CMS FSE. All zeros, been for hours. Realtime is enabled and everything. HUBs are taking care of all the mailflow and stamp all the messages after they are being scanned I understand that, but we have realtime enabled on FSE on CMS too. Why then new messages that users create are not being scanned by FSE in realtime on store level before they are sent out?

    I've tried to create a file filter and then send the 'dummy' file and it wasn't removed on a store level. It just went through without any problems. FSE Cluster service is up, CMS fails over fine without any problems. Everything seems to be working but nothing is really going on on store level FSE.

    FSE 10 SP2 Rollup 1
    Exchange 2007 SP1 Rollup 5 on stores and Rollup 6 on HUBs. no Edges.


    Friday, May 07, 2010 7:56 PM


All replies

  • Also the log file is full of errors like this:

    Fri May 07 16:07:39 2010 ( 4260- 7120), "ERROR: muiresource.cpp::MuiResource::LoadStringW(): Unable to access resource.  ID:414  Module:"C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\FSCRealtimeScanner.exe"  Error Code:1813  Error:"(0x00000715) The specified resource type cannot be found in the image file.  Failed to load string 414 from resource 0x00400000, filename "C:\Program Files (x86)\Microsoft Forefront Security\Exchange Server\FSCRealtimeScanner.exe""

    The only difference is the number in parenthesis.

    Friday, May 07, 2010 8:09 PM
  • Hi,


    I would like to suggest that you contact Microsoft Product Support Services via telephone so that a dedicated Support Professional can assist with this request.


    To obtain the phone numbers for specific technology request please take a look at the web site listed below.



    If you are outside the US please see for regional support phone numbers.


    Thank you for your patience and understanding.



    Nick Gu - MSFT
    Friday, May 14, 2010 3:01 AM
  • Hi Any luck with this?  I know it is a bit outdated...  Thanks  :-)
    Tuesday, July 30, 2013 5:54 PM