none
Pinning items to the task bar icon RRS feed

  • Question

  • We use office 2003 and Windows 7 Pro. I have word and excel both pinned to my task bar and want to have recent applications show up on the list and be abel to pin the most used ones to the top. This works fin for the word app. but can not get it to work for excel. Does anyone have any ideas as to why excel would not work? Is there a way to backup the settings once we get it to work?

    Thanks

    bob wiggins

    Thursday, July 29, 2010 5:32 PM

Answers

  • Hi Bob,
    Please check this setting in Excel 2003:
    Click Tools, Options, then the General tab
    Check the recent documents list box and set the number of recent documents to display

    If the option to change the number of recent documents is unavailable, “grayed out.” In that case, Windows itself is preventing the display of a recent documents list. To
    see if recent documents are disabled everywhere:

     

    Click Start, then Run
    Enter regedit
    Navigate to the following registry entry:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\
    CurrentVersion\Policies\Explorer

    In the right-hand pane, see if there is a DWORD named “NoRecentDocsHistory”. If there is, either delete it or set its value to zero. Then close regedit and reboot.

    • Marked as answer by cmtbob Tuesday, August 3, 2010 2:45 PM
    Tuesday, August 3, 2010 6:31 AM
    Moderator

All replies

  • Hi Bob,

    Drag the Microsoft Excel 2003 icon that you've added as a shortcut to the Windows desktop and drop it into its desired position on the Windows 7 taskbar.

    After you pin an Excel 2003 icon to the Windows 7 taskbar, the button appears on the Windows taskbar each time you start your computer.

    If you cannot pin Excel 2003 by this way, please try to click Start->All Programs->Microsoft Office->Excel 2003 and right-click on it to choose "Pin to Taskbar".

    Hope it helps.

    Friday, July 30, 2010 8:13 AM
    Moderator
  • I can pin the app there just fine, I can't pin documents. After you open an excel sheet and then close it out, it dosn't show up when you right click on the excel icon in the task bar as it should. Since it dosn't show up as a receient document you can't pin it to the top either. Word seems to work just not excel.
    Friday, July 30, 2010 2:14 PM
  • Hi,

    Sorry, actually I don't understand your meaning very clearly.

    I have tried to pin my Excel to taskbar and there is no problem. I can open it in taskbar fine.

    So could you give me more details on this issue?

    Monday, August 2, 2010 6:50 AM
    Moderator
  • Ok sorry for the confussion. Lets look at it from the beginning. I install office on my computer, then I click onthe start button and select all program, Microosft Office and right click on excel and select pin to task bar. Then I right click on word and select pin to task bar. Now both apps are in my task bar. Now lets say throughout the day I open 3 documents in word, Doc1, Doc2 & Doc3. Then also open 3 excel files, excel1, Excel2 & Excel 3. If i go to word in the task bar and right click I will see all 3 word docs listed that I had previously opened and I will have the option to pin any of the three to the top of the menu to always be listed on top of the list (whereas the bottom of the list is the most recently opened ). This is how it should work and dose for word, however when I right click on Excel in the task bar It dose not show the three excel files I had recently opened. There is nothing in the list at all and when I open and close excel files they never show up in the list.
    Monday, August 2, 2010 1:56 PM
  • Hi Bob,
    Please check this setting in Excel 2003:
    Click Tools, Options, then the General tab
    Check the recent documents list box and set the number of recent documents to display

    If the option to change the number of recent documents is unavailable, “grayed out.” In that case, Windows itself is preventing the display of a recent documents list. To
    see if recent documents are disabled everywhere:

     

    Click Start, then Run
    Enter regedit
    Navigate to the following registry entry:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\
    CurrentVersion\Policies\Explorer

    In the right-hand pane, see if there is a DWORD named “NoRecentDocsHistory”. If there is, either delete it or set its value to zero. Then close regedit and reboot.

    • Marked as answer by cmtbob Tuesday, August 3, 2010 2:45 PM
    Tuesday, August 3, 2010 6:31 AM
    Moderator
  • Thanks for the info. Excel was set correctly already and the registry entry was not there so It still was not working but I followed the link you provided and dragged a excel document on top of the taskbar icon and that pinned it correctly. Now when I open an excel file it shows up. Thanks for the help.

    Additional question: can theses settings be backup and saved? if you are using this for word & excel & explorer the list can get pretty long in each one so is it possible to backup theses lists?

    Thanks for the help.

    Robert Wiggins

    Tuesday, August 3, 2010 2:45 PM
  • Hi Robert,

    See this article about Backup User and System Files of Windows 7.

    http://www.sevenforums.com/tutorials/615-backup-user-system-files.html

    Thursday, August 5, 2010 3:48 AM
    Moderator
  • But isn't their just one file I can copy like the .nk2 file for outlook memorized email addresses?
    Monday, August 9, 2010 10:56 PM