locked
Exchange 2016 - Mails stuck in outbox RRS feed

  • Question

  • Hello, can somebody help me with the following Exchange problem?

    Sometimes happens that the mails are getting stuck in the outbox folder in Outlook, if I click on "Send all" they are still in outbox. Sometimes they are marked with the sending icon (envelope) and sometime with the edit icon (the pencil). If I open it and click on send I have the mail doubled in outbox, one with the sending/edit icon and the other without an icone, like as it was sent but checking the logs it is not.

    This is what I have on the exchange


    The only way I found to send these mails is to restart the Microsoft.Exchange.UM.CallRouter.exe service, then afer a while some of the mails are automatically sent and for some others I need to open them and click on send.

    We are running Windows Server 2016 with Exchange 2016. All the users are working on a RDS Server (Windows Server 2016 with XenApp 7.15) with Microsoft Office ProPlus 2016 64-bit.

    Thanks


    • Edited by BdTim Tuesday, November 6, 2018 11:02 AM .
    Tuesday, November 6, 2018 11:01 AM

Answers

  • @dvrooij thanks for the suggestion, the inheritance was already activated.

    The problem is solved: we have multiple mailboxes for each user, seems that outlook is not able to change the credentials fast enough when they are sending a mail form a different mailbox. We fixed it sharing the mailboxes, we gave Full Access and Send As rights to the main mailbox of the user and works fine.

    • Marked as answer by BdTim Thursday, December 20, 2018 9:04 AM
    Thursday, December 20, 2018 9:04 AM

All replies

  • Hi Mate,

    Quick question users are working in an RDS Environment, do they have cache mode turned on ? One Exchange Server and how many users ? 

    Kind Regards,

    Daniel Giallombardo

    Wednesday, November 7, 2018 9:50 AM
  • Hi,

    How many users are affected by this issue? Are these stucked emails normal emails or voice mails?

    Do you have UM deployed in your Exchange organization?

    >>The only way I found to send these mails is to restart the Microsoft.Exchange.UM.CallRouter.exe service, then afer a while some of the mails are automatically sent and for some others I need to open them and click on send.

    Since restarting the service could fix the issue, we may try running the following command to retrieve the UM.CallRouter health set details, then review the command output to see there is any ‘Unhealthy’ state reported by the monitors.

    Get-ServerHealth server1.contoso.com | ?{$_.HealthSetName -eq "UM.CallRouter"}

    Besides, please have a look at the Event Logs and see whether there are any related warnings or errors.

    Please also run the Get-MessageTrackingLog cmdlet and see whether there is any clue in the message tracking log.

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, November 7, 2018 9:55 AM
  • Hello,

    We have 6 users working on the server and all of them are affected by this problem. The stucked mails are only normal mails. Cache mode is off. I've tried to re-create the outlook profile but it doesn't help.


    These are the server roles:
    Cafe, Mailbox, ClientAccess, UnifiedMessaging, HubTransport, FrontendTransport

    As you can see in the following picture, there is no Unhealthy state.

    What I have noticed running Get-MessageTrackingLog is that when a mail is getting stuck I have repeatedly these three EventId until I restart UM.CallRouter service: NotifyMapi, Receive, SubmitDefer. After the service is restart then I have Submit.


    At the biginning I was thinking that is an Exchange misconfiguration, but now I'm wondering if the problem is on outlook itself.
    For what I can see, sending mails via OWA works fine but since the users are not using OWA and the issue happens intermittently I cannot prove it.
    • Edited by BdTim Wednesday, November 7, 2018 2:41 PM update
    Wednesday, November 7, 2018 2:33 PM
  • Do you actually use Unified Messaging within Exchange? If not, what about if you disable the UMservice? Are the emails routing correctly with it disabled?

    Alternatively what about disabling for the users on that RDP server - https://docs.microsoft.com/en-us/exchange/voice-mail-unified-messaging/set-up-voice-mail/disable-voice-mail


    • Edited by Ki_Kumo Wednesday, November 7, 2018 4:02 PM
    Wednesday, November 7, 2018 3:59 PM
  • I will disable UM for the users, thanks for the suggestion.

    Edit: Actually the UM is disabled for all the users, in this case I will try to disable the service.
    • Edited by BdTim Thursday, November 8, 2018 2:34 PM update
    Thursday, November 8, 2018 2:30 PM
  • The only thing I found checking the events is this warning occurring many times:

    The Client Access server isn't currently enabled and the Microsoft Exchange Unified Messaging call router can't listen on any TCP/UDP ports. Any existing connections will be disconnected.

    <Eventxmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="MSExchange Unified Messaging"/>
      <EventIDQualifiers="32772">1621</EventID>
      <Level>3</Level>
      <Task>8</Task>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2018-11-08T13:44:22.102503300Z"/>
      <EventRecordID>2473798</EventRecordID>
      <Channel>Application</Channel>
      <Computer>ExchangeServer.company.domain</Computer>
      <Security />
      </System>
      <EventData />
      </Event>





    • Edited by BdTim Thursday, November 8, 2018 2:52 PM
    Thursday, November 8, 2018 2:49 PM
  • Thank you for the update.

    >>These are the server roles:
    >>Cafe, Mailbox, ClientAccess, UnifiedMessaging, HubTransport, FrontendTransport

    May I know what the "Cafe" refer to here?

    >>Edit: Actually the UM is disabled for all the users, in this case I will try to disable the service.

    Have you tried disabling the service? Any luck?

    Since sending mails via OWA works fine, we may also try starting Outlook in safe mode (outlook /safe) and performing a Windows clean boot to troubleshoot the issue.

    Hope this helps.

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, November 21, 2018 10:18 AM
  • Thank you Steve for the answer.

    Since even our second level support was not able to find a solution to this they opted for a new exchange server.... even with the new exchange server the situation is the same.

    We tried a different mail client, when we have the issue it shows this error message:

    So that means it is an authentication problem?

    Thanks



    • Edited by BdTim Wednesday, December 12, 2018 8:34 AM
    Wednesday, December 12, 2018 8:24 AM
  • If you're using Active Directory to authenticate you might try checking whether permission inheritance is enabled.

    In AD check advanced features, and under Properties -> Security -> Advanced there should either be a button or checkbox for enabling inheritance.

    I've had your exact issue with several users, and it turned out this somehow got disabled for those users. Hope this helps!  

    Thursday, December 13, 2018 1:06 PM
  • @dvrooij thanks for the suggestion, the inheritance was already activated.

    The problem is solved: we have multiple mailboxes for each user, seems that outlook is not able to change the credentials fast enough when they are sending a mail form a different mailbox. We fixed it sharing the mailboxes, we gave Full Access and Send As rights to the main mailbox of the user and works fine.

    • Marked as answer by BdTim Thursday, December 20, 2018 9:04 AM
    Thursday, December 20, 2018 9:04 AM