none
Rebuilding msdsc manually RRS feed

  • Question

  • Hello,

    Records in the _.msdsc.DOMAIN  zone is missing all the srv records and folders like gc, dc, etc.

    I have already rebuilt msdsc zone by restarting netlogon, etc.  However, it repopulates with these records still emtpy.

    Is it possoble or me to rebuilt\input these records manually by looking at a similare domain control and reporducing them for this domain?  There is only one domain controller in this domain.

    Thanks

    Sunday, September 16, 2018 11:21 PM

All replies

  • Hi,

    Thanks for your question.

    • Please refer to the link below to rebuild the _msdsc zone:

    https://www.dell.com/support/article/sg/en/sgdhs1/sln155826/how-to-delete-and-recreate-the-_msdcs-dns-zone-on-a-windows-dns-server?lang=en  

    • Check the folder in the DOMAIN zone, which may contain records of the _msdcs.DOMAIN zone.
    • You can recreate the records manually, but you need to make sure they are correct.

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, September 17, 2018 2:08 AM
    Moderator
  • I already did the dell one but it didnt recreate the records.

    Tuesday, September 18, 2018 12:00 AM
  • Hi,

    Thanks for your reply.

    Have you downgraded DC? Is there an error in the event viewer?

    Best regards,

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, September 18, 2018 8:46 AM
    Moderator
  • After restarting Netlogon I get Netlogon event 5781.

    Dynamic registration or deletion of DNS of DNS records associated with DOMAIN.Local failed.

    Posible wrong IP addresses, etc.

    I think this may have started a long while ago when they were having issues on network with a rogue dhcp server.  I believe the person onsie had switched the server to dhcp and had been using a different IP address then originally setup.  Th IP address has since been changed back to the original IP address.

    Windows 7 pcs are working ok but windows 10 will not login in with new uses on their desktop althought previosuly configured users continue to work fine on with server shares, login, etc.  There is issue with joing domain though and it days the record for tcp ldap can't be found whihc led me to the DNS server to begin with.

    Tuesday, September 18, 2018 11:56 PM
  • Also I think the server is getting a ipv6 dns address and dns servers from the comcast router.  When I do a nslookup on the servname and timesout and says it is using server.comcast.net for the lookup.

    Not sure how that would cause the msdcs zone records to not register however.

    I had turned off ipv6 on the clients previosly because they were having issues getting comcast addresses as well.

    Can I change this on server?


    • Edited by 2010 Wednesday, September 19, 2018 12:12 AM
    Wednesday, September 19, 2018 12:09 AM
  • Hi,

    Thanks for your reply.

    Based on the complexity and the specific situation, I would suggest you contact Microsoft Customer Services and Support to get an efficient solution:

    http://support.microsoft.com/contactus/?ln=en-au  

    Have a nice day!

    Travis


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, September 19, 2018 8:51 AM
    Moderator