locked
Visio 2010 Plugin RRS feed

  • Question

  • Hi All

    Never had a problem before with Visio plugin for SCOM but am at a site and it won't work. When I enable logging get the following error:

    "System.PlatformNotSupportedException: The Client and server are not compatible --- Microsoft.EnterpriseManagement.Common.ObjectNotFoundException"

    I have all the pre-reqs installed and have tried re-installing everything. Have made sure I don't have the Azure MP as know this can cause the error. I have tried the console not patched and tried every roll up to UR5 but still not joy.

    Anyone any ideas?

    Thanks

    Friday, April 24, 2015 2:52 PM

All replies

  • Hi,

    Did you ever install Visio plugin before? If you have previously installed the Vision 2007 version of the Add-in on this computer, uninstall it before installing the Visio 2010 Add-in.

    Did you download it from the link below? Make sure you meet the below requirements.

    Supported Operating System

    Windows Server 2008; Windows Server 2008 R2; Windows Server 2008 R2 SP1; Windows Server 2008 Service Pack 2                
        • Other Software:
        • Visio 2010 Premium and (optionally) SharePoint 2010 Enterprise
        • System Center 2012 - Operations Manager

    http://www.microsoft.com/en-hk/download/details.aspx?id=29268

    In addition, please go through the links below to re-check these requirements:

    https://technet.microsoft.com/en-us/library/hh920815.aspx

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 27, 2015 8:20 AM
  • Hi

    Thanks for the reply.

    The machine was a clean windows 7 machine.

    I have even tried it on my laptop which I use to connect into customer SCOM systems to demo the plugin but this fails with exactly the same error.

    There was an issue originally where they had registered the SPN's incorrectly. They had been registered against the server rather than the SDK account. This has been fixed now and all management servers rebooted but am now getting the error mentioned above.

    Are there any other management packs which could cause this error. I have tried the console with all the different UR to rule out having the wrong console patch applied.

    Regards,

    Martyn

    Monday, April 27, 2015 8:33 AM
  • Hi,

    Would you please connect to our management server with another Windows Operating system, such as Windows Server 2012?

    How about re-installing the plugin on your server?

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 1, 2015 8:18 AM
  • Hi,

    did you install DataONTAP MP on your scom environment?

    Could you please execute this query on your opsmanager DB, and search for some NULL value in the ImageCategory column?

    SELECT [ImageReference].[ImageId], [ImageReference].[ReferenceId], [ImageReference].[ManagementPackId], [ImageReference].TimeAdded, [ImageReference].LastModified, SUBSTRING([EnumType].EnumTypeName, 1, 100) AS ImageCategory, [MPElementView].[MPElementName],
      [ManagementPack].[ContentReadable]
      FROM dbo.ImageReference 
      JOIN dbo.[Resource] on ([Resource].ResourceId = ImageReference.ImageId)
      LEFT JOIN dbo.[Category] ON [Category].CategoryTarget = [Resource].ResourceId
      LEFT JOIN dbo.[EnumType] ON [EnumType].EnumTypeId = [Category].CategoryValue
      JOIN dbo.MPElementView ON (ImageReference.ReferenceId = MPElementView.MPElementId)
    INNER JOIN dbo.[ManagementPack] ON dbo.ManagementPack.ManagementPackId = [ImageReference].ManagementPackId AND dbo.ManagementPack.ContentReadable = 1
    WHERE dbo.[ImageReference].[ReferenceId] IN (select dbo.ManagedType.ManagedTypeId from dbo.ManagedType)
        and dbo.[Resource].ResourceType = 4 

    Regards,

    --

    Donato

    Thursday, June 18, 2015 2:39 PM
  • Hi

    Yes we do have DataONTAP, have come across this at two sites now both with the ONTAP pack.

    Ran the command and didn't come back with any Null values.

    Martyn

    Monday, August 10, 2015 2:44 PM
  • Hi

    I tell a lie there is two Null Values for FCP Adapter.

    Regards,

    Martyn

    Monday, August 10, 2015 2:56 PM
  • You are not alone - I have the same issue at a client site. Tried reinstalling everything, both with Visio 2010 and 2013 and got the same error.

    I tried it in my demo environment too, I ended up reinstalling SCOM and then it worked regardless of supported platforms. I am running Server 2012 R2, SCOM 2012 R2 UR6 and Visio 2013.

    Monday, August 10, 2015 3:02 PM
  • I am stuck as can't re-install SCOM.

    I am running 2012 R2 CU6 and still have the issues.

    Driving me up the wall going to have to log a call with Microsoft.

    Monday, August 10, 2015 3:05 PM
  • This fixed my issue:

    http://community.netapp.com/t5/Data-ONTAP-Related-Plug-ins-Discussions/Problem-with-OCPM-4-1-for-Microsoft-SCOM/td-p/102138

    Visio and Exchange now working :)

    • Proposed as answer by ScottMoss Thursday, August 13, 2015 6:45 PM
    Tuesday, August 11, 2015 10:23 AM