locked
No new folder option in documents (Windows 7) RRS feed

  • Question

  • Hi all,

    I've been trying to fix a problem, help would be greatly appreciated??!!

    I have no new folder option in My Documents.  There is no icon on the task bar and no option for new folder when I right click?

    What is puzzling is that this function works on the Desk top and in Downloads.

    I have tried the below option and several others.

    1. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue.

     

    2. Locate and then click the following registry subkey:

     

    HKEY_CLASSES_ROOT\Folder

     

    3. Right click on the Folder key on the left pane, and then select "Export" to backup this registry key.

    4. Go to my skydrive and download folderfix.zip file.

    5. Save the folderfix.zip file on to your Desktop.

    6. Right click and extract the folderfix.reg file.

    7. Right click on the folderfix.reg file and then click Merge.

    8. Click Yes to confirm the modification.

    Please help!


    Monday, March 13, 2017 10:02 AM

All replies

  • Hi,

    The issue should be caused by damaged or incorrect registry key entry. Please check the following registry value:

    1. Click Start, type regedit in Search Bar, and then click regedit in the Programs list.

    Note: If you are prompted for an administrator password or confirmation, type your password or click Continue.

    2. Locate and then click the following registry subkey:

    HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New\

    3. Please check if the value for (Default) is: {D969A300-E7FF-11d0-A93B-00A0C90F2719}

    You can fix this problem from the Windows Registry.

    From the start menu, run regedit.

    Browse to the key: HKEY_CLASSES_ROOT\Folder\ShellNew

    If the key doesn't exist you can create it.

    Edit:

    Check your HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Folder it should be identical to the above mentioned registry key.

    It could also be a permissions issue. From command prompt try

    icacls C:\Users\USERNAME\Desktop /grant USERNAME:f /t

    Last but not least super registry key fix. Adds all of the folder keys (except for HKEY_LOCAL_MACHINE). included are:

    HKEY_CLASSES_ROOT\Directory\Background\shellex\ContextMenuHandlers\New

    HKEY_CLASSES_ROOT\CLSID\

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Tony_Tao Monday, March 20, 2017 8:42 AM
    Thursday, March 16, 2017 5:02 AM