none
Exchange 2010/2013/2016 convert outbound messages to plain text

    Question

  • We have an application that sends HTML messages and a single recipient will only accept plain text format.

    Can this be done native by Exchange or is there a utility that will do that?

    TIA

    Glyn

    Monday, July 3, 2017 11:11 AM

All replies

  • Hi,

    I trust if your particular recipient lives in Remote Domain execute following cmdlets 

    Get-RemoteDomain  -Identity xyz.com | fl
    Here look for ContentType property 

    There are three settings allowed here:

    • MimeHtml – converts messages to MIME messages that use HTML formatting, unless the original message is a text message. If the original message is a text message, outbound message will be a MIME message that uses text formatting.
    • MimeText – converts all messages to MIME messages that use text formatting.
    • MimeHtmlText – converts all messages to MIME messages that use HTML formatting.

    To set to to particular type use following cmdlet based upon your requirement 

    Set-RemoteDomain -Identity xyz.com –ContentType MimeHtmlText


    Aditya Mediratta


    Monday, July 3, 2017 11:25 AM
  • if this is only for single recipient and you can create that recipient as a contact in exchange then follow below:

    Create Mail contact

    User PowerShell cmdlet: Set-MailContact -Identity “contact name” - UseMapiRichTextFormat:$Never

    or from Console: 

    1. Go to Exchange Manager Console
    2. Go to Recipient Configuration
    3. Go to Mail Contact
    4. Select the Contact you want to Change to Text format.
    5. Right click on the Contact and select Properties
    6. Select the Dropdown box next to where it says "Use MAPI rich text format:  Choose Never
    7. Apply

    Monday, July 3, 2017 6:59 PM
  • Hi,

    Only one recipient? Internal recipient or external recipient? Did he receive other messages in plain text format? Perhaps he have setting on client sides to convert message into plain text format, for example:

    If that's external recipient and we have configured one mail contact for that recipient, check Message encoding options on this mail contact.

    Get-MailContact ContactName | Fl Format*

    More information about Message encoding options, refer to this document:

    https://technet.microsoft.com/en-us/library/bb310794(v=exchg.150).aspx#Message encoding options for mail users and mail contacts


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 4, 2017 2:28 AM
    Moderator
  • Thanks all for the replies, however none work.

    I cannot use a contact nor outlook. From an application that sends email in HTML format (can't be changed) to an SMS service provider which only accepts plain text email. The remote domain option is the only one i can use.

    I have tried setting the the contenttype to Mimetext and MimeHTMLText and mail sent to my Gmail test account arrives in HTML format.

    I am testing with Office 365. Any ideas please?

    If this is not possible, can anyone suggest a 3rd party utility to try instead?

    TIA

    Glyn

    Tuesday, July 4, 2017 9:44 AM
  • Hi,

    As you don't typically have gmail in your remote domain list so email arrives in HTML format . For particular change where your remote recipient lives , ensure it is part of remote domain and then try executing below cmdlet & look for ContentType property and make desired changes per Set-RemoteDomain !


    Get-RemoteDomain  -Identity xyz.com | fl

    Set-RemoteDomain -Identity xyz.com ContentType MimeHtmlText


    Aditya Mediratta


    Tuesday, July 4, 2017 10:27 AM
  • I THINK i have fixed it!

    I added this to the Powershell

    Set-RemoteDomain -Identity <Name> –ContentType MimeText

    Set-RemoteDomain -Identity <Name> –TnefEnabled $true

    AFAIK the email is now being sent in plain text.

    Thanks you all for the input

    Tuesday, July 4, 2017 10:28 AM
  • Good to hear we finally fixed the issue , kindly mark post as helpful / Proposed answer as you feel appropriate to allow other users to use this as reference :)

    Aditya Mediratta

    Tuesday, July 4, 2017 11:07 AM