locked
Data source question RRS feed

  • Question

  • Hi

    I have two data sources.
    1. Main data source
    2. TaskAssignmentHeader (SharePoint secondary data source) 

    I want to pull data from the secondary data source TaskAssignmentHeader and populate the form's Main data source by using the action (Set a field's value)  Is this possible?  
       
    Can I populate the form fields (Main data source) with data from secondary data sources?  Am I missing something?

    Thanks in advance for your help!

    smsemail

    Thursday, October 29, 2015 3:42 PM

Answers

  • Hi smsemail,

    Use rules to set the Main fields with the external data should work.

    I recommend to set the rules in Form Load or use Query foe data action before Set a field’s value to see if the issue still occurs.

    And set the default value of the Main field with secondary data source is also fine.

    There is no harm to set the default value.

    Best regards,

    Victoria


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, October 30, 2015 5:07 AM
  • As Victoria mentioned, there's no harm in using the default value. Not sure why pulling in the data using my method isn't working for you. You're basically doing the same thing using the default value.

    cameron rautmann

    Friday, October 30, 2015 12:08 PM

All replies

  • Hi sms- yes, you can do that. Add your data connection to receive data and choose your SP location. Set an action rule on the field to set the field's value. Change your data connection from "Main" to "Your new connection" and choose the field to get the value from.


    cameron rautmann

    • Proposed as answer by KRISHANA KUMAR Saturday, October 31, 2015 4:29 PM
    Thursday, October 29, 2015 3:59 PM
  • Thanks for your help Cameron.  I did what you suggested, however it is not pulling the data.  I found a way to capture the data. I used the default  value in the Text Box Properties and selected the field from the secondary data source.  It displays correctly.

    Is there any harm in using the default value.

    smsemail

    Thursday, October 29, 2015 9:20 PM
  • Hi smsemail,

    Use rules to set the Main fields with the external data should work.

    I recommend to set the rules in Form Load or use Query foe data action before Set a field’s value to see if the issue still occurs.

    And set the default value of the Main field with secondary data source is also fine.

    There is no harm to set the default value.

    Best regards,

    Victoria


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, October 30, 2015 5:07 AM
  • As Victoria mentioned, there's no harm in using the default value. Not sure why pulling in the data using my method isn't working for you. You're basically doing the same thing using the default value.

    cameron rautmann

    Friday, October 30, 2015 12:08 PM