locked
Automatic reply ( out of office) with picture RRS feed

  • Question

  • Hello,

    I like to insert our company logo (a small picture) in the auto reply (out of office). The only way I found, was to use a rule using a template:

    -> automatic replies (out of office)

    -> send automatic replies

    -> Rules ...

    -> Add rule

    --> Reply with

    --> Template

    --> Save & Close

    -> ok

    -> yes

    ->ok

    -> yes

    But unfortunately this rule is only working for internal mails, but I like to use it also for external incoming mail.

    Best regards.

    Alain.

    Saturday, November 23, 2013 9:12 AM

Answers

  • Hi Alain,

    I have tested per your steps in my environment, and insert a picture in the template. It works for both internal and external mails.

    I’d suggest you firstly verify the rule was also checked in the External autoreply setting as below:

    If it still doesn’t work, please test the issue with a template without picture and see if it works.

    Hope it can help to narrow down the issue.

    Regards,


    Rebecca Tu
    TechNet Community Support


    Monday, November 25, 2013 2:48 AM
  • Hello,

    So I've found the solution in other forum. There was a setting on the server:

    • Open Exchange Management Console
    • Expand Organization Configuration-> Hub Transport
    • In the right pane select the Remote Domains tab
    • Right click Default and choose Properties
    • Tab Message Format
    • Check box : Allow automatic replies

    Anyway thanks to Rebecca.

    Regards.

    Alain.

    Tuesday, December 3, 2013 12:04 PM

All replies

  • Hi Alain,

    I have tested per your steps in my environment, and insert a picture in the template. It works for both internal and external mails.

    I’d suggest you firstly verify the rule was also checked in the External autoreply setting as below:

    If it still doesn’t work, please test the issue with a template without picture and see if it works.

    Hope it can help to narrow down the issue.

    Regards,


    Rebecca Tu
    TechNet Community Support


    Monday, November 25, 2013 2:48 AM
  • Hello Rebecca,

    Many thanks for your feedback.

    First I've checked without a picture in the template. But it still not works for the external mails.

    So first I'm wondering that I need to check the box "Auto-reply to people outside my organisation" and to choose the option "Anyone outside my organisation".

    But anyway, I try your suggestion. First I get a message: "The auto-reply message for people outside your organisation cannot be blank"
    --> So I add a blank in the message for the "auto-reply outside my organisation".

    So now i receive a mail for the external mail. But the message is not the one from the rule, but from the "auto-reply outside my organisation". In others words I receive a blank mail.

    Any other ideas ?

    Regards.

    Alain.

    Monday, November 25, 2013 1:06 PM
  • Hello,

    Any idea ?

    Alain

    Tuesday, November 26, 2013 10:29 AM
  • Hi Alain,

    According to your description, I believe the OOF in your Outlook Client works but the user behavior causes the issue.

    I might not make myself clear, so I will show you what I did as below:

    1.File>Automatic Replies

    2.Check Send automatic replies>verify both internal and external autoreplies are enabled, I also checked Anyone outside my organization

    3.In the Inside My Organization tab>Rules...>Add Rule>Check Reply with>Template

    4.A new window for template came out>Insert>Choose a picture>Type the text in this template>Message tab>Save&Close

    5.The window closes, in the Edit Rule>OK>This rule will fire for all incoming messages. Is this what you want?>Yes

    6.Automatic Reply Rules>verify I have checked Show rules for all profiles, status is checked. > OK

    7.Then turn to Outside My Organization>Rules...>The same as Internal setting, and it's shown like the picture I posted above. >OK>It said the content cannot be blank, so I typed a space in it.

    8.Automatic Replies wizard>OK>A notification turns out to be An automatic reply message has not been entered and will prevent automatic replies from being sent. Automatic reply rules will work. Do you want to continue without an automatic reply message?>Yes> Another notification as You changed ...for people inside...Do you also want to change...outside...??Yes> OK

    10.Now a notification in your Outlook will display as Automatic Replies are being sent for this account.

    11.When I tested it with external mail, I received two autoreplies, but it didn't happen with internal account. One is the same as internal, the other is blank, I think it is caused by the step7 and it is inevitable by design.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Tuesday, November 26, 2013 12:32 PM
  • Hi Rebecca,

    Many thanks for your feedback again.

    I've done the same as you. But I still receive only the blank mail and not the mail with the template.

    May be, it's related to my version of client/server.

    We have exchange 2010 SP3 (Version: 14.03.0123.003).

    Our outlook version is 14.0.6023.1000

    Maybe there is hotfix somewhere regarding my versions ?

    Regards.

    Alain.

    Wednesday, November 27, 2013 7:53 AM
  • Hello,

    Any other idea ?

    Regards.

    Alain.

    Thursday, November 28, 2013 9:43 AM
  • Hi Alain,

    As far as I know, user behavior affects more than Outlook version on this case.

    However, I’d recommend another method using Inbox rule to set autoreply. Please have a try and see if it works.

    Here is the reference:

    1.Open the Rules and Alerts wizard.

    2.New Rule...

    3.Start from a blank rule--->Apply rule on messages I receive

    4.Step 1:Select condition--->sent only to me

    5.Next--->have server reply using a specific message, replace it with your custom autoreply information. Here you can insert the company logo into message.

    6.Specify a name for this rule.

    7.Finish

    Regards,


    Rebecca Tu
    TechNet Community Support

    Thursday, November 28, 2013 1:29 PM
  • Hi Rebecca,

    Thanks for your feedback.

    It's great, it's work. But I can only use, when my outlook is open.

    But the aim, is to be able to receive this automatic answer, when I'm out of office.

    Maybe there is something to set on the server side, to enable automatic answer with template ?

    Regards.

    Alain.

    Friday, November 29, 2013 7:07 AM
  • Hi Alain,

    So far I have introduced two method to set autoreply.

    The first method is to set Out of Office from server side. And it works in my lab environment, I have tested with my Hotmail account for times. So I suspect something improper from your side.

    The second is to set autoreply using Inbox rule. The rule is also applied on server side, the it will reply automatically even if you close the Outlook client.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Friday, November 29, 2013 4:19 PM
  • Hi Rebecca,

    Thanks again for you input.

    So if it works from the client side, and not on the server side, then as you said, something is wrong.

    But what can I check. Is there any parameter or registry entry on the server side to check.

    Best regards.

    Alain

    Monday, December 2, 2013 8:00 AM
  • Hello,

    Any other ideas ?

    Regards.

    Alain.

    Tuesday, December 3, 2013 10:53 AM
  • Hi Alain,

    Currently, we need to find out whether the OOF emails failed to be generated or it’s rejected by the remote email domain.

    I suggest we use SMTP log to confirm two things of the missing Autoreply generates from External rule: the message has been generated , the message has been delivered to the hub or edge server.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Tuesday, December 3, 2013 11:47 AM
  • Hello,

    So I've found the solution in other forum. There was a setting on the server:

    • Open Exchange Management Console
    • Expand Organization Configuration-> Hub Transport
    • In the right pane select the Remote Domains tab
    • Right click Default and choose Properties
    • Tab Message Format
    • Check box : Allow automatic replies

    Anyway thanks to Rebecca.

    Regards.

    Alain.

    Tuesday, December 3, 2013 12:04 PM
  • Hi Alain,

    Thanks for sharing the solution.

    Should you need more assistance, you are welcome to ask questions in this forum.

    Regards,


    Rebecca Tu
    TechNet Community Support

    Wednesday, December 4, 2013 2:03 AM
  • Hi All,

    I want to add picture on auto reply email. i have added but when I receive email it show me blank box in place of picture. is that true that i cannot add picture in Auto reply email only with exchange server 2010 I must have other alternative tool to do this ?

    Wednesday, September 30, 2015 6:10 AM
  • So-

    This message deals only with the OOO sending two messages, one blank, issue.  The above instructions seem to work well, otherwise.

    Following the instructions above I was able to send out an image in my OOO.  But I also noticed that two messages were being sent out.  1- My 'actual' OOO and 2. The 'rule' OOO (that contained the image.)

    The actual OOO was blank, because I deleted all the text in it, of course.  But I noticed that there were still some text characters in the message.  It was a couple of spaces left over.  If you completely clear the OOO box from all characters, spaces, etc., then, when you close all the windows, you should get a message that says "Your OOO is blank, so no message will be sent.  "Rules" messages will still be sent.  Is this what you want?"  - Or something like that.  Click "yes' or "ok" or whatever.  And so now when your OOO sends, it will send the rule message w/your image and NOT also your regular OOO message.  No double message.

     

    Hope that helps-

     

    -Jason

    Monday, December 21, 2015 4:52 PM
  • Another way around it is not using the OOO at all and just create a rule that any message sent to me have the server send a reply using a specific message and paste your message with pic there. It works inside and outside the organization with no double emails.
    • Proposed as answer by TomKov2 Thursday, February 9, 2017 3:00 PM
    Thursday, March 24, 2016 7:32 PM
  • Hi,

    In office 2013, Exchange Management Console is Exchange Management Center, right?

    because i couldn't find Exchange Management Console here.

    Could you help me, please.

    Thanks, 

    Sarbjeet Khosa

    Monday, June 13, 2016 9:23 AM
  • Hi There,

    I am facing issues with external emails.

    It says 'The auto-reply message for people outside your organization cannot be blank.'

    Any idea how to deal with this error? 

    Tuesday, April 25, 2017 2:20 PM
  • Hi,

    I have exactly the same problem, and this procedure above didn't change much. Do you need to restart services or something like that to make it effective?

    Basically I can send the out of office message using the rule, but I cannot save the configuration without entering some text in the tab for outside my organisation. Like Rebecca suggested above, 

    I get the usual message: "The auto-reply message for people outside your organisation cannot be blank"
    --> So I add a blank in the message for the "auto-reply outside my organisation".

    Now, when I save it and test sending a message from outside my organization, I receive 2 out of office messages: One coming from my rule+template, the other one coming with automatic subject "Automatic reply:<my subject>"

    and blank content. Clearly the autoresponder still send the blank space inserted in the outside my organisation tab.

    Did you fix that? Could you please help, thanks

    Wednesday, April 26, 2017 2:43 PM