locked
Agent install error with Windows 7 x64 Client RRS feed

  • Question

  • I have a problem trying to push install the agent to my one and only Windows 7 workstation. It is 64 bit business.

    The error report is not very enlightening, but here it is.

    The Operations Manager Server could not start the MOMAgentInstaller service on computer "FQDN" in the time.
    This service is used to perform configuration operations on the computer before the System Center Operations Manager agent can be configured.
    Operation: Agent Install
    Install account: DOMAIN\administrator
    Error Code: 80070102
    Error Description: (null)

    The SCE2010 server can ping the IP and FQDN of the Win7 machine.

    The Windows firewall was switched on on the Win7 machine. I switched it off for Domain and tried again. Same error.

    The agent log shows this;

    12:37:39 PM : CServiceModule::Init : m_bService is set to true HResult: 0
    12:37:39 PM : CServiceModule::Start : Service flag is set
    12:37:39 PM : CServiceModule::SetServiceStatus : State: 2, Error: 0
    12:37:39 PM : CServiceModule::SetServiceStatus12:37:39 PM :  : State: 2, Error: 0RegisterFile
     : Before LoadLibrary
    12:37:39 PM : RegisterFile : After LoadLibrary
    12:37:39 PM : RegisterFile : Before GetProcAddress
    12:37:39 PM : RegisterFile : After GetProcAddress
    12:37:39 PM : RegisterFile : After FreeLibrary
    12:37:39 PM : RegisterFile : Success return
    12:37:39 PM : RegisterFile : WaitForSingleObject return  HResult: 0
    12:37:39 PM : ConfigureWindowsFirewallExceptionForApp : AddRemoveAppForWindowsFirewallException failed: HResult: 8000ffff
    12:37:39 PM

    Do I need to totally disable the firewall to push the agent to Win7 x64?
    Tuesday, November 17, 2009 12:52 PM

Answers

  • Hi Ian,

    During agent installation, the Essentials server needs to be able to communicate with managed computers over the file sharing port (139 and 445) and the remote administration ports (135 and ports over 1024).  During Essentials configuration, you can enable these necessary Windows Firewall Exceptions if you configure Essentials to use Domain policy.  If you used Local policy, or have other host firewall software, you'll need to configure these port exceptions manually.

    Dustin
    Dustin
    • Proposed as answer by Stephanie Drenchen Tuesday, November 24, 2009 9:15 PM
    • Marked as answer by Yog Li Wednesday, November 25, 2009 10:47 AM
    Wednesday, November 18, 2009 4:35 PM

All replies

  • Hi Ian.  You don't need to totally disable the firewall.  Try opening port 5723.  Hope that helps.

    Pierre

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Tuesday, November 17, 2009 5:21 PM
  • I opened 5723 inbound and got the same error as above and same agent log.

    I switched off the firewall for all 3 connection types and got the same error.

    Read this blog; http://systemcentercentral.com/tabid/150/SortOrder/0/Days/7/SortDirection/2/tag/Blog/Default.aspx then stopped the firewall service and the agent installed correctly.
    Wednesday, November 18, 2009 2:04 PM
  • Hi Ian,

    During agent installation, the Essentials server needs to be able to communicate with managed computers over the file sharing port (139 and 445) and the remote administration ports (135 and ports over 1024).  During Essentials configuration, you can enable these necessary Windows Firewall Exceptions if you configure Essentials to use Domain policy.  If you used Local policy, or have other host firewall software, you'll need to configure these port exceptions manually.

    Dustin
    Dustin
    • Proposed as answer by Stephanie Drenchen Tuesday, November 24, 2009 9:15 PM
    • Marked as answer by Yog Li Wednesday, November 25, 2009 10:47 AM
    Wednesday, November 18, 2009 4:35 PM
  • Thanks for the info Dustin.

    I did configure essentials to enable the firewall exceptions, but I am pretty sure the Win7 box had not been rebooted since. So it won't have picked up the changes that enable the exceptions.

    Anyway, the info you have provided will be helpful when we roll out Win7 to the rest of the company and for anyone else having firewall issues of whatever variety.
    Thursday, November 19, 2009 10:02 AM
  • Hello Ian,

    For your reference, the following article discussed a similar issue for SCE 2007 SP1:

    EBS, SCE, Windows Server 2008 R2 and Windows 7
    http://blogs.technet.com/essentialbusinessserver/archive/2009/10/30/ebs-sce-windows-server-2008-r2-and-windows-7.aspx

    According to the article, SCE 2007 does not support deploying 64-bit Windows 7 clients through the Discovery Wizard (see the article for details).  The clients must be deployed manually.  The detailed steps can also be found in the article.

    I'm afraid SCE 2010 beta doe not resolve this issue yet. So you can also try the manul installation.

    Thanks,


    Yog Li - MSFT
    • Edited by Yog Li Friday, November 20, 2009 7:10 AM
    Thursday, November 19, 2009 10:53 AM
  • Please note that the above blog entry is specific to Essentials 2007 SP1.

    There should not be an issue with using the Discovery Wizard in Essentials 2010 to add Win 7 x64 agents to monitoring. Please let us know if Dustin's suggestion hasn't worked so that we can investigate further.

    Thanks

    Richard


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, November 20, 2009 12:41 AM
  • Please note that the above blog entry is specific to Essentials 2007 SP1.

    There should not be an issue with using the Discovery Wizard in Essentials 2010 to add Win 7 x64 agents to monitoring. Please let us know if Dustin's suggestion hasn't worked so that we can investigate further.

    Thanks

    Richard


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, November 20, 2009 12:50 AM
  • Please let us know if Dustin's suggestion hasn't worked so that we can investigate further.

    I have already got the agent installed by turning the Windows firewall off and then disabling the service.

    I do have SCE2010 running in domain mode and did tell it to enable the firewall exceptions.

    I will see if I have time today to fire up another VM and test it without shutting the Windows firewall down.
    Friday, November 20, 2009 9:37 AM
  • Thanks! We look forward to hearing the results of this attempt.

    Dustin
    Dustin
    Tuesday, November 24, 2009 11:47 PM