none
Company Portal App Windows 8 Phone RRS feed

  • Question

  • Hi, we have successfully deployed the Company Portal app to Windows Phone 8 devices. My question is about the way we are distributing it and also some strange lettering that appears on the Company app tile...

    1. We email an .aetx AET file to the user, who then clicks on the attachment on his/her phone and this adds the token to the phone - is this necessary/correct procedure?

    2. Once installed, the company portal app appears as a tile, all good, but it has the path printed on the tile: "C:\Data\Programs...." I am sure this is not supposed to be like this, how do I rename it to "My Company Name" or get rid of it?

    Thanks in advance!

    Paul

    Monday, February 4, 2013 12:25 PM

Answers

All replies

  • Hi Paul,

    When a user enrolls the device in "Company Apps" in settings on their phone, the Company Portal Application will be installed automatically.  It's not required to distribute it out via email or some other method.  This may be why you are experiencing problems.

    I would have users try that path first and see if the issue is resolved.

    Thanks,

    Jon L. - MSFT

    Monday, February 4, 2013 4:58 PM
    Moderator
  • Ok thanks for the response. So you are saying that it is not necessary to generate and then email a .aetx token to prospective Windows 8 Phone Company app "enrolees". Why all the documentation on this then? Specifically: http://msdn.microsoft.com/en-us/library/windowsphone/develop/jj735576(v=vs.105).aspx....

    My 2nd question, about the Path on the Comapny app tile on the Windows 8 Phone is still unanswered. There must be a parameter somewhere or perhaps part of a PowerShell script or some code in the "SPP.xap" file that places this patch writing on the tile?


    • Edited by bezza97 Tuesday, February 5, 2013 9:34 AM
    Tuesday, February 5, 2013 9:33 AM
  • Hi Guys,

    How did you get on with signing the company portal app with SignTool?

    I am using windows 8, and the latest version of Visual studio and the SDK for windows phone, but cannot seem to get SignTool to run. I Googled the issue and all the articles are outdated. I can find the exe for it in the program files but that doesn't run, the command windows flashes open then closes. And I cant find it in the programs themselves. This is the only thing holding me back from getting the app on our Win8 phones.

    How did you do it?

    Thanks in advance for any replies.

    Connor

    Tuesday, February 5, 2013 1:42 PM
  • Hi Connor, I feel your pain. Basically you have to run the powershell that comes with the SDK. After hours of googling and not a lot of help from the great MS, I came up with this:

    1. Download the Company portal app from the Intune portal onto a Windows 8 machine

    2. Install the Windows 8 Phone SDK onto the same Windows 8 machine

    3. Run the MSI. Nothing happens, but don't worry. It will have installed a "SSP.XAP" file. Search C: for this file. Rename it to "yourcompanyportal.xap"

    4. Download your .PFX certificate on to the same Windows 8 machine

    5. Go to C:\Windows\System32\WindowsPowerShell\v1.0, right click on Powershell.exe and select Run as Administrator

    6. Change directories to the MDILXAPCompile tools folder within the SDK:

    cd ‘C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v8.0\Tools\MDILXAPCompile\’

    7. Run BuildMDILXap.ps1. Use the below script, substituting "yourcompanyportal.xap", and the .PFX file name. (Might be easier to move the .XAP and .PFX file into the same directory as the script)

    .\BuildMDILXap.ps1 –xapfilename 'c:\temp\Provisioning\SimpleCompanyApp.xap' –pfxfilename 'c:\temp\companyappcert.p12' –password mypassword

    8. The PowerShell will have created a "new_mycompanyportal.xap" file. This is your signed Company Portal file. Upload this to Intune along with the .PFX Certificate.

    Your users will now be able to enroll and download/install the company portal App. On the downside, you may now be at the stage I am at in waiting for MS to help rename the Company Portal app tile from the messy: @C:\Data\Programs.... you'll see what I mean.

    Paul

    Tuesday, February 5, 2013 2:17 PM
  • Hi Everyone,

    Let me clear up the confusion and help you get on the right path.

    The Windows Intune Help page to start with for WP8 setup is here:  http://technet.microsoft.com/en-us/library/jj733640.aspx

    The signing process in Step 6, Part 6:

    To sign the Company Portal app, follow the instructions in the “Signing the XAP by using the XapSignTool tool” section in How to precompile managed assemblies and sign a company app. You must sign the Company Portal app with the Symantec enterprise mobile code-signing certificate that you obtained when you completed step 3b

    The link refers you to:  http://msdn.microsoft.com/en-us/library/windowsphone/develop/jj681686(v=vs.105).aspx

    The only process you need to perform on your XAP is the "XapSignTool" portion on that page.  Performing the steps that are  part of the "Precompile" section are not needed and causing the issues you are encountering.  Those steps are only for signing custom applications you are creating/building.

    For now, if you need immediate assistance in resolving these issues please contact our support team and we'll help to resolve your issue on a per case basis.

    Thanks,

    Jon L. - MSFT


    Tuesday, February 5, 2013 8:16 PM
    Moderator
  • Hi Jon, thanks for the reply. When we try the command, we just keep getting: Xapsigntool error: illegal characters in path

    We can't seem to overcome this.

    How do we contact the support team?

    Wednesday, February 6, 2013 12:24 PM
  • Hi,

    Did you open a support case?  It would be great if you could show the command line you are executing here.  If you do have a support case open, please list the SRX # and I'll take a look with the technician.

    Thanks,

    Jon L. - MSFT

    Wednesday, February 6, 2013 6:40 PM
    Moderator
  • Sure: SRX1195799328ID

    The command line is:

    Open VS2012 x86 Native Command prompt as Administrator.

    set path=%path%;"%ProgramFiles(x86)%\Microsoft SDKs\Windows Phone\v8.0\Tools\XapSignTool"

    Then:

    XapSignTool.exe sign /f c:\temporary\certificate.pfx /p 888888 c:\temporary\ssp.xap

    XapSignTool error: illegal characters in path

    We have tried quotes, with/without, removing spaces etc... the password of the certificate is in numbers.

    Thanks

    Wednesday, February 6, 2013 8:44 PM
  • Can you drop the SSP and PFX into the XAP Sign tool directory.

    Then open a standard command prompt in Administrator mode, navigate to that folder and run the same command without the c:\temporary\

    Trying to eliminate the path as the issue.

    Thanks,

    Jon

    Wednesday, February 6, 2013 11:14 PM
    Moderator
  • Tried this just now, same result:

    XapSignTool error: illegal characters in path

    Wednesday, February 6, 2013 11:35 PM
  • Hi,

    Can you copy signtool.exe into the xapsigntool folder and retry?

    It usually lives in C:\Program Files (x86)\Windows Kits\8.0\bin\x86

    Thanks,

    Jon L. - MSFT

    Thursday, February 7, 2013 12:11 AM
    Moderator
  • Maybe stupid idea, but don't these % signs count as illegal characters in path?
    "set path=%path%;"%ProgramFiles(x86)%\Microsoft SDKs\Windows Phone\v8.0\Tools\XapSignTool"

    Thursday, February 7, 2013 8:38 AM
  • Same issue here with the @C:\Data\Program naming of the Company Portal

    I signed it using the PowerShell script as using the XapSignTool directly was giving me the same problem with the illegal characters.

    I'll try moving the various exe's into the same folder and try again and let you know.

    Cheers,
    SB


    My System Center Blog

    Thursday, February 7, 2013 10:59 AM
  • Nope, stripped everything out, waited an hour, put everything back in again with a newly signed portal and still the same.

    Signing via the PowerShell script or directly with XapSignTool makes no difference in my case.

    Any more ideas anyone?

    Regards,
    SB


    My System Center Blog

    Thursday, February 7, 2013 1:37 PM
  • Hi all,

    You cannot sign the certificate with the powershell script. (the two processes live on the same page, but are used for different purposes)

    Using the XAPSIGNTOOL Process is the only proper way to sign the SSP.

    If you are still encountering issues with signing the file I would request that you open a support request so we can investigate.

    Thanks,

    Jon L. - MSFT

    Thursday, February 7, 2013 4:25 PM
    Moderator
  • Hi Jon,

    I've raised a ticket (1196044312) I'll wait and see what happens.

    Regards,
    Steve


    My System Center Blog

    Thursday, February 7, 2013 5:15 PM
  • I didn't know about XAPSIGNTOOL, I used SignTool and successfully signed the xap file but I was now trying to figure out how to deploy the xap to a windows phone 8.  Here is the command I used

    signtool sign /f "c:\CodeSigning\CodeSigning.pfx" /p somePassword "c:\Program Files (x86)\Microsoft Corporation\Windows Intune Company Portal
    for Windows Phone 8\SSP.xap"

    Is that incorrect?  For references, I used MakeCert to create a selfsigned code signing cert.  I read elsewhere on this forum that someone signed the .msi file instead?

    Thursday, February 7, 2013 8:17 PM
  • I didn't know about XAPSIGNTOOL, I used SignTool and successfully signed the xap file but I was now trying to figure out how to deploy the xap to a windows phone 8.  Here is the command I used

    signtool sign /f "c:\CodeSigning\CodeSigning.pfx" /p somePassword "c:\Program Files (x86)\Microsoft Corporation\Windows Intune Company Portal
    for Windows Phone 8\SSP.xap"

    Is that incorrect?  For references, I used MakeCert to create a selfsigned code signing cert.  I read elsewhere on this forum that someone signed the .msi file instead?

    You need to use a Symantec Cert, a self-signed code signing cert isn't supported. 
    Thursday, February 7, 2013 9:54 PM
    Moderator
  • Hi Jon,

    I've raised a ticket (1196044312) I'll wait and see what happens.

    Regards,
    Steve


    My System Center Blog

    Hi Steve,

    Do You have response?

    I've same issue (xap signed with xapsigntool.exe)

    Tuesday, February 12, 2013 1:50 PM
  • Hi Jeniffer,

    Yes I do, just not sure if I'm allowed to publicly state the problem yet, but it's not just us doing something wrong.
    I'll check in with them tonight and feedback asap.

    Just out of interest, what language is your Win8 Phone running?

    Regards,
    Steve


    My System Center Blog

    Tuesday, February 12, 2013 4:33 PM
  • Hi @ll,

    it's good to see that at least somebody managed to upload their signed ssp.xap to intune. I'm still struggling with the initial installation during enrollment.

    I've uploaded it to intune using the setup tool I should use when I add software. I've selected the installed ssp.xap and provided my signing certificate from Symantec. This tool will take care for me to sign the XAP before it is uploaded to Intune, so there is no need to sign with the PowerShell script.

    Only if you want to upload your own apps, you will need to sign it beforehand with the PowerShell script. At least this is my understanding.

    Best regards

    Markus

    Wednesday, February 13, 2013 3:37 PM
  • Hi all,

    The issue Steve is referring to is related to phones that are set to "English" for the language (English UK).  When set to that language, the SSP application name appears as shown in the graphic above.  We are investigating a fix for this issue, but in the meantime you can workaround this by setting your phone to English - US.

    If you are having issues with the SSP installing on your device after enrollment please open a support case so we can investigate as this is probably a different issue.

    Thanks,

    Jon L. - MSFT

    • Proposed as answer by Jeniffer345_34 Wednesday, February 13, 2013 8:31 PM
    Wednesday, February 13, 2013 4:55 PM
    Moderator
  • Hi, all,

    I'm the PM on the company portal team and we have determined the root cause. If the phone is set to a language we don't specifically support, we should fall back to US English. That's working for the app itself but not for the title string in the list of apps, or on the Live Tile if the user pins it to start. We don't have a specific set of loc strings for UK English for this product (for some products we do) so it should just show the US English title but instead it's looking for a string in a UK resource file that doesn't exist. You might also see this for example in Portuguese because we localize to Brazilian Portuguese not European Portuguese. Brazilian will work fine but the other will show the path.

    Thank you for bringing it to our attention! We're working on it.

    Cathy

    ps: you shouldn't see this issue with any of the languages listed belwo but if you do, please let us know

    Chinese (Simplified)

    Chinese (Traditional)

    Czech - Czech Republic

    Danish - Denmark

    Dutch - The Netherlands

    English - United States

    Finnish - Finland

    French - France

    German - Germany

    Greek - Greece

    Hungarian - Hungary

    Italian - Italy

    Japanese - Japan

    Korean - Korea

    Norwegian (Bokmål) - Norway

    Polish - Poland

    Portuguese - Brazil

    Romanian - Romania

    Russian - Russia

    Spanish - Spain

    Swedish - Sweden

    Turkish


    Cathy Moya PM, Windows Intune/System Center Configuration Manager

    This posting is provided AS IS with no warranties and confers no rights.


    • Edited by Cathy MoyaMicrosoft employee Wednesday, February 13, 2013 5:11 PM hadn't updated my sig line in a while - now it shows my current group
    • Proposed as answer by Jeniffer345_34 Wednesday, February 13, 2013 8:31 PM
    Wednesday, February 13, 2013 5:08 PM
  • Hi,

    yes switch from UK to US resolved my issue.

    Jon, I redeployed same signed xap to SCCM (together with pfx) and Company portal has started deploying.

    One new Q: (outside this tread)

    We use SCCM + Windows Intune conector + ADFS + Dirsync as SSO, but always when I start Company app I need auth on our sts (via form-base auth)

    Is it possible to turn-off adfs form-base auth? (because form base auth can't remember username/password)

    Thanks 

    Wednesday, February 13, 2013 8:30 PM
  • Deleted
    • Proposed as answer by SimmoLeigh Wednesday, April 1, 2015 1:22 PM
    Thursday, February 14, 2013 12:19 AM
  • I have the same issue with SSO. It makes the company portal app a bit 'clunky' to use. Does this need to be set to use forms auth though? Haven't had chance to test other configurations on our TMG server yet but was going to see if another auth type would work.
    Thursday, February 14, 2013 8:06 AM
  • I'm not sure if this will ease the SSO experience as I haven't got adfs setup in my lab to test but it may.

    There is a new login experience on its way for the Intune admin console & the company portals.

    You can sign up for a look/test before the March release here:

    https://login.microsoftonline.com/optin.srf

    Regards,

    Steve


    My System Center Blog

    Friday, February 15, 2013 10:09 PM
  • Steve, new login behaviour doesn't help. (It isnt about SSO. Only one benefit I see is - you don't need click to auth redir when you use sso. It happens automaticaly)

    When I changed auth type order in web.conf ADFS from integrated,forms,tls,basic to integrade,basic,forms,tls browser can save password and formbase auth doesnt show.    but Company portal stops respond and in IIS logs is 302 error.

    Company Portal looks like ver 0,0001 alpha not 4.0 :)


    Sunday, February 17, 2013 10:11 PM
  • Paul, today we released an updated version of the company portal app to the Microsoft Download Center. You can find it here:

    http://www.microsoft.com/en-us/download/confirmation.aspx?id=36060

    It's the same DL page as before, but the version you want is 2.0 and the file name is WPSSP.exe, not WPSSP.msi. I don't know if there are any replication lags or other delays in content propgation but I can see it updated from Redmond.

    To upgrade to the new version, please see this updated documentation:

    http://technet.microsoft.com/en-us/library/jj733640.aspx

    If you run into any issues with the updated file, please post here and I'll automatically get an email alert.

    Thanks for your patience,


    Cathy Moya PM, Windows Intune/System Center Configuration Manager This posting is provided AS IS with no warranties and confers no rights.


    Tuesday, March 5, 2013 12:58 AM
  • Brilliant, thanks Cathy and MSFT for turning around a solution so quickly.

    My System Center Blog

    Tuesday, March 5, 2013 12:36 PM
  • For anyone getting the "illegal characters in path" error from XapSignTool when trying to sign the Company Portal app, I might have a solution. I tried the mrasmussen's suggestion of just signing with SignTool and while it didn't give me any errors, it failed to install on a device. I could go through the enrollment up to the point where you actually install the app, but when it tried to do the install it would fail with a generic "error installing application" type error.  This is what appears to have done the trick for me (it works in the emulator included with the SDK, but I still need to test on real hardware.):

    1) Copy your .pfx file and the ssp.xap file from the Company App installer to C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v8.0\Tools\XapSignTool

    2) Open the "VS2012 x86 Native Tools Command Prompt" as Administrator

    3) cd to C:\Program Files (x86)\Microsoft SDKs\Windows Phone\v8.0\Tools\XapSignTool (or the equivalent if you installed the SDK in a different spot).

    Hi, Chad (and anyone else having this problem)

    Ironic that I was getting the same error when I was trying to sign the xap with a cert I got from a tester. I Binged the error and found the part of this thead I ignored before when addressing the loc issue we fixed.

    I used Chad's procedure and it worked, and then pinged the writer for the MSDN topic that walks you through signing. (http://msdn.microsoft.com/en-us/library/windowsphone/develop/jj681686(v=vs.105).aspx)

    He was able to repro the error using the standard command prompt in some cases, but it consistently works right using the VS2012 x86 Native Tools Command Prompt. He's going to change the MSDN topic to tell people to use the VS2012 x86 Native Tools Command Prompt, instead of leaving it optional.

    And if you don't know how to start the VS2012 x86 Native Tools Command Prompt, go to the Start screen in Windows and type “VS2012 x86 Native Tools Command Prompt”.

    Hope that helps!


    Cathy Moya PM, Windows Intune/System Center Configuration Manager This posting is provided AS IS with no warranties and confers no rights.

    Thursday, March 21, 2013 6:40 PM