locked
Dual Monitor setup, secondary monitor keeps sleeping. RRS feed

  • Question

  • I had been using a dual monitor setup in Windows XP with no problems. I have recently upgraded to Windows 7 Home Premium (with new Graphics card), and since have been unable to prevent the secondary monitor from sleeping. It will sleep after 10 or so minutes when the computer is active or not. I have tried using extended desktop and duplicate with no success. I can "recover" the second monitor by switching from extended to dupicate or visa versa, however it continues to sleep after the usual time period.

    I am using a Gigabyte geforce 560 with 2 DVI ports.

    I have set all of the sleep settings to the 'Never' option. I have disabled the motherboard's onboard video. I am running out of things to try.

    Any help is appreciated.

     

    Wednesday, December 28, 2011 5:23 AM

Answers

  • Yes, I tried that previously, "Interestingly, after I made the problem monitor (Asus) the "primary" it started sleeping much faster than before".

    As it turns out when I removed the Asus to try on another machine it failed to power up at all. So my guess is the Asus is on it's way out. I've sinced started using an old 4:3 monitor and have no problems since. Seems the culprit has been found.

    Thanks for the help.

    • Marked as answer by Barry20 Monday, January 2, 2012 2:14 PM
    Monday, January 2, 2012 2:14 PM

All replies

  • Hi,

    According to your description, it seems a driver problem. Please update your display card driver for a test first.


    Juke Chou

    TechNet Community Support

    Thursday, December 29, 2011 7:08 AM
  • Thanks, yes I did try downgrading the nvidia drivers to the one supplied with the card, however that had no effect, I have since reinstalled the current drivers, still no luck.
    Thursday, December 29, 2011 9:49 AM
  • Hi

    It may be worth swapping the monitor connections to see if it occurs with one of the DVI ports or the monitor itself.

     

    Otherwise, check the nView is setting up the monitors correctly.  I have seen this issue where windows was showing the extended desktop, but nView was showing montors  as 1 & 2 instead of Dual-view.

    Andy

     

     

    Thursday, December 29, 2011 11:50 AM
  • Hi Andy, thanks for the advice. I tried swapping the cables over with no real difference, the monitor indentity switched to the reverse, however the monitor continued to sleep after a short time.

     

    Interestingly, after I made the problem monitor (Asus) the "primary" it started sleeping much faster than before, ie. after a few seconds. So the problem seems to be the relationship between the OS and this particular monitor, at a guess.

    Just some further information for the case;

    Monitor 1: Acer AL2216W

    Monitor 2: Asus MW221C (problematic)

    Video Card: Gygabyte GTX560 GV-N56GOC-1GI

    Friday, December 30, 2011 6:50 AM
  • Hi,

    Does this occur under Safe Mode? You may also try to insert Windows 7 Installation Disk and Boot into Windows PE for a while and see whether this is caused by OS.


    Juke Chou

    TechNet Community Support

    Friday, December 30, 2011 7:01 AM
  • I tried safe mode, but could not get dual view working at all, (no second monitor), do you have a guide or instructions on how to get that working?

    I am going to try the monitor on a different machine and see how that works.

    Saturday, December 31, 2011 3:23 AM
  • Hi,

    Yes, because the display driver have not been loaded in Safe Mode. Please set the problematic monitor as your screen, then check whether the issue still occurs. This will eliminate hardware cause.


    Juke Chou

    TechNet Community Support

    Monday, January 2, 2012 1:55 AM
  • Yes, I tried that previously, "Interestingly, after I made the problem monitor (Asus) the "primary" it started sleeping much faster than before".

    As it turns out when I removed the Asus to try on another machine it failed to power up at all. So my guess is the Asus is on it's way out. I've sinced started using an old 4:3 monitor and have no problems since. Seems the culprit has been found.

    Thanks for the help.

    • Marked as answer by Barry20 Monday, January 2, 2012 2:14 PM
    Monday, January 2, 2012 2:14 PM