locked
Wallpaper deployed trough a msi package not working properly RRS feed

  • Question

  • So, the msi package is something like this: 

    • A bmp file copied directly in C:\Windows
    • The registry: HKCU\Control Panel\Desktop\Wallpaper = "reference to the bmp file"
    • And an Active Setup registry in HKLM that starts the selfhealing process at logon so the CU registry is applied for each user.

    Theres one interesting problem that occurs only if I do the next steps before installing the package.

    First of all, I set Windows Theme to the default Aero theme and after that I`ll go in Control Panel\All Control Panel Items\Personalization\Desktop Background, browse for a local folder containing some wallpapers and the options Change picture every: 30 minutes; Shuffle: Checked before I hit Save Changes.

    After this settings are made I install the package and log-off. I log-on with the same user and the wallpaper installed trough the msi file appears, but it appears for 5  to 10 seconds. After that the wallpaper is changed. 

    I`m sorry for my poor english and if I posted in the wrong forum. Does anyone know why is this happening? I also tried with a modified package that had the registries: 

    HKCU\Software\Microsoft\Internet Explorer\Desktop\General\WallpaperSource = "reference to the bmp file" ; 

    HKCU\Control Panel\Personalization\Desktop Slideshow\Shuffle = 0 added. 

    Tuesday, February 12, 2013 3:46 PM

Answers

  • Found the problem.

    I needed to remove the file slideshow.ini from %APPDATA%\Microsoft\Windows\Themes.

    • Marked as answer by Ionuț Maxim Wednesday, February 13, 2013 11:46 AM
    Wednesday, February 13, 2013 11:46 AM

All replies

  • Found the problem.

    I needed to remove the file slideshow.ini from %APPDATA%\Microsoft\Windows\Themes.

    • Marked as answer by Ionuț Maxim Wednesday, February 13, 2013 11:46 AM
    Wednesday, February 13, 2013 11:46 AM
  • Hi,

    Glad to hear the issue was resolved.


    Tracy Cai
    TechNet Community Support

    Thursday, February 14, 2013 3:31 AM