none
IE9 Disable AutoComplete for Forms Registry Setting (where is it?) RRS feed

  • Question

  • I have tried with no success to use GP to consistently force Disable AutoComplete for forms (User Configuration\Administrative Templates\Windows Components\Internet Explorer).

    Using GPResult, some workstations show "disabled" when the setting is actually "enabled" through GP. 

    I am now pursuing a registry edit to force this to my workstations consistently (key word; consistently). Does anyone know the correct registry key for IE9 on a Windows 7 Pro (64 bit OS)? I've tried about five so far and none of them work. 

    So far, I've tried:

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\AutoComplete]
    "Append Completion"="no"

    HKCU\Software\Microsoft\Internet Explorer\Main\WindowsSearch\AutoCompleteGroups REG_DWORD "0"

    and a few more I forget... 

    I am supposing that a Microsoft support person will be the only one(s) in the know for this one but please help if you can! 



    Charlie Newman

    Wednesday, May 28, 2014 7:33 PM

Answers

  • Hi,

    As we all know we can disable AutoComplete throung IE settings. While if you want to disable them through Registry, it would be better to use Regshot to caputer registry modifing after this setting changed in IE.

    I made a test in my test enviroment, there are some other volume and key modified, also contains:

    Eg:

    HKU\S-1-5-21-4145364215-115882434-1782034342-500\Software\Microsoft\Internet Explorer\Main\Use FormSuggest: "yes"

    Please make a capture in your system.


    Roger Lu
    TechNet Community Support

    Thursday, May 29, 2014 3:01 AM
    Moderator

All replies

  • The thread to disable auto complete should be "AutoSuggest"="no"

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]    
    "FormSuggest Passwords"="no"    
    "FormSuggest PW Ask"="no"    
    "Use FormSuggest"="no"
    
    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\WindowsSearch]    
    "AutoCompleteGroups"=dword:00000000    
    "EnabledScopes"=dword:00000000
    
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoComplete]
    "AutoSuggest"="no"

    Change these 3 different keys.  I would change this with a GPO if you have many users.

    Wednesday, May 28, 2014 7:48 PM
  • I have tried using GPO. It is not consistent. The GPO was modified to enable the setting after the initial release. If a user had a local profile prior to the GPO setting change, the setting will NOT take affect even if you run GPUpdate /force.

    Also, your setting(s) do not work either. The actual user registry entries in HKey_Users will override these settings everytime. I have accepted this as something that is an IE9 anomaly that simply cannot be changed consistently through Group Policy or by a registry key push.

    Thanks anyway!


    Charlie Newman

    Wednesday, May 28, 2014 9:14 PM
  • Hi,

    As we all know we can disable AutoComplete throung IE settings. While if you want to disable them through Registry, it would be better to use Regshot to caputer registry modifing after this setting changed in IE.

    I made a test in my test enviroment, there are some other volume and key modified, also contains:

    Eg:

    HKU\S-1-5-21-4145364215-115882434-1782034342-500\Software\Microsoft\Internet Explorer\Main\Use FormSuggest: "yes"

    Please make a capture in your system.


    Roger Lu
    TechNet Community Support

    Thursday, May 29, 2014 3:01 AM
    Moderator