locked
Unable to disconnect iscsi target from iscsi initiator RRS feed

  • Question

  • Hi,

    I have discovered an iscsi target which I created in my NAS device, using Microsoft iSCSI initiator in windows 8.  I just connected the target in initiator.

    But I am unable disconnect a particular target from MSiSCSI initiator (windows 8), but in windows 7 I am able to disconnect.

    It is saying that  "The session cannot be logged out since a device on that session is currently being used."

    Please give the solution, whether this is really a problem with windows 8 iscsi initiator or any changes had happened in windows 8 from windows 7?

    Thanks.

    Friday, April 26, 2013 8:25 AM

All replies

  • This issue can be caused by device that is not compatible. However you can disconnect it from Device Manager.

    http://blog.moonflare.com/2011/06/28/cleanly-disconnecting-an-iscsi-disk/


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, April 29, 2013 9:38 AM
  • Hi,

    Thanks for your reply. I tried making the device offline from Device manager, still the problem exists.

    Also tried deleting the targets from Favorite Targets. It doesn't solve the issue.

    Please let me know if any other solution is there.

    Thanks.

    Tuesday, April 30, 2013 7:06 AM