none
Project Server 2010 Project Workspaces and Trusted Locations RRS feed

  • Question

  • Project Server 2010 Question: On countless occasions, our users receive an Excel Services trusted location error message, which prevents them from opening files from the Project Workspace Libraries. Our SharePoint Tech says that each Project Workspace needs to have its libraries configured in the trusted file location after the PM creates the workspace. This cannot be the answer to prevent this error, it would mean a huge maintenance committment. What is the solution?
    Thursday, November 1, 2012 1:19 PM

Answers

  • Hi there,

    If you are only trying to open these files in excel then there is no need to add the trusted file location in Excel Services! Just hover over the file, click Edit in Microsoft Excel from the drop down menu...

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    • Marked as answer by Lmzwatkins Thursday, November 1, 2012 8:58 PM
    Thursday, November 1, 2012 1:58 PM
    Moderator
  • The site will use the default server setting which is open in browser when possible, you can change this on the Doc library settings, navigate to the doc library, click Library Settings > Advanced Settings > check "Open in the client application" in the the Opening Documents in the Browser section.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    • Marked as answer by Lmzwatkins Thursday, November 1, 2012 9:40 PM
    Thursday, November 1, 2012 9:11 PM
    Moderator

All replies

  • Hi there,

    Your SharePoint tech guy is correct if you want to open these excel files in excel services. Can the Excel files be stored in a central place such as the BI center rather than on each project site?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, November 1, 2012 1:28 PM
    Moderator
  • Our users are not trying to open the files in Excel Services, just MS Excel. These are simply uploaded documents on the project workspace, no different than MS Word or PowerPoint. This is a serious issue if you cannot upload Excel files to a project site, and a possible show stopper for our organization using Project Server. Should we open an M$ support ticket for a better resolution. Adding every project site manually to a trusted file location is not an acceptable option.
    Thursday, November 1, 2012 1:50 PM
  • Hi there,

    If you are only trying to open these files in excel then there is no need to add the trusted file location in Excel Services! Just hover over the file, click Edit in Microsoft Excel from the drop down menu...

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    • Marked as answer by Lmzwatkins Thursday, November 1, 2012 8:58 PM
    Thursday, November 1, 2012 1:58 PM
    Moderator
  • I agree with Paul,this has nothing to with excel services configuration. Have you tried uploading and opening  excel files from other sharepoint sites?


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Thursday, November 1, 2012 6:33 PM
    Moderator
  • So unlike other objects loaded in the SharePoint site, you cannot click the file name that is a link to the object because for some reason something is triggering the notion that the user wants to open the file in Excel Services. I cannot believe that this is by design. I wonder if something was installed incorrectly. In the meantime, I will instruct the users to use Edit in Excel in the drop menu. Thanks for you help Paul!
    Thursday, November 1, 2012 8:58 PM
  • The site will use the default server setting which is open in browser when possible, you can change this on the Doc library settings, navigate to the doc library, click Library Settings > Advanced Settings > check "Open in the client application" in the the Opening Documents in the Browser section.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    • Marked as answer by Lmzwatkins Thursday, November 1, 2012 9:40 PM
    Thursday, November 1, 2012 9:11 PM
    Moderator
  • SWEET!! Thanks Paul!
    Thursday, November 1, 2012 9:40 PM
  • Assuming that you are creating the Project Sites in the PWA site collection, then you simply need to set the Trusted file location to http://<servername>/pwa

    This will trust all locations in the site collection. You don't mention whether these are using Data Connections. Setting trusted data connections is best contained to specific locations.


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Friday, November 2, 2012 1:03 PM
    Moderator