none
DPM 2010 and Anonymous SMTP Broken? RRS feed

  • Question

  • Hello,

    I'm evaluating DPM 2010 in a testing environment and am in the middle of setting up the SMTP settings. The trouble is with the "Authenticated SMTP Server" settings.

    I am using Exchange that accepts anonymous SMTP connections from certain IP addresses on the internal network (the DPM server IP is in this list) so I don't need to put any details in here however, when I leave these blank and click "Send Test Email" I receive "Error ID 2013: Logon failure: unknown user or bad password" immediately and if I put junk credentials in and click "Send Test Email" I get a dialogue box where I can put the recipient email address in. Putting a valid email address in here I still get the same error message. Additionally the tool-tip for these fields is the same as the tool-tip for the "SMTP Server Name:" field, which is just wrong.

    The SMTP settings seem to be somewhat broken, I can't keep the username and password for the "Authenticated SMTP Server" blank and when I put junk credentials in, it still doesn't work - this is for anonymous SMTP!? I just want to get a sanity check on this because I can't understand why this dialogue box has been implemented the way it has. There isn't this trouble with DPM 2007, which is set up in the same way with regards to the SMTP and does not have these issues, I don't know why this needed to change.

    I know the Exchange side is fine and accepting annonymous connections from the DPM server as I've done an SMTP email send using telnet from the DPM server. Anyone have any ideas?

    Sunil

    Wednesday, December 1, 2010 2:24 PM

Answers

  • run regedit and find
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Notification\
    export this regkey first (for backup purposes).

    Then delete the two following entrys:
    SmtpPassword
    SmtpUserName

    now it works again without SMTP Auth.

    in future: never click into the Username or password field in DPM Options GUI

    • Proposed as answer by MC-FSP Friday, December 3, 2010 3:14 PM
    • Marked as answer by Sunil-Spiral Wednesday, February 2, 2011 9:43 AM
    Friday, December 3, 2010 3:09 PM

All replies

  • Try using a username and password of  a user that has administrator privileges on the DPM server.
    Thursday, December 2, 2010 1:44 PM
    Moderator
  • This does not sound like anonymous SMTP - why is there the requirement to use credentials? My though process is:

    If DPM uses these credentials to connect to SMTP then that means I am sending a plain-text username and password for someone that has administrative access to the DPM server across the network to the SMTP server, often. No - that's insane, they couldn't possibly have made it that bad and it's not anonymous SMTP.

    If DPM requires the credentials to enable itself to send email but doesn't actually use these credentials when connecting to the SMTP then why does it need another set of credentials on top of the service account/whatever it makes for itself when it installs.

    Finally, whether a domain or username account is required, I now have to remember that every time the email alerts stop coming through, it's becuase the password for the user has expired and I have to go an manually change it.

    It doesn't look good either way.

    Friday, December 3, 2010 10:58 AM
  • I do understand your thought process and this is an issue that our product team is aware of and the current workaround is to enter the domain\username and password under the Authenticated SMPT Server section of the SMTP options page. 

    Enter Username and Password of User who have administrator privileges on the DPM server. Otherwise you will receive the following error:

     An Authentication error occured when trying to connect to the SMTP server. (ID: 518)

    You typed an incorrect user name, password, or SMTP server name. Type the correct user name and password to enable e-mail delivery of reports and alerts notifications.

     

    Friday, December 3, 2010 1:21 PM
    Moderator
  • run regedit and find
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Notification\
    export this regkey first (for backup purposes).

    Then delete the two following entrys:
    SmtpPassword
    SmtpUserName

    now it works again without SMTP Auth.

    in future: never click into the Username or password field in DPM Options GUI

    • Proposed as answer by MC-FSP Friday, December 3, 2010 3:14 PM
    • Marked as answer by Sunil-Spiral Wednesday, February 2, 2011 9:43 AM
    Friday, December 3, 2010 3:09 PM
  • Thanks - I'll try the Registry change and see if that sort it out.

    Sunil

    Friday, December 3, 2010 6:54 PM
  • It took me a while to get round to it but "resetting" the SMTP settings via regedt I think solved the problem.

    Anonymous SMTP shouldn't require any details to be entered, especially the administrative credentials of the DPM server. I can't imagine how this got through sanity checking. I'm glad this is being fed back to the product team and that they may be working on correcting this.

    Sunil

    Wednesday, February 2, 2011 9:48 AM
  • This registry fix is not working for us. We use a third-party product for SMTP relaying and this is very frustrating to see broken. KB2020373 does not work either.

    -Brian

    Saturday, February 11, 2012 12:32 AM
  • STILL BROKEN IN SCDPM 2012 SP1 - Are monkeys doing the job in the SCDPM Dev-Team?
    Monday, August 5, 2013 12:11 PM
  • Wow - we haven't upgraded, but I can't believe something as basic as this is still an issue three years after it was originally reported.

    Tuesday, August 6, 2013 11:48 AM
  • I ran into this problem (again), and since we don't have Exchange anymore, was looking for another solution.

    Someone posted a solution by putting a simple " " (space) character in the Username and leave the password empty.

    It works. I think it is worth mentioning it. :)

    The Username-is-emtpy check is probably a different one than the one that checks whether authentication is needed, with this configuration DPM doesn't try to login with a space, it just uses anonymous authentication.

    Robin


    Thursday, August 29, 2013 6:56 AM
  • Hmm,... I have to come back from the simple space " " solution. The Test e-mail function works this way. But when your DPM fails you don't get a mail....

    So it doesn't work.

    Wednesday, September 4, 2013 7:43 AM