none
Sharepoint 2016 Fresh Install. WFE, DB server. The Topology service is not available in the farm.

    Question

  • Running install on web server select web front end the rest is automated.

    2 servers
    -wfe - running the installer
    -database - service account has access to master database and everything else.

    Monday, March 20, 2017 11:30 PM

All replies

  • Hi Sequii, this happens because the SharePoint farm isn't configured in a supported topology.  Just having a WFE is insufficient for SharePoint to run properly.

    See the Planning for a MinRole server deployment in SharePoint Server 2016 article on TechNet for details.  Specifically:

    • The "MinRole Topologies" section, which describes the different types of farms and the server roles required for each of those farms.
    • The "Deploying services" section, which warns against trying to create service applications until you've deployed a minimum supported farm topology.

    If you want to have SharePoint running on only one server in your farm, you should select the Single-Server Farm server role instead of the Front-end server role.  You can convert your existing server to a different server role via the SharePoint Central Administration -> System Settings -> Convert server role in this farm page.

    - Troy Starr [MSFT]

    Tuesday, March 21, 2017 1:31 AM
  • Thanks Troy - Exactly what I needed!

    Joseph Quintero

    Tuesday, March 21, 2017 3:37 PM
  • Please marked thread as "answered" if Troy's answer really fix the issue. thanks.
    Thursday, March 30, 2017 4:05 PM
  • Hi Sequii, 

    Please remember to mark the reply as an answer if it helps. 

    Have a nice day!

    Best Regards, 

    Lisa Chen 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, April 07, 2017 1:17 AM
    Moderator